Main Restorations Software Audio/Jukebox/MP3 Everything Else Buy/Sell/Trade
Project Announcements Monitor/Video GroovyMAME Merit/JVL Touchscreen Meet Up Retail Vendors
Driving & Racing Woodworking Software Support Forums Consoles Project Arcade Reviews
Automated Projects Artwork Frontend Support Forums Pinball Forum Discussion Old Boards
Raspberry Pi & Dev Board controls.dat Linux Miscellaneous Arcade Wiki Discussion Old Archives
Lightguns Arcade1Up --- Bug Reports --- Site News

Unread posts | New Replies | Recent posts | Rules | Chatroom | Wiki | File Repository | RSS | Submit news

  

Author Topic: DemulShooter (Dual light gun on DEMUL, Model2, Dolphin, Silent Hill, etc...)  (Read 306446 times)

0 Members and 6 Guests are viewing this topic.

argonlefou

  • Trade Count: (0)
  • Full Member
  • ***
  • Online Online
  • Posts: 655
  • Last login:Today at 07:00:09 pm
So, small update :DemulShooter v7.6a :
Chnaged a few things to correct the following issue (very user-specific issue) :
For following games :
- Haunted Museum
- Haunted Museum 2
- FrightFearLand
- Gaia Attack 4

The cursor was not going full range if you played with DxWnd and a resolution different from the one used in the game's INI file.
For example, INI file set to 1024x768 (original resolution of the games) and DxWnd on a 640x480 windowed mode, cursor was stuck on a small upper-left part of the screen

It's now working good, provided you keep the same aspect ratio between DxWnd window and the game's INI settings
Messing with the ratio may have unwanted effect according to the game's engine and DxWnd filling the blank so be carefull....

Model2 have the same issue but this will be settled later unfortunately

Edit
I updated the Gaia Attack 4 no crosshair patch on first post with the new one removing the crosshair on the cat minigame

phasermaniac

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 191
  • Last login:Today at 01:42:55 pm
  • I want to build my own arcade controls!
Amazing, isnt haunted museum2 anf fright fear land the same game?

Also, I have the same problem with Lets go island

argonlefou

  • Trade Count: (0)
  • Full Member
  • ***
  • Online Online
  • Posts: 655
  • Last login:Today at 07:00:09 pm
Amazing, isnt haunted museum2 anf fright fear land the same game?
The same game yes, but not the exact same release as FFL cab is GlobalVR american "rebuild" of the original Taito HM2 cab
The overall content is the same but EXE are different (that's why they each have their own command in DemulShooter) so I'm just telling that both were corrected

Also, I have the same problem with Lets go island
This shouldn't  :-\
LGI axis value range is fixed, it does not change according to the game resolution
On top of that I'd say LGI is kind of deprecated as LGI3D is better and easier to display

Edit:
I can confirm that LGI does work with the whole DxWnd/Different resolution system
Although I could easily reproduce the issue in all TTX games, this one is working fine
The only bug in LGI is the ingame crosshair not in the correct place but it has always been since day 1
« Last Edit: June 14, 2018, 09:01:46 am by argonlefou »

phasermaniac

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 191
  • Last login:Today at 01:42:55 pm
  • I want to build my own arcade controls!
Ok thank for the clraifications, so may be my fault, Ill try with lgi 3d

xbrunox

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 68
  • Last login:March 26, 2020, 09:23:38 pm
  • I want to build my own arcade controls!
Argon thanks again for your great software!

Remember when you have time to do the same fix you did for the dxwnd also for the model2!

Zeratul

  • Trade Count: (0)
  • Jr. Member
  • **
  • Offline Offline
  • Posts: 6
  • Last login:December 30, 2018, 01:26:40 pm
  • I want to build my own arcade controls!
Is there a way to edit the "OnScreen" values manually for an xinput device? I need to make the application detect the wiimote in a certain range and not the full way, is there a way to do that?

Also what do you guys use to map other buttons while using demulshooter? can I use joy2key? and if so, do I direct it to launch with the game's exe, or with demulshooter? I'm trying to set my + and - keys to be "5, 1" for first player and "5, 2" for second player so that I can insert coins without the need for a keyboard, but I couldn't get this running with joy2key or AHK key mapping in rocketlauncher.

argonlefou

  • Trade Count: (0)
  • Full Member
  • ***
  • Online Online
  • Posts: 655
  • Last login:Today at 07:00:09 pm
Is there a way to edit the "OnScreen" values manually for an xinput device? I need to make the application detect the wiimote in a certain range and not the full way, is there a way to do that?

If you're refering to the OnScreen values in the debug file,  no there is no way.
I'm not handling wiimotes direclty,  I'm just handling Xinput so analog max/min boundaries are fixed by Xinout driver
If you want to tweak your wiimote detection,  it has to be done on your wimote emulation software

Quote

Also what do you guys use to map other buttons while using demulshooter? can I use joy2key? and if so, do I direct it to launch with the game's exe, or with demulshooter? I'm trying to set my + and - keys to be "5, 1" for first player and "5, 2" for second player so that I can insert coins without the need for a keyboard, but I couldn't get this running with joy2key or AHK key mapping in rocketlauncher.
I'm using AHK to map all other buttons of my gun and run everything
I posted some sample scripts earlier,  it's somewhere in the thread (I can't acces them to repost it right now)
But again,  not with RocketLauncher as I'm not using it

wderbi

  • Trade Count: (0)
  • Jr. Member
  • **
  • Offline Offline
  • Posts: 9
  • Last login:June 22, 2018, 01:50:00 am
  • I want to build my own arcade controls!
I am having a bit of a problem getting demulshooter to work with Dreamcast games running demul0.7. Has anyone gotten this to work successfully with Dreamcast games?  I have great results with the arcade systems running 2-player shooter mode (Naomi, Atomiswave, etc...), but not with dreamcast games...only one player mode works and both guns share player 1's bullets.  Do I have to switch to dolphin for those dreamcast games (HOTD2, Crimson Ox, Virtua cops, etc...) games?

argonlefou

  • Trade Count: (0)
  • Full Member
  • ***
  • Online Online
  • Posts: 655
  • Last login:Today at 07:00:09 pm
I am having a bit of a problem getting demulshooter to work with Dreamcast games running demul0.7. Has anyone gotten this to work successfully with Dreamcast games?  I have great results with the arcade systems running 2-player shooter mode (Naomi, Atomiswave, etc...), but not with dreamcast games...only one player mode works and both guns share player 1's bullets.  Do I have to switch to dolphin for those dreamcast games (HOTD2, Crimson Ox, Virtua cops, etc...) games?
It's just not designed to work with Dreamcast games.  ;)
All those games are already available on other arcade emulators with much better result than the console port, so there is no need to support Dreamcast

argonlefou

  • Trade Count: (0)
  • Full Member
  • ***
  • Online Online
  • Posts: 655
  • Last login:Today at 07:00:09 pm
Argon thanks again for your great software!

Remember when you have time to do the same fix you did for the dxwnd also for the model2!
Back on this...so, what would be the point to use DxWnd with a different resolution than model2 resolution ?
The emulator is working good with 640x480 and any other fullscreen resolution is possible with the .ini file

I can understand the issue with "modern" TTX games and their 3D engine, but model2 is really good on this point

xbrunox

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 68
  • Last login:March 26, 2020, 09:23:38 pm
  • I want to build my own arcade controls!
Hi Argon


I guess the request may seem strange but it is not and now I'll explain why.

I use the model2emulator on a 15 khz monitor. Unfortunately, the resolution of 640x480 on a 15khz is interlaced, and then flickers, that's why I do not use it.

I set my desktop at 640x240 maximum resolution available on 15khz with a decent refresh.
I configure model2 to 640x480 and then with dxwnd I use it at the resolution of 640x240.

if I did not use dxwnd and set the model2 directly to 640x240 I would have a flattened image,

that's why I use dxwnd!

argonlefou

  • Trade Count: (0)
  • Full Member
  • ***
  • Online Online
  • Posts: 655
  • Last login:Today at 07:00:09 pm
Hi Argon


I guess the request may seem strange but it is not and now I'll explain why.

I use the model2emulator on a 15 khz monitor. Unfortunately, the resolution of 640x480 on a 15khz is interlaced, and then flickers, that's why I do not use it.

I set my desktop at 640x240 maximum resolution available on 15khz with a decent refresh.
I configure model2 to 640x480 and then with dxwnd I use it at the resolution of 640x240.

if I did not use dxwnd and set the model2 directly to 640x240 I would have a flattened image,

that's why I use dxwnd!
Ok I see now  :)
That way I can set up both model2 and DxWnd like you to test and verify changes


wderbi

  • Trade Count: (0)
  • Jr. Member
  • **
  • Offline Offline
  • Posts: 9
  • Last login:June 22, 2018, 01:50:00 am
  • I want to build my own arcade controls!
I am having a bit of a problem getting demulshooter to work with Dreamcast games running demul0.7. Has anyone gotten this to work successfully with Dreamcast games?  I have great results with the arcade systems running 2-player shooter mode (Naomi, Atomiswave, etc...), but not with dreamcast games...only one player mode works and both guns share player 1's bullets.  Do I have to switch to dolphin for those dreamcast games (HOTD2, Crimson Ox, Virtua cops, etc...) games?
It's just not designed to work with Dreamcast games.  ;)
All those games are already available on other arcade emulators with much better result than the console port, so there is no need to support Dreamcast

Thanks for clearing that up for me!  :applaud:  I spent days trying to get it to work---I thought I had 2-player support working on the dreamcast when I originally set it up last September.  I had to swap out my hard drive and had to go back through some of the emulators and set everything up again.  Me being wrong cost me days of trying to troubleshoot this! :(

argonlefou

  • Trade Count: (0)
  • Full Member
  • ***
  • Online Online
  • Posts: 655
  • Last login:Today at 07:00:09 pm
DemulShooter v7.6b :
- Changed a few things to make model2 work with DxWnd when the window size is different from model2 rendering resolution

@xbrunox : I think only you can tell if this is working well  :D

xbrunox

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 68
  • Last login:March 26, 2020, 09:23:38 pm
  • I want to build my own arcade controls!
Hi Argon, thanks as always for your availability and speed!

I downloaded and tried the latest version with dxwnd and model2, here's how it behaves:

I can finally move across all the screen with the crosshairs!

but....

here are the problems:
HOD, VCOP, VCOP2 if I play with the P1 I always see the crosshair of P2 in the lower right corner, if I move in the corners with the crosshair of the P1 the P2 crosshair follow me, if I play with both players and rest far from the edges everything is ok.

gunblade ny everything seems ok.

rail chase2 I see while I play the 2 crosshair shoot in the lower right corner .

are I really the only one who uses dxwnd with model2? I think that running on 15Khz interlaced resolutions is really terrible!

thanks Argon!
« Last Edit: June 21, 2018, 01:29:55 am by xbrunox »

argonlefou

  • Trade Count: (0)
  • Full Member
  • ***
  • Online Online
  • Posts: 655
  • Last login:Today at 07:00:09 pm
From what you're telling this has nothing to do with the latest patch or with 15Khz, but more like some hooking issue
There was no change to the core of the program and I can confirm I can play fine with 2 Players, even with DxWnd and 640x240


Model2 can be troublesome for some users. Crosshairs stuck in the corner has happened already but never on any of my computer
You can try to change RawDevP1 and RawDevP2 to some different values (like 8 and 9) in model2 INI file (Of course I'm guessing you correctly changed UseRawInput=1)

When you're tlking about crosshairs, are they the original one or the ones you can display with installed scripts by DemulShooter (the ones you can change or hide/show with a keyboard key ?)
I don't use crosshair at all but if I remember well thay all are completelly off with the real aim if you calibrate the gun (not enough to be stuck in the corner though)

And try also to run demulshooter with the -v option and share the created debug.txt file
« Last Edit: June 21, 2018, 03:15:49 am by argonlefou »

xbrunox

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 68
  • Last login:March 26, 2020, 09:23:38 pm
  • I want to build my own arcade controls!
Argon you are great!

I set RawDevP1 and RawDevP2 on 8 and 9 and the problems are gone!
In case I play alone I just have to move the player2 crosshair in a corner!

I use the crosshair of the script!

thank you!

AxxeL

  • Trade Count: (0)
  • Jr. Member
  • **
  • Offline Offline
  • Posts: 1
  • Last login:July 02, 2018, 01:40:41 am
  • I want to build my own arcade controls!
Hello everyone, thanks to all of you who provide solutions in this post, you help many people.

Has anyone found any way to connect two wiimotes to play pcsx2 games like time crisis 2?

I have seen many solutions for aimtrak, but none for wiimotes. I have a mayflash dolphin bar to connect the wiimotes.

xbrunox

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 68
  • Last login:March 26, 2020, 09:23:38 pm
  • I want to build my own arcade controls!
Axxel buy another mayflash like me! Set both bars in mode2 and for your system you will have 2 mouse!
i use 2 wiimote with 2 mayflash with mame, supermodel and obviously with demulshooter with demul and model2!

isilkin

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 15
  • Last login:December 23, 2018, 03:13:19 am
  • I want to build my own arcade controls!
I just wanted to thank everyone and especially creator of demulshooter for an awesome software. I am so glad that there are programmers in this world. I seem to have some issues with demulshooter though.
I am following this video
Where a guy sets up his wiimote through touchmote software to emulate 360 controller input. Then he uses DemulShooter to play Model2 games.
One issue that I am having is that in demul diag no matter which device I am choosing (except my mouse) nothing happens. I wonder if that diag window only works with real guns?
So then when I map my wiimote pointer to left stick in demulshooter and go to Model2 the crosshair is not moving at all. I did verify in windows device setting that the left stick is being emulated propertly.
Could you guys help me by telling me what I may be doing wrong?
thank you.

argonlefou

  • Trade Count: (0)
  • Full Member
  • ***
  • Online Online
  • Posts: 655
  • Last login:Today at 07:00:09 pm
I just wanted to thank everyone and especially creator of demulshooter for an awesome software. I am so glad that there are programmers in this world. I seem to have some issues with demulshooter though.
I am following this video
Where a guy sets up his wiimote through touchmote software to emulate 360 controller input. Then he uses DemulShooter to play Model2 games.
One issue that I am having is that in demul diag no matter which device I am choosing (except my mouse) nothing happens. I wonder if that diag window only works with real guns?
Indeed DsDiag.exe is only working with Raw Input devices. These are not just "real guns" but any mouse or other device supporting raw input protocol
 
So then when I map my wiimote pointer to left stick in demulshooter and go to Model2 the crosshair is not moving at all. I did verify in windows device setting that the left stick is being emulated propertly.
Could you guys help me by telling me what I may be doing wrong?
thank you.
There are a lot of things to check with your configuration
Easiest ones are Model2 version (must be 1.1a), good demulshooter command line according to the .exe you're using (emulator.exe or emulator_multicpu.exe) and the game you run, and that you changed values as needed in the emulator INI file
The video doesn't show this, but it would be better to change also RawDevP1 and RawDevP2 in the INI file. Check a few message up, there are info about this issue
Also, read carrefully the user guide

isilkin

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 15
  • Last login:December 23, 2018, 03:13:19 am
  • I want to build my own arcade controls!
Thank you for your advice I will try and post here any useful information to other who maybe dealing with this issue.

Do I need to map controls in Model2 to use left stick as the aim or should default control settings work?

isilkin

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 15
  • Last login:December 23, 2018, 03:13:19 am
  • I want to build my own arcade controls!
No, something is still wrong. Here is my model2 config. Btw, should xinput be on?

[Input]
XInput=1         ;Enable support for Xbox360 compatible devices
EnableFF=0         ;Enable Force Feedback Effects
HoldGears=0         ;Set to 1 to return to Neutral in driving games when the gear shift key is released
UseRawInput=1         ;Read mouse through Rawinput, allowing 2 mice
RawDevP1=8         ;Assign specific RawInput devices to players. If you have more than 2 mice
RawDevP2=9         ;set which one is assigned to each player (0-based)

As soon as I enable rawinput and launch model2 I cannot use my real mouse anywhere outside the game window. Wiimotes don't move the aim at all. I even tried this with the 360 controller and the same result. While writing this post I thought of a way to test if demulshooter is doing anything at all. disable xinput don't map any controls in Model2 and see if I can shoot by pressing the button. If so then my controller is using the left mouse click. 

Yes, wiimote 1 is using mouse clicks but not moving the crosshair. Wiimote 2 does not do anything at all.
I read a comment in the youtube video where someone else is having exactly same problem.
I wish the there was a way to test demulshooter outside a game.
« Last Edit: June 28, 2018, 06:09:51 pm by isilkin »

DMB77

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 57
  • Last login:April 24, 2019, 01:42:40 pm
I'm having trouble launching /running Let"s Go Island 3D.  1st Issue is no matter how i edit the app.ini in LGI3D folder,  my tv says "Resolution Mismatch: Change Device's Resolution" when I run the game.  I have a 720HDReady tv set to a resolution of 1360x768.
2nd issue Does anyone know the proper ahk script to run that specific game?  as it is now I have a script to launch DemulShooter and No mousey, but I have to manually start TeknoParrot.  Here is my Script

#SingleInstance force

;Hide Mouse Cursor
Run, C:\nomousy\nomousy.exe -h, C:\nomousy\

;2p support
Run, C:\DemulShooter\demulshooter.exe -target=ringwide -rom=lgi3d, C:\DemulShooter

,Run game
Run, C:\TeknoParrot\1.53\TeknoParrotUi.exe, C:\TeknoParrot\1.53\

Any Help would be greatly appreciated, Thanks!
Fate flies in fear of the moment

argonlefou

  • Trade Count: (0)
  • Full Member
  • ***
  • Online Online
  • Posts: 655
  • Last login:Today at 07:00:09 pm
I'm having trouble launching /running Let"s Go Island 3D.  1st Issue is no matter how i edit the app.ini in LGI3D folder,  my tv says "Resolution Mismatch: Change Device's Resolution" when I run the game.  I have a 720HDReady tv set to a resolution of 1360x768.
2nd issue Does anyone know the proper ahk script to run that specific game?  as it is now I have a script to launch DemulShooter and No mousey, but I have to manually start TeknoParrot.  Here is my Script
I can't say anything about the display issue as I'm playing on a 1080p TV and the game is running natively without any issue with default settings. Maybe you should try DxWnd ?

As for the script :
Code: [Select]
#SingleInstance force

;TEST MODE :
;Run, "D:\RingWide\TeknoParrot_1.53_Hotfix\TeknoParrotUi.exe" --profile=LGI3D.xml --test, D:\RingWide\TeknoParrot_1.53_Hotfix\
Run, "D:\RingWide\TeknoParrot_1.53_Hotfix\TeknoParrotUi.exe" --profile=LGI3D.xml, D:\RingWide\TeknoParrot_1.53_Hotfix\

;2p support
Run, C:\Program Files (x86)\DemulShooter\DemulShooter.exe -target=ringwide -rom=lgi3d -parrotloader, C:\Program Files (x86)\DemulShooter

;Hide Mouse Cursor
Run, C:\Program Files (x86)\nomousy\nomousy.exe -h, C:\Program Files (x86)\nomousy\


No, something is still wrong. Here is my model2 config. Btw, should xinput be on?
No, let it as it was originally (XInput=0)


As soon as I enable rawinput and launch model2 I cannot use my real mouse anywhere outside the game window.
Yes, that's how the emulator is designed...it's capturing mouse I can't do anything about that.
Just ALT+TAB between windows to get your mouse back on other running programs


Wiimotes don't move the aim at all. I even tried this with the 360 controller and the same result. While writing this post I thought of a way to test if demulshooter is doing anything at all. disable xinput don't map any controls in Model2 and see if I can shoot by pressing the button. If so then my controller is using the left mouse click. 
I have no Wiimotes but for debug purpose I'm using some DualShocks gamepad with the same driver (virtual X360 gamepad) and you don't have to configure anything in Model2 for controls to be able to play with demulshooter
Start from a fresh Model2 install and just change what's written in the guide (and RawDevP1 & RawDevP2 I have to update the guide). This will be a good starting base

I wish the there was a way to test demulshooter outside a game.
There is, but only for rawinput devices
Xinput virtual devices can already be tested with Windows in controllers settings

For anything else related to DemulShooter, just run the command and add "-v"option at the end, to create the debug.txt and share it here, it may have usefull information
« Last Edit: June 29, 2018, 02:51:16 am by argonlefou »

isilkin

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 15
  • Last login:December 23, 2018, 03:13:19 am
  • I want to build my own arcade controls!
Again, thank you for developing this awesome software. I was able to test it with Demul emulator and it is great. I had to do everything exactly by your pdf guid to get it working. So, thank you.
I will try what you have suggested of starting fresh on Model2.

isilkin

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 15
  • Last login:December 23, 2018, 03:13:19 am
  • I want to build my own arcade controls!
Lol. I guess all the New people here have a lot of questions. I ve got house of the dead 2 working on demul but I cannot see any crosshair. The guns shoot fine and I can calibrate them but there is no aim on the screen. Is there a shortcut or something to enable it in the game?

Nevermind, F11 enables a little red triangle in Demul for your aim. I think you need to run the old video plugin for it to show up. Though is only follows my real mouse cursor and it does not follow demulshooter ones.
Is there a way to fix that?
« Last Edit: June 29, 2018, 07:02:50 pm by isilkin »

isilkin

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 15
  • Last login:December 23, 2018, 03:13:19 am
  • I want to build my own arcade controls!
I hope I am not spamming this forum with my Model2 issue. If I get this working I will be sure to post a guide for others who maybe dealing with this issue.

I am attaching my debug file hoping someone could take a look and see what is going on with my model 2 setup. As I said earlier my wiimotes shoot and reload fine but the crosshairs do not move. I see it says in the debug log that there is an error converting location but I have now idea what causes it or how to fix it.
As I said in the usb devices when I test my controller it's working fine.

tony.silveira

  • Trade Count: (+1)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 629
  • Last login:March 27, 2020, 01:24:26 am
    • my baby
I am having an issue where mouse clicks are not registering within m2 games for player 2, actlab guns.  Player 1 works perfectly.

Player 2 cursor reacts with the trigger button, meaning it moves to where I am firing nut no bullets are shot.  Same with the back button for reloading.  FYI, actlab player 2 gun reads triggers as mouse buttons 3 & 4.

Any thoughts?  Thanks!
« Last Edit: July 01, 2018, 01:25:33 pm by tony.silveira »

argonlefou

  • Trade Count: (0)
  • Full Member
  • ***
  • Online Online
  • Posts: 655
  • Last login:Today at 07:00:09 pm
Lol. I guess all the New people here have a lot of questions. I ve got house of the dead 2 working on demul but I cannot see any crosshair. The guns shoot fine and I can calibrate them but there is no aim on the screen. Is there a shortcut or something to enable it in the game?

Nevermind, F11 enables a little red triangle in Demul for your aim. I think you need to run the old video plugin for it to show up. Though is only follows my real mouse cursor and it does not follow demulshooter ones.
Is there a way to fix that?
Unfortunatelly no. Those crosshairs (I didn't even know Demul had some with the older GPU plugins) are handled par Demul video plugin.
If you want to have custom crosshairs you have to hack into DirectX rendering to change that. Only Model2 allow us to acces the rendering engine with LUA scripts, and even with that I'm not sure crosshairs are in line with DemulShooter.

I am having an issue where mouse clicks are not registering within m2 games for player 2, actlab guns.  Player 1 works perfectly.

Player 2 cursor reacts with the trigger button, meaning it moves to where I am firing nut no bullets are shot.  Same with the back button for reloading.  FYI, actlab player 2 gun reads triggers as mouse buttons 3 & 4.

Any thoughts?  Thanks!
Can you make both gun work as expected with DsDiag.exe ?
Mouse buttons number are not very meaningfull to me, rawinput is filtering left/middle/right click system events, so this point is up to the driver


I hope I am not spamming this forum with my Model2 issue. If I get this working I will be sure to post a guide for others who maybe dealing with this issue.

I am attaching my debug file hoping someone could take a look and see what is going on with my model 2 setup. As I said earlier my wiimotes shoot and reload fine but the crosshairs do not move. I see it says in the debug log that there is an error converting location but I have now idea what causes it or how to fix it.
As I said in the usb devices when I test my controller it's working fine.
Thanks. Your issue is somewhat "normal" as model2 window size cannot be detected (so you're playing in a 0x0 pixel  window for DemulShooter, that's why nothing is moving)
As for the "why" I can't say....you can try some earlier build of DemulShooter (you should find the 7.6a on the first message on top of this page) as a small change occured for Model2 in 7.6b release
« Last Edit: July 02, 2018, 09:01:49 am by argonlefou »

isilkin

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 15
  • Last login:December 23, 2018, 03:13:19 am
  • I want to build my own arcade controls!
Hi guys.
I am trying to set up Fright Fear Land. I have used the patch tool to determine the version that I have and it told me to use this argument below.

C:\arcade\Emulators\DemulShooter\DemulShooter_v7.6b\DemulShooter.exe -target=ttx -rom=ffl

Though when I try to run demulshooter with this argument it is not even starting. Usualy when demulshooter is running the icon shows in the tray and the process is started but with my syntax nothing shows at all. Is there an error somewhere?

Another question which is completely unrelated: Is there a way to make wiimote vibrate when I shoot? I check vibration on in the demulshooter but nothing happens.


Edit: tried running DemulShooter.exe -target=globalvr -rom=fearland

demulshooter now works but only registers 1 gun. Is there something I need to change in the game's ini? If so can someone share their ini file.
« Last Edit: July 05, 2018, 12:10:19 am by isilkin »

isilkin

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 15
  • Last login:December 23, 2018, 03:13:19 am
  • I want to build my own arcade controls!
I would like to post a current up to date tutorial on how to make wiimotes work with Model2 emulator.

1. Download touchmote link:http://touchmote.net/
2. download sega model 2 emulator. Not sure I can post a link so just google it.
3. Get a rom I am using virtua cop 2 for this example
4. Download this specific version of demulshooter
5. Copy my batch file but change everything to your directories
6. Setup your wiimotes according to my images
7. Open sega model 2 multi cpu exe file, run your game then go to setting and assign controls (I assume your touchmote is running at this point) Only assign coin and start buttons. The rest of the button don't matter because demulshooter will replace them.
7a. Remember to set up your controls in Model2 now because once you replace the ini file with mine you will not be able to access the menu. It is because we change the raw input value to 1 and that lock you out of the menus.
7b. Download demulshooter version 7.6  not "a" or "b" and setup according to my images link: https://forum.arcadecontrols.com/index.php?action=dlattach;topic=149714.0;attach=368241
8. Now copy and paste my emulator.ini file. (change your game direcory in the ini file.)
9. I added a wait screen while you are pairing your wiimotes so copy my image in your directory.
10. Run my batch file as an admin and everything should work.

argonlefou

  • Trade Count: (0)
  • Full Member
  • ***
  • Online Online
  • Posts: 655
  • Last login:Today at 07:00:09 pm
Hi guys.
I am trying to set up Fright Fear Land. I have used the patch tool to determine the version that I have and it told me to use this argument below.

C:\arcade\Emulators\DemulShooter\DemulShooter_v7.6b\DemulShooter.exe -target=ttx -rom=ffl

Though when I try to run demulshooter with this argument it is not even starting. Usualy when demulshooter is running the icon shows in the tray and the process is started but with my syntax nothing shows at all. Is there an error somewhere?

Edit: tried running DemulShooter.exe -target=globalvr -rom=fearland

Yes, sorry this one is my fault
Syntax has changed after the release of TTX version of the game, the patcher was modified and posted in the thread but I forgot to update the link on the 1st page to point to the last version of the patcher.
You found out the correct one

demulshooter now works but only registers 1 gun. Is there something I need to change in the game's ini? If so can someone share their ini file.
Nothing special has to be modified in the game's ini file

Another question which is completely unrelated: Is there a way to make wiimote vibrate when I shoot? I check vibration on in the demulshooter but nothing happens.
I don't know for Wiimotes, it may depend on the driver. I just know it works with DualShocks


I would like to post a current up to date tutorial on how to make wiimotes work with Model2 emulator.

[...]
Thanks !
Good to know that you had to revert back to 7.6 to make it work.
In theory 7.6a should work too as nothing has changed for model2

But well, not a good news if solving issues for some people create new ones for others

isilkin

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 15
  • Last login:December 23, 2018, 03:13:19 am
  • I want to build my own arcade controls!
Nevermind. I just answered my own question. However, If I run operation ghost via teknoparrot will it work with demulshooter and if so what arguments should I use.
« Last Edit: July 06, 2018, 06:37:03 pm by isilkin »

argonlefou

  • Trade Count: (0)
  • Full Member
  • ***
  • Online Online
  • Posts: 655
  • Last login:Today at 07:00:09 pm
I suppose I am testing all the listed games in your pdf one by one. Thank you again for this great software. Now I am testing teknoparrot games. I am working on operation ghost. In your tutorial you say to change ini and run gs2.exe but the operation ghost does not have any exe files. I know of only one place where to get it (but it only comes with gametest.bat and game.bat). Also what argument would I use globalvr or ringwide?
Operation Ghost is a RingWide game, even if you can run it without Teknoparrot
But if you don't have any exe file, then either you're missing some files from the dump or you don't have a good dump

argonlefou

  • Trade Count: (0)
  • Full Member
  • ***
  • Online Online
  • Posts: 655
  • Last login:Today at 07:00:09 pm
DemulShooter v8.0 :
- Added support for up to 4 devices (so far only Gaia Attack 4 can be played as Player 3 and/or Player 4)
- As a consequence, some .ini file items syntax had to be modified (making old .ini file not correct anymore, please start again from scratch)
- Few changes to correct some model2 bugs, created by the previous release
- Cleaned up code to publish it on Github
- PDF user guide replaced by Github Wiki

So now, source code is available on Github : https://github.com/argonlefou/DemulShooter
And user guide has moved to online Wiki : https://github.com/argonlefou/DemulShooter/wiki
Please be aware that I'm not used to it so don't expect much more than "simple" code publishing (i.e: most of discussion / support will be here and not with some github tickets, requests, etc...)

There was some major re-write for this update, and I've tested a lot of things but do not hesitate to give some feedback if something is broken


@isilkin : Can you try this version with Model2 and see if it's working for you ?
« Last Edit: July 07, 2018, 12:05:02 pm by argonlefou »

sushko

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 14
  • Last login:Today at 05:47:52 pm
  • I want to build my own arcade controls!
Two questions one can Silent Hill run in Windows 10 and Music GunGun is missing some dll files maybe a bad download?

Thanks


Sent from my SM-G935V using Tapatalk


phasermaniac

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 191
  • Last login:Today at 01:42:55 pm
  • I want to build my own arcade controls!
Hi sushko, I think Silent hill arcade wont work in win10.
With music gungun I had the same problem, but if you use Ati, I discovered disablig GPU scaling in AMD Radeon configuration resolved it.
« Last Edit: July 09, 2018, 12:28:32 pm by phasermaniac »

phasermaniac

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 191
  • Last login:Today at 01:42:55 pm
  • I want to build my own arcade controls!
For me model2 dont work since 7.6a.
With 7.6b and 8.0, while working in other emus, in m2 I get the aiming stuck in the upper left corner. Tried to change the RawDevP1 and RawDevP2 in m2 .ini but no luck.
As I have a Crt, I tested in 640x480i and 640x240p, but same in both resolutions. Maybe i'm missing something...

argonlefou

  • Trade Count: (0)
  • Full Member
  • ***
  • Online Online
  • Posts: 655
  • Last login:Today at 07:00:09 pm
For me model2 dont work since 7.6a.
With 7.6b and 8.0, while working in other emus, in m2 I get the aiming stuck in the upper left corner. Tried to change the RawDevP1 and RawDevP2 in m2 .ini but no luck.
As I have a Crt, I tested in 640x480i and 640x240p, but same in both resolutions. Maybe i'm missing something...
It may not be you  ;)
Model2 support was modified in 7.6a but while working for people who had bugs, it may create some bugs for those who hadn't previously  :(
Can you provide a debug file ?