Main Restorations Software Audio/Jukebox/MP3 Everything Else Buy/Sell/Trade
Project Announcements Monitor/Video GroovyMAME Merit/JVL Touchscreen Meet Up Retail Vendors
Driving & Racing Woodworking Software Support Forums Consoles Project Arcade Reviews
Automated Projects Artwork Frontend Support Forums Pinball Forum Discussion Old Boards
Raspberry Pi & Dev Board controls.dat Linux Miscellaneous Arcade Wiki Discussion Old Archives
Lightguns Arcade1Up --- Bug Reports --- Site News

Unread posts | New Replies | Recent posts | Rules | Chatroom | Wiki | File Repository | RSS | Submit news

  

Author Topic: Groovymame Setup - Going Nuts, need help please!  (Read 1254 times)

0 Members and 1 Guest are viewing this topic.

rancid

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 21
  • Last login:June 12, 2019, 07:49:54 pm
  • I want to build my own arcade controls!
Groovymame Setup - Going Nuts, need help please!
« on: December 29, 2018, 11:32:56 pm »
Evening all,

This is a follow up post to the one I made here: http://forum.arcadecontrols.com/index.php/topic,159149.0.html

I was able to fix my issues outputting to my CRT by running catalyst uninstaller and completely starting over which allowed my R9 380x to start outputting correctly.  Fast forward to my issues tonight that I can't seem to figure out.

First issue I am having is there is overscan on my Sony Trinitron 24" Consumer TV and  I see no way to correct this within the TV settings. Is this normal or is there something else contributing to the overscan?  Notice the windows bar is cut off.



Second issue I am having is Groovymame itself.  When I load the .exe from the icon in the install directory it always displays on my primary LCD monitor.  I tried unplugging the monitoring and Groovymame refuses to load and will hang.  I ran a CMD window to see what was happening and below is the error I am getting when using my CRT as the primary display:



To troubleshoot this I reinstalled my modelines from the default super-res file included with the driver package and I also tried making my own file, both give the same error.  I also reinstalled DX9 from numerous distributions without any luck, but I can't get Groovymame to run off my CRT.

Third issue if I run Groovymame off my LCD in a window and drag it to the CRT, the games load on my LCD and switchres is changing to the resolution of the game as expected.  The problem is obviously my LCD can't display the signal and times out until I hit esc and get out of Groovymame.  It is almost like everything is setup to use my LCD rather than my CRT.  I went through the VMMaker install process and verified that I am outputting on the Analog0 VGA signal (DVI-I shows Digital) and my CRT is showing as Arcade_15khz.  (See screenshot below showing switchres working):



Does anyone have any thoughts on what might be happening and how to correct these issues?  I am completely stumped at this point and not sure what else to even try.  I can boot into Windows on my CRT fine and also run Retroarch (still working on setting up Switchres for that). 

Ty for the help and wonderful community!
« Last Edit: December 29, 2018, 11:35:12 pm by rancid »

Arroyo

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 619
  • Last login:Today at 02:09:03 am
  • Budgets are boring
    • newforum.arcadecontrols.com/index.php/topic,156267.0.html
Re: Groovymame Setup - Going Nuts, need help please!
« Reply #1 on: December 30, 2018, 08:50:20 am »
I’ve gone through some of your issues in my testing/setup that is very similar to yours. Not sure what your model number for the TV is but for most Sony’s this will work work to gain access to the on screen display for making adjustments to the TV’s digital chassis.

On your remote control with the TV off press “Display”, then “5”, then the “Volume up” button.  Then press power.  When you do a on screen menu comes up (just text) and you use the numbers 1 & 4 on your remote to move up and down the menu, and 3 & 6 to changes the values up and down.  This is where you can play with the geometry of the display and fix your vertical height issue (if memory services it’s VSIZE).  I would recommend using a test pattern though, ideally from a source that output a native NTSC/PAL signal (DVD Player, PS3 @ 480i or other console that can load a test pattern image).

Here’s a link to resources for the Sony service menu:

http://www.neo-geo.com/forums/showthread.php?248996-Sony-WEGA-Trinitron-CRT-TV-service-menu-Tips-Tricks-and-settings-suggestions

You may also want to download your TV’s service repair manual:

https://www.manualslib.com/brand/sony/tv.html

Here you will get a breakdown on what each of the acronyms in the Service menu mean and what functions they perform.


Regarding Mame showing up on your LCD have you tried simply unplugging your LCD and running Mame?  That works for me, but I think the main issue here is what you are calling your “primary display”.  You can edit that by always right clicking the desktop choose “screen resolution”, then make your CRT the primary display.

Lastly it doesn’t appear as though you are using super resolutions.  The output of the command line you posted looks like you are using the regular user modes.ini.  In VMM on the tab second from right you can browse to the super user modes and that usual helps center the image, etc.

rancid

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 21
  • Last login:June 12, 2019, 07:49:54 pm
  • I want to build my own arcade controls!
Re: Groovymame Setup - Going Nuts, need help please!
« Reply #2 on: December 30, 2018, 09:54:46 am »
Morning Arroyo,

I will mess with the service mode on the Sony later and see if I can fix the vertical scan issue, apparently that is fairly common on consumer TVs from what I read last night in previous threads.

In regards to the mode lines, can you help shed some clarity on my end?  I used both the user mode.ini file when I initially set everything up and went back and loaded a custom config I made for retroarch based on the wiki documentation.  Here is the file I used in the "user mode tab".  I created a .txt file and renamed it to .ini via DOS since VMMaker wouldn't read the text file:  https://pastebin.com/YfNuCpKa

Also, under the video card tab can you confirm if I should be checking the box "Add modes from modes list"?  I didn't see anything in any documents mentioning this setting.

If I unplug my primary monitor or set the CRT to main display I get the D3D9 error where it says fatal error and crashes.  I read last night this might be due to a big in the software with multiple monitors, but I thought Calamity fixed it in the latest version.  I am going to try a different version of GroovyMame and I'll report back.

Thanks for the help!

rancid

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 21
  • Last login:June 12, 2019, 07:49:54 pm
  • I want to build my own arcade controls!
Re: Groovymame Setup - Going Nuts, need help please!
« Reply #3 on: December 30, 2018, 10:22:31 am »
Making some headway, new version of Groovymame corrected the D3D error and I can get it to run now by unplugging my LCD monitor.

I don't think switchres is working correctly though, it is setting everything to 640x480i.  I tried re-running VMMaker to generate the scanmodes from the user_modes -super file to see if I borked something in my custom one and it always defaults to 640x480i.  Is this normal?



Attached is my log file from MK, looks like switchres is doing something, just not sure if it is the right res or not.
« Last Edit: December 30, 2018, 10:28:20 am by rancid »

Arroyo

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 619
  • Last login:Today at 02:09:03 am
  • Budgets are boring
    • newforum.arcadecontrols.com/index.php/topic,156267.0.html
Re: Groovymame Setup - Going Nuts, need help please!
« Reply #4 on: December 30, 2018, 10:51:12 am »
In regards to the mode lines, can you help shed some clarity on my end?  I used both the user mode.ini file when I initially set everything up and went back and loaded a custom config I made for retroarch based on the wiki documentation.

I don’t know if my knowledge is enough to comment on this.  I’ve only used the default “user_modes - super.ini” that comes with the download.  I have edited that text file to add other vertical resolutions, but that’s it.


Quote
Also, under the video card tab can you confirm if I should be checking the box "Add modes from modes list"?  I didn't see anything in any documents mentioning this setting.

I’ve never checked that box :dunno:


Quote
If I unplug my primary monitor or set the CRT to main display I get the D3D9 error where it says fatal error and crashes.  I read last night this might be due to a big in the software with multiple monitors, but I thought Calamity fixed it in the latest version.  I am going to try a different version of GroovyMame and I'll report back.

Thanks for the help!

Do you mean you set your Mame.ini to d3d9ex?  If so the documentation on the GroovyMame tutorial website is dated.  You just need to put d3d under the video mode in the name.ini

rancid

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 21
  • Last login:June 12, 2019, 07:49:54 pm
  • I want to build my own arcade controls!
Re: Groovymame Setup - Going Nuts, need help please!
« Reply #5 on: December 30, 2018, 11:33:37 am »
I got Switchres working to an extent.  I feel like a complete idiot, but I am learning so that is all that matters.  I am using dual-output from my R9 380x and in VMMaker I was adding the user modes to the wrong monitor (facepalm).  For those doing their first setup and see this, under Video Card Tab make sure the Device is your R9 380 ARCADE_15 and not anything else if you have two outputs from the same video card.

With that said, none of the Mortal Kombat games (or Midway in genearl) are displaying correctly.  Switchres is doing its thing, but the entire image is bouncing up and down vertically.  Does anyone know a quick fix or should I set specific output resolutions for the MK games?  I think it is due to the refresh rate it is syncing to, but not 100% sure just yet what the issue is.

Attached is my log for MK, it appears all Midway games do this. Capcom games seem to be working great.

Ty again for sticking with me through this crazy setup process.  I plan on writing a guide for new users that is more updated for Windows 10.
« Last Edit: December 30, 2018, 11:56:22 am by rancid »

haynor666

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 1222
  • Last login:Today at 01:26:44 am
  • retro maniac
Re: Groovymame Setup - Going Nuts, need help please!
« Reply #6 on: December 30, 2018, 12:32:25 pm »
EDID emulation is enabled? Why You are mixing native resolutions with super resolutions?

rancid

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 21
  • Last login:June 12, 2019, 07:49:54 pm
  • I want to build my own arcade controls!
Re: Groovymame Setup - Going Nuts, need help please!
« Reply #7 on: December 30, 2018, 01:33:06 pm »
EDID emulation is enabled? Why You are mixing native resolutions with super resolutions?

I re-did the EDID emulation just to be sure, 100% positive it is enabled.  All other arcade games are working as intended except the midway ones.

I am mixing native and super because I am utilizing native mode in switchres for Retroarch and these are the values recommended off their 15khz wiki article.

To troubleshoot further I loaded MK.zip and NBAJAMTE.zip in Retroarch using the Mame core and at native resolution it is bouncing around there as well which eliminates an issue with Groovymame.  Something is wrong with one of the modelines I have set, but even the default ones don't seem to work with Midway games.
« Last Edit: December 30, 2018, 01:38:23 pm by rancid »

rancid

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 21
  • Last login:June 12, 2019, 07:49:54 pm
  • I want to build my own arcade controls!
Re: Groovymame Setup - Going Nuts, need help please!
« Reply #8 on: December 30, 2018, 08:27:46 pm »
I scrapped mixing super and native resolutions and have super resolutions working perfectly in retroarch and groovymame.  MK and any other midway game remains an issue with the bouncing ?bobbing" screen.  I am completely out of ideas, but I still think it has something to do with the sync rate that is being reported based on this output: 

D:\Mame>mame64 -changeres mk

SwitchRes: [mk] (1) horizontal (400x254@54.706841)->(2560x254@54.706841)

Does anyone have any ideas on what I need to do to make this work? The Midway games were the main games outside of Capcom I built this for so I definitely need this working.

Ty again for all the help!

Arroyo

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 619
  • Last login:Today at 02:09:03 am
  • Budgets are boring
    • newforum.arcadecontrols.com/index.php/topic,156267.0.html
Re: Groovymame Setup - Going Nuts, need help please!
« Reply #9 on: December 31, 2018, 09:44:55 am »
I scrapped mixing super and native resolutions and have super resolutions working perfectly in retroarch and groovymame.  MK and any other midway game remains an issue with the bouncing ?bobbing" screen.  I am completely out of ideas, but I still think it has something to do with the sync rate that is being reported based on this output: 

D:\Mame>mame64 -changeres mk

SwitchRes: [mk] (1) horizontal (400x254@54.706841)->(2560x254@54.706841)

Does anyone have any ideas on what I need to do to make this work? The Midway games were the main games outside of Capcom I built this for so I definitely need this working.

Ty again for all the help!


Midway games are a challenge, from my limited experience.  They use both a taller vertical resolution (stretches off the visual area usually without adjusting your monitor vertical size) and a slower refresh rate (hard to sync depending on your CRT (i.e. chassis capability) ).  I’m still testing my Sony CRT TV, but right now I get a wavy picture on the sides with Midway games (and a lot of vertical games like Galaga), which is the precursor to a bouncing image like you have.  I just discovered this thread:

 http://forum.arcadecontrols.com/index.php?topic=157893.0

I have yet to try playing with this, but the guy has a professional monitor which usually have a lot of flexibility on refresh rates.  The more that I read it appears as though this may be one of the challenges of using a standard TV, as the chassis appear to not usually like refresh rates that aren’t close to 60Hz (NTSC) or 50hz (PAL).

Perhaps someone with more experience can chime in, as I’m having the same problem and would love for the Midway games to be in their native resolution without wavy lines/bouncing as well. 

One thing I can’t seem to get around is that the  manual of my TV implies that it can handle down to 56hz:



but as far as I can tell if I adjust the settings in Arcade OSD to anything under 59.4Hz I start to see a waviness on the horizontal boarders and eventually I get to bouncing the image.


rancid

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 21
  • Last login:June 12, 2019, 07:49:54 pm
  • I want to build my own arcade controls!
Re: Groovymame Setup - Going Nuts, need help please!
« Reply #10 on: December 31, 2018, 10:22:04 am »
I found this thread which is the EXACT TV i have and the EXACT same issue, but his fix did not work for me.  It tried adding the modelines using the program and VMMaker, modified my mame.ini with the custom monitor settings and no-go.  http://forum.arcadecontrols.com/index.php?topic=146803.0

Here is what the output looks like native and superers after adding his settings:

D:\Mame>mame64 mk

SwitchRes: [mk] (1) horizontal (400x254@54.706841)->(400x254@54.706841)
SwitchRes: [mk] (1) horizontal (400x254@54.706841)->(2560x254@54.706841)

I tried adding this setting to my mame.ini with custom monitor no-go: 15625-16200, 49.50-65.00, 2.000, 4.700, 8.000, 0.064, 0.192, 1.024, 0, 0, 192, 288, 448, 576

I added these as well, no-go:
crt_range0 15600-15900, 55.0-65.0, 4.361, 4.462, 6.466, 0.859, 0.191, 1.367, 0, 0, 224, 224, 0, 0
crt_range1 15600-15900, 55.0-65.0, 4.361, 4.462, 6.466, 0.318, 0.191, 0.891, 0, 0, 240, 240, 0, 0
crt_range2 15600-15900, 55.0-65.0, 4.361, 4.462, 6.466, 0.064, 0.191, 0.127, 0, 0, 256, 256, 0, 0
crt_range3 15600-15900, 55.0-65.0, 4.361, 4.462, 6.466, 1.177, 0.191, 1.049, 0, 0, 0, 0, 448, 448

Modeline "2560x448_60 15.7KHz 60.0Hz" 53.190 2560 2792 3032 3384 448 474 479 524 interlace -hsync -vsync 
Modeline "2560x256_58 15.7KHz 60.0Hz" 53.330 2560 2792 3048 3392 256 257 260 262  -hsync -vsync 
Modeline "2560x240_60 15.7KHz 60.0Hz" 53.200 2560 2792 3040 3384 240 245 248 262  -hsync -vsync 
Modeline "400x240_60 15.7KHz 60.1Hz" 8.150 400 432 472 520 240 242 245 261  -hsync -vsync 
Modeline "256x224_60 15.7KHz 60.1Hz" 5.290 256 280 312 336 224 235 238 262  -hsync -vsync 
Modeline "2560x224_60 15.7KHz 60.0Hz" 53.200 2560 2792 3040 3384 224 237 240 262  -hsync -vsync

I hooked up my PVM and MK works fine with no bobbing, this is definitely an issue with the FS120 CRT TV handling that refresh rate.  What can I do to adjust the bobbing?  I tried making a custom config called mk.ini and put it in the ini and /preset folder with no luck.  My monitor is identified as ARCADE_15 and I have "custom" as the monitor, is this correct or should it be ARCADE_15?

Someone please help :(

« Last Edit: December 31, 2018, 10:48:03 am by rancid »

rancid

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 21
  • Last login:June 12, 2019, 07:49:54 pm
  • I want to build my own arcade controls!
Re: Groovymame Setup - Going Nuts, need help please!
« Reply #11 on: January 01, 2019, 12:23:20 am »
Set VMMaker mode to NTSC, it definitely helped but still having issues with bobbing/flickering and resolution is squashed:

https://imgur.com/a/TFB9tfc

Calamity

  • Moderator
  • Trade Count: (0)
  • Full Member
  • *****
  • Offline Offline
  • Posts: 6640
  • Last login:June 22, 2019, 12:06:55 pm
Re: Groovymame Setup - Going Nuts, need help please!
« Reply #12 on: January 01, 2019, 07:49:14 am »
In mame.ini, set:

monitor custom
crt_range0 15625.00-16200.00,55.00-65.00,2.000,4.700,6.000,0.064,0.192,1.920,0,0,192,288,448,576
Important note: posts reporting GM issues without a log will be IGNORED.
Steps to create a log:
 - From command line, run: groovymame.exe -v romname >romname.txt
 - Attach resulting romname.txt file to your post, instead or pasting it.

CRT Emudriver, VMMaker & Arcade OSD downloads, documentation and discussion:  Eiusdemmodi

rancid

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 21
  • Last login:June 12, 2019, 07:49:54 pm
  • I want to build my own arcade controls!
Re: Groovymame Setup - Going Nuts, need help please!
« Reply #13 on: January 01, 2019, 09:47:43 am »
In mame.ini, set:

monitor custom
crt_range0 15625.00-16200.00,55.00-65.00,2.000,4.700,6.000,0.064,0.192,1.920,0,0,192,288,448,576

Good morning Calamity, Happy New Year!

I made the change, same outcome as before with the bobbing screen vertically.  Attached are some files that might help track this down and what mame is doing from CMD: D:\Mame>mame64 mk

SwitchRes: [mk] (1) horizontal (400x254@54.706841)->(2560x254@54.706841)
Average speed: 100.00% (2 seconds)

D:\Mame>mame64 -v mk >mklog.txt

D:\Mame>

Modeline file: https://pastebin.com/yNb8PU20
Mame.ini : https://pastebin.com/z215mdH1

Ty for replying!

Calamity

  • Moderator
  • Trade Count: (0)
  • Full Member
  • *****
  • Offline Offline
  • Posts: 6640
  • Last login:June 22, 2019, 12:06:55 pm
Re: Groovymame Setup - Going Nuts, need help please!
« Reply #14 on: January 01, 2019, 11:02:35 am »
There's probably some other ini getting in the middle. Make sure to remove any ini and just leave mame.ini in there.
Important note: posts reporting GM issues without a log will be IGNORED.
Steps to create a log:
 - From command line, run: groovymame.exe -v romname >romname.txt
 - Attach resulting romname.txt file to your post, instead or pasting it.

CRT Emudriver, VMMaker & Arcade OSD downloads, documentation and discussion:  Eiusdemmodi

rancid

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 21
  • Last login:June 12, 2019, 07:49:54 pm
  • I want to build my own arcade controls!
Re: Groovymame Setup - Going Nuts, need help please!
« Reply #15 on: January 01, 2019, 11:27:21 am »
There's probably some other ini getting in the middle. Make sure to remove any ini and just leave mame.ini in there.

I just removed all the ini files to be sure (even the preset ones) and am having the same end result.  It keeps trying to load at 2560x254@54.706.

I put my EDID back to ARCADE_15 this morning, do you recommend I switch back to NTSC and try with the setting you provided?  I am at a loss on why it keeps trying to lock to 2560x254@54.706.

Calamity

  • Moderator
  • Trade Count: (0)
  • Full Member
  • *****
  • Offline Offline
  • Posts: 6640
  • Last login:June 22, 2019, 12:06:55 pm
Re: Groovymame Setup - Going Nuts, need help please!
« Reply #16 on: January 01, 2019, 11:48:42 am »
Mmmm what inis did you kill? The ones in the mame folder as I meant or the ones in VMMaker?

This is something you have to fix in MAME, you don't have to touch VMMaker.
Important note: posts reporting GM issues without a log will be IGNORED.
Steps to create a log:
 - From command line, run: groovymame.exe -v romname >romname.txt
 - Attach resulting romname.txt file to your post, instead or pasting it.

CRT Emudriver, VMMaker & Arcade OSD downloads, documentation and discussion:  Eiusdemmodi

rancid

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 21
  • Last login:June 12, 2019, 07:49:54 pm
  • I want to build my own arcade controls!
Re: Groovymame Setup - Going Nuts, need help please!
« Reply #17 on: January 01, 2019, 12:31:49 pm »
Mame, I tried earlier to create system-specific ini files so to be 100% sure I got rid of all of them I took the ini folder from the 7zip file and made sure to keep my original mame.ini which is in D:\Mame\mame.ini.  I have not touched VMMaker since we started talking.

Do you have any other recommendations to try inside the ini?  Someone on another forums recommended I try this modeline:

Horizontal Scan Rate: 15.756 KHz
Horizontal Active: 720
Horizontal Total: 858
Horizontal Sync: 64
Horizontal Front Porch: 41
Horizontal Back Porch: 33
(Horizontal Sync Polarity Negative)

Vertical Rate: 54.708 Hz
Vertical Active: 254
Vertical Total: 288
Vertical Sync: 3
Vertical Front Porch: 8
Vertical Back Porch: 23
(Vertical Sync Polarity Negative)

rancid

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 21
  • Last login:June 12, 2019, 07:49:54 pm
  • I want to build my own arcade controls!
Re: Groovymame Setup - Going Nuts, need help please!
« Reply #18 on: January 01, 2019, 12:34:08 pm »
Mame, I tried earlier to create system-specific ini files so to be 100% sure I got rid of all of them I took the ini folder from the 7zip file and made sure to keep my original mame.ini which is in D:\Mame\mame.ini.  I have not touched VMMaker since we started talking.

Do you have any other recommendations to try inside the ini?  Someone on another forums recommended I try this modeline:

Horizontal Scan Rate: 15.756 KHz
Horizontal Active: 720
Horizontal Total: 858
Horizontal Sync: 64
Horizontal Front Porch: 41
Horizontal Back Porch: 33
(Horizontal Sync Polarity Negative)

Vertical Rate: 54.708 Hz
Vertical Active: 254
Vertical Total: 288
Vertical Sync: 3
Vertical Front Porch: 8
Vertical Back Porch: 23
(Vertical Sync Polarity Negative)

Would there be any value of letting Mame try to create a full list from the XML file?

Calamity

  • Moderator
  • Trade Count: (0)
  • Full Member
  • *****
  • Offline Offline
  • Posts: 6640
  • Last login:June 22, 2019, 12:06:55 pm
Re: Groovymame Setup - Going Nuts, need help please!
« Reply #19 on: January 01, 2019, 12:53:21 pm »
rancid,

Check the log you posted here.

Here are the first lines:

SwitchRes: v0.017m, Monitor: custom, Orientation: horizontal, Modeline generation: enabled
SwitchRes: Monitor range 15625.00-16200.00,49.50-65.00,2.000,4.700,6.000,0.064,0.192,1.920,0,0,192,288,448,576

As you see, it's not picking the crt range you added in mame.ini, which should be:

crt_range0 15625.00-16200.00,55.00-65.00,2.000,4.700,6.000,0.064,0.192,1.920,0,0,192,288,448,576


This necessarily means there's a silly mistake in your GM's configuration which is preventing the custom crt range from being loaded, probably as a consequence of having tried too many things, it happens to all us.

My advice is to start from scratch. Download my GM's package from my site, unzip, edit mame.ini, only change these 3 options:

rompath (whatever)
monitor custom
crt_range0 15625.00-16200.00,55.00-65.00,2.000,4.700,6.000,0.064,0.192,1.920,0,0,192,288,448,576
Important note: posts reporting GM issues without a log will be IGNORED.
Steps to create a log:
 - From command line, run: groovymame.exe -v romname >romname.txt
 - Attach resulting romname.txt file to your post, instead or pasting it.

CRT Emudriver, VMMaker & Arcade OSD downloads, documentation and discussion:  Eiusdemmodi

rancid

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 21
  • Last login:June 12, 2019, 07:49:54 pm
  • I want to build my own arcade controls!
Re: Groovymame Setup - Going Nuts, need help please!
« Reply #20 on: January 01, 2019, 01:08:42 pm »
rancid,

Check the log you posted here.

Here are the first lines:

SwitchRes: v0.017m, Monitor: custom, Orientation: horizontal, Modeline generation: enabled
SwitchRes: Monitor range 15625.00-16200.00,49.50-65.00,2.000,4.700,6.000,0.064,0.192,1.920,0,0,192,288,448,576

As you see, it's not picking the crt range you added in mame.ini, which should be:

crt_range0 15625.00-16200.00,55.00-65.00,2.000,4.700,6.000,0.064,0.192,1.920,0,0,192,288,448,576


This necessarily means there's a silly mistake in your GM's configuration which is preventing the custom crt range from being loaded, probably as a consequence of having tried too many things, it happens to all us.

My advice is to start from scratch. Download my GM's package from my site, unzip, edit mame.ini, only change these 3 options:

rompath (whatever)
monitor custom
crt_range0 15625.00-16200.00,55.00-65.00,2.000,4.700,6.000,0.064,0.192,1.920,0,0,192,288,448,576

I noticed that as well but assumed it was pulling the switchres info from the monitor file or elsewhere.  I will certainly take your advice and start over with GroovyMame, I'll report back soon!

rancid

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 21
  • Last login:June 12, 2019, 07:49:54 pm
  • I want to build my own arcade controls!
Re: Groovymame Setup - Going Nuts, need help please!
« Reply #21 on: January 01, 2019, 01:27:56 pm »
rancid,

Check the log you posted here.

Here are the first lines:

SwitchRes: v0.017m, Monitor: custom, Orientation: horizontal, Modeline generation: enabled
SwitchRes: Monitor range 15625.00-16200.00,49.50-65.00,2.000,4.700,6.000,0.064,0.192,1.920,0,0,192,288,448,576

As you see, it's not picking the crt range you added in mame.ini, which should be:

crt_range0 15625.00-16200.00,55.00-65.00,2.000,4.700,6.000,0.064,0.192,1.920,0,0,192,288,448,576


This necessarily means there's a silly mistake in your GM's configuration which is preventing the custom crt range from being loaded, probably as a consequence of having tried too many things, it happens to all us.

My advice is to start from scratch. Download my GM's package from my site, unzip, edit mame.ini, only change these 3 options:

rompath (whatever)
monitor custom
crt_range0 15625.00-16200.00,55.00-65.00,2.000,4.700,6.000,0.064,0.192,1.920,0,0,192,288,448,576

Calamity that worked!  I can't tell you how excited I am right now.  Switchres is no longer working with these values for any game, should I perhaps try to make a game-specific ini file for MK and leave the default values for other games?  No other games were having issues that I am aware of.  Attached is the latest log.

D:\GroovyMame>mame64 -v mk >mknew.txt
SwitchRes: progressive_lines_max 288 out of range
SwitchRes: Error in monitor range (ignoring): 15625.00-16200.00,55.00-65.00,2.000,4.700,6.000,0.064,0.192,1.920,0,0,192,288,448,576
SwitchRes: could not find a video mode that meets your specs

Calamity

  • Moderator
  • Trade Count: (0)
  • Full Member
  • *****
  • Offline Offline
  • Posts: 6640
  • Last login:June 22, 2019, 12:06:55 pm
Re: Groovymame Setup - Going Nuts, need help please!
« Reply #22 on: January 01, 2019, 01:31:45 pm »
Yes, create a blank mk.ini file, and only add this (no other options):

monitor custom
crt_range0 15625.00-16200.00,55.00-65.00,2.000,4.700,6.000,0.064,0.192,1.920,0,0,192,256,448,576
Important note: posts reporting GM issues without a log will be IGNORED.
Steps to create a log:
 - From command line, run: groovymame.exe -v romname >romname.txt
 - Attach resulting romname.txt file to your post, instead or pasting it.

CRT Emudriver, VMMaker & Arcade OSD downloads, documentation and discussion:  Eiusdemmodi

rancid

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 21
  • Last login:June 12, 2019, 07:49:54 pm
  • I want to build my own arcade controls!
Re: Groovymame Setup - Going Nuts, need help please!
« Reply #23 on: January 01, 2019, 01:39:05 pm »
Yes, create a blank mk.ini file, and only add this (no other options):

monitor custom
crt_range0 15625.00-16200.00,55.00-65.00,2.000,4.700,6.000,0.064,0.192,1.920,0,0,192,256,448,576

I'm up and running!  Ty so much for jumping in on New Years day to help, I am absolutely thrilled I will get to play some games today with my son.

I am going to send you a PM, I have a quick non-related question for you.

If anyone finds this post and needs help setting up under Windows 10, I've been through the ringer and will be glad to help.