Main Restorations Software Audio/Jukebox/MP3 Everything Else Buy/Sell/Trade
Project Announcements Monitor/Video GroovyMAME Merit/JVL Touchscreen Meet Up Retail Vendors
Driving & Racing Woodworking Software Support Forums Consoles Project Arcade Reviews
Automated Projects Artwork Frontend Support Forums Pinball Forum Discussion Old Boards
Raspberry Pi & Dev Board controls.dat Linux Miscellaneous Arcade Wiki Discussion Old Archives
Lightguns Arcade1Up --- Bug Reports --- Site News

Unread posts | New Replies | Recent posts | Rules | Chatroom | Wiki | File Repository | RSS | Submit news

  

Author Topic: GroovyMAME Game Speed Erratic  (Read 631 times)

0 Members and 1 Guest are viewing this topic.

Yardley

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 89
  • Last login:October 09, 2019, 01:48:17 pm
  • I want to build my own arcade controls!
GroovyMAME Game Speed Erratic
« on: January 17, 2019, 10:43:21 pm »
Hi all, when running Golden Tee Fore 2005 or 2006 (has happened in other cases as well I believe with other emulators), the game speed is very erratic. For example, with Golden Tee Fore 2006, at the beginning intro video, the speed is at like 150% (the audio is super fast, see video below) and then later slows down to about 70% and the announcers voice has that low pitch sound. I have a second PC with the same specs as my GroovyMAME PC (minus the graphics card) running regular MAME on an LCD and this doesn't happen on that one. Any thoughts on how I can fix this?


Trnzaddict

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 126
  • Last login:October 10, 2019, 08:54:56 pm
Re: GroovyMAME Game Speed Erratic
« Reply #1 on: January 21, 2019, 01:30:31 pm »
http://forum.arcadecontrols.com/index.php/topic,159008.0.html



Youíre most likely having the same issue I finally solved last week.

Make a custom ini with the rom name, put:

autosync 0
syncrefresh 0
Triplebuffer 1
changeres 0

If that fixes the issue, I donít know what other games you play but youíll need the same ini files for Carnevil, Area 51 & Maximum Force.

Also, going forward Calamity will not help you unless you post a log, just so you know.

Yardley

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 89
  • Last login:October 09, 2019, 01:48:17 pm
  • I want to build my own arcade controls!
Re: GroovyMAME Game Speed Erratic
« Reply #2 on: January 21, 2019, 03:23:43 pm »
http://forum.arcadecontrols.com/index.php/topic,159008.0.html



Youíre most likely having the same issue I finally solved last week.

Make a custom ini with the rom name, put:

autosync 0
syncrefresh 0
Triplebuffer 1
changeres 0

If that fixes the issue, I donít know what other games you play but youíll need the same ini files for Carnevil, Area 51 & Maximum Force.

Also, going forward Calamity will not help you unless you post a log, just so you know.

Thanks for the tip about the log. You're right about Carnevil, although Area 51 seems ok for me. I have attached here logs for both Carnevil and Golden Tee Fore 2006 with and without a custom ini. The custom ini did make a difference for Golden Tee, it doesn't speed up crazy fast anymore but it still slows down quite a bit. This can be due to my hardware but if Calamity or someone else can look at the logs to confirm that it's possibly my hardware and not a configuration issue that would be great. For Carnevil, using the custom ini corrects the speed but the image gets squished in the middle of the screen. Pictures below of Golden Tee with and without custom ini and of Carnevil with custom ini showing the squashed image.

Golden Tee without custom ini



Golden Tee with custom ini



Carnevil with custom ini


Calamity

  • Moderator
  • Trade Count: (0)
  • Full Member
  • *****
  • Offline Offline
  • Posts: 6735
  • Last login:October 12, 2019, 11:09:54 am
  • Quote me with care
Re: GroovyMAME Game Speed Erratic
« Reply #3 on: January 21, 2019, 04:14:12 pm »
Your custom inis are missing the -triplebuffer part, is it possible that you typed "Triplebuffer" instead of "triplebuffer"?

Also, because you're disabling changeres, you need to force the final desired resolution in then ini, use -resolution 2560x480.
Important note: posts reporting GM issues without a log will be IGNORED.
Steps to create a log:
 - From command line, run: groovymame.exe -v romname >romname.txt
 - Attach resulting romname.txt file to your post, instead or pasting it.

CRT Emudriver, VMMaker & Arcade OSD downloads, documentation and discussion:  Eiusdemmodi

Yardley

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 89
  • Last login:October 09, 2019, 01:48:17 pm
  • I want to build my own arcade controls!
Re: GroovyMAME Game Speed Erratic
« Reply #4 on: January 21, 2019, 04:43:18 pm »
Your custom inis are missing the -triplebuffer part, is it possible that you typed "Triplebuffer" instead of "triplebuffer"?

Also, because you're disabling changeres, you need to force the final desired resolution in then ini, use -resolution 2560x480.

Thanks Calamity, I did have a capital T, fixed that and added the resolution parameter to the custom ini. Carnevil is still squished. I've attached a new log with these fixes applied.

Calamity

  • Moderator
  • Trade Count: (0)
  • Full Member
  • *****
  • Offline Offline
  • Posts: 6735
  • Last login:October 12, 2019, 11:09:54 am
  • Quote me with care
Re: GroovyMAME Game Speed Erratic
« Reply #5 on: January 21, 2019, 04:52:09 pm »
Try removing the changeres 0 option.
Important note: posts reporting GM issues without a log will be IGNORED.
Steps to create a log:
 - From command line, run: groovymame.exe -v romname >romname.txt
 - Attach resulting romname.txt file to your post, instead or pasting it.

CRT Emudriver, VMMaker & Arcade OSD downloads, documentation and discussion:  Eiusdemmodi

Yardley

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 89
  • Last login:October 09, 2019, 01:48:17 pm
  • I want to build my own arcade controls!
Re: GroovyMAME Game Speed Erratic
« Reply #6 on: January 23, 2019, 12:50:43 am »
Try removing the changeres 0 option.

That worked! Thanks. Is there somewhere I can learn more about what these parameters are doing? I'd like to understand what is going on and how to determine which resolution to specify when needed.