Main Restorations Software Audio/Jukebox/MP3 Everything Else Buy/Sell/Trade
Project Announcements Monitor/Video GroovyMAME Merit/JVL Touchscreen Meet Up Retail Vendors
Driving & Racing Woodworking Software Support Forums Consoles Project Arcade Reviews
Automated Projects Artwork Frontend Support Forums Pinball Forum Discussion Old Boards
Raspberry Pi & Dev Board controls.dat Linux Miscellaneous Arcade Wiki Discussion Old Archives
Lightguns Arcade1Up --- Bug Reports --- Site News

Unread posts | New Replies | Recent posts | Rules | Chatroom | Wiki | File Repository | RSS | Submit news

  

Author Topic: Vsync on = sound stuttering, Vsync off = tearing  (Read 1435 times)

0 Members and 1 Guest are viewing this topic.

RVZ

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 67
  • Last login:May 08, 2019, 03:25:54 pm
    • Metal Slug!
Vsync on = sound stuttering, Vsync off = tearing
« on: September 08, 2010, 02:22:40 am »
I'm using the latest version of mame, and using HyperSpinFE as the frontend.  The graphics card is a Geforce 6600LE, connected to a tv through s-video.  When I turn vsync on I get sound stuttering / echoing.  When I turn it off, the sound is perfect, but then I get tearing.  Anything I can try to fix both?

isucamper

  • Trade Count: (+2)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 633
  • Last login:February 06, 2019, 02:28:33 pm
  • I'm a slasher... of prices!!
    • my project arcade blog
Re: Vsync on = sound stuttering, Vsync off = tearing
« Reply #1 on: September 08, 2010, 08:26:05 am »
Only way to get rid of the tearing is to turn vsync on.

You get stuttering with vsync on if the refresh rate for the resolution of your monitor does not match the native refresh rate of the game.  For instance, if your monitor is running at 60Hz, but the native refresh rate is 60.05 or something weird (a lot of old arcade games are weird like that) then the game only runs at 99% speed and the sound stutters. 

There are 2 solutions for this that I know of.  If you're fortunate enough to be using a multisync arcade monitor, use Soft15Khz or an ArcadeVGA video card to output the game's native resolution and refresh rate.  This is the best solution.

Alternatively, you can use SailorSat's cabMame (do a google search on cabMame) to run your games.  This version of MAME has a hack in it so the game will slow down just a fraction (imperceptibly) rather than stuttering if your refresh rates don't match. 
THE SYSTEM          Popeye

ragnar

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 454
  • Last login:November 22, 2013, 11:09:57 am
Re: Vsync on = sound stuttering, Vsync off = tearing
« Reply #2 on: September 08, 2010, 09:59:29 am »
Wow, I learned something new today.  Thanks isucamper !!!!
« Last Edit: September 08, 2010, 11:00:33 am by ragnar »
MY FIRST BUILD:

RVZ

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 67
  • Last login:May 08, 2019, 03:25:54 pm
    • Metal Slug!
Re: Vsync on = sound stuttering, Vsync off = tearing
« Reply #3 on: September 08, 2010, 10:06:48 am »
Alternatively, you can use SailorSat's cabMame (do a google search on cabMame) to run your games.  This version of MAME has a hack in it so the game will slow down just a fraction (imperceptibly) rather than stuttering if your refresh rates don't match. 

Cool, will give this a try, thanks for the advice.  I've been searching for this all day and lot's of people have this same problem.  First solution I've seen so far.  Will cabMame work with HyperspinFE?

RVZ

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 67
  • Last login:May 08, 2019, 03:25:54 pm
    • Metal Slug!
Re: Vsync on = sound stuttering, Vsync off = tearing
« Reply #4 on: September 08, 2010, 02:40:34 pm »
Ok, I downloaded cabmame, but it runs the games in a small window.  Can't seem to find where to make it fullscreen?

isucamper

  • Trade Count: (+2)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 633
  • Last login:February 06, 2019, 02:28:33 pm
  • I'm a slasher... of prices!!
    • my project arcade blog
Re: Vsync on = sound stuttering, Vsync off = tearing
« Reply #5 on: September 08, 2010, 03:56:06 pm »
Are you running the command line or windows version?  There should be a fullscreen option you can enable.  I'm not having this issue with the cabmame version i'm using but I don't remember the options off the top of my head. 
THE SYSTEM          Popeye

RVZ

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 67
  • Last login:May 08, 2019, 03:25:54 pm
    • Metal Slug!
Re: Vsync on = sound stuttering, Vsync off = tearing
« Reply #6 on: September 08, 2010, 04:31:48 pm »
There should be a fullscreen option you can enable.

It is running in fullscreen mode, but the image doesn't take up the whole screen, just a small part in the middle.

jtslade

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 746
  • Last login:July 16, 2019, 06:32:21 pm
  • Keep it looking originallish!
Re: Vsync on = sound stuttering, Vsync off = tearing
« Reply #7 on: September 08, 2010, 05:33:23 pm »
Is your triple buffeting on? Check your mame.ini



I have not been able to get frame tearing to stop but my setup is a dual format pal & NTSC tv using svideo Since pal-b is it's best looking format I run that. I was able to Get it to stop by using triple buffeting in NTSC but the video quality was awful so I decided that the frame tearing
« Last Edit: September 08, 2010, 05:36:37 pm by jtslade »
Ms. Pacman Original Cocktail with Non destructive mod to Groovy Arcade Linux with All 4way Vertical Cocktail capable 2 button or less games.


Neo Geo MVS Mame Cab Running Hyperspin, 25" Nanao Arcade Monitor, Mini-pac, ATI Radeon HD 4850 (ATOM-15), IL 8 Way Euro-Sticks from Paradise Arcade, Win XP 64bit, and tons of other junk.


RVZ

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 67
  • Last login:May 08, 2019, 03:25:54 pm
    • Metal Slug!
Re: Vsync on = sound stuttering, Vsync off = tearing
« Reply #8 on: September 08, 2010, 05:39:11 pm »
Played around with the settings in mame.ini and got the screen size sorted, but it feels like the games are running slower than what they're supposed to?  Unless the EmuMovies are playing faster?

I see the numprocessors is set to auto, should I change that?  I'm using a dual core cpu.

RayB

  • I'm not wearing pants! HA!
  • Trade Count: (+4)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 11275
  • Last login:September 17, 2018, 11:19:59 am
  • There's my post
    • RayB.com
Re: Vsync on = sound stuttering, Vsync off = tearing
« Reply #9 on: September 09, 2010, 12:55:06 pm »
The best way to diagnose these problems is to turn off all "effects" and extra video processing, set Vsync on, se if the problem is gone. If so, then you turn on the extras you absolutely need, until the problem comes back. Then you know the limitations of the system.

Another angle to try is reducing sound quality to 22.5

If your machine is Windows based, some options you might turn off will make things worse. In general you want DirectDraw on, and depending on your hardware Direct3D might help or it might hinder.
NO MORE!!