Main Restorations Software Audio/Jukebox/MP3 Everything Else Buy/Sell/Trade
Project Announcements Monitor/Video GroovyMAME Merit/JVL Touchscreen Meet Up Retail Vendors
Driving & Racing Woodworking Software Support Forums Consoles Project Arcade Reviews
Automated Projects Artwork Frontend Support Forums Pinball Forum Discussion Old Boards
Raspberry Pi & Dev Board controls.dat Linux Miscellaneous Arcade Wiki Discussion Old Archives
Lightguns Arcade1Up --- Bug Reports --- Site News

Unread posts | New Replies | Recent posts | Rules | Chatroom | Wiki | File Repository | RSS | Submit news

  

Author Topic: (OT) Golden Tee on Win2K  (Read 1100 times)

0 Members and 1 Guest are viewing this topic.

BuZz880

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 201
  • Last login:November 24, 2018, 02:59:13 pm
  • I'm a llama!
(OT) Golden Tee on Win2K
« on: June 21, 2003, 09:41:10 am »
I upgraded my cab to Win2K then noticed Golden Tee golf PC version is no longer playable.  It flashes a black screen for a second then back to the desktop.  This may be a dumb question but any thoughts on how I might trick it into working?  I mean it is a low tech game and plays supposedly on WIndows 95, 98 and I even heard XP so is there any way to work around this problem?

SirPoonga

  • Puck'em Up
  • Global Moderator
  • Trade Count: (+1)
  • Full Member
  • *****
  • Offline Offline
  • Posts: 8176
  • Last login:September 05, 2017, 09:45:52 am
  • The Bears Still Suck!
Re:(OT) Golden Tee on Win2K
« Reply #1 on: June 21, 2003, 11:52:07 am »
Got all the update and drivers for windows and the hardware?

BuZz880

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 201
  • Last login:November 24, 2018, 02:59:13 pm
  • I'm a llama!
Re:(OT) Golden Tee on Win2K
« Reply #2 on: June 21, 2003, 01:39:26 pm »
Yup, sure do I am have Win2K SP3 and Directx 9a.

Hey check this out, I figured I might as well try and find a different perhaps better golf game so I need something that will run 640x480 on my arcade monitor so I tried several - Tiger woods 99, PGA Pro 99 and 2000, Links 2000 and maybe a couple others all either sucked or wouldn't work.

I unistalled them all and guess what??? Now MAME runs at 100 times the speed it is supposed to.  Same thing in ZSNES, all my other emulators run fine.  In fact ZSNES shows the FPS as like 5 out of 60 even though it is running at about 600.

Obviously one of these old games changed something and of course I don't think Win2K has restore points so if anyone knows anything about D3D and Direct Draw - I think the problem is in there somewhere.

Yes, I reinstalled DX and SP3.  Next will be reinstall win2k... help!

Lilwolf

  • Trade Count: (+1)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 4943
  • Last login:May 06, 2020, 03:16:13 pm
Re:(OT) Golden Tee on Win2K
« Reply #3 on: June 21, 2003, 02:42:25 pm »
You probably have your vsync on in mame.  Rename the mame.ini to mame.old.ini or something... And run mame -cc again.  See if this fixes the problem... Then go from there.  But I'm pretty sure it will be the waitvsync option.

As for the other problem.  I don't know.  I don't have golden tee...  I personally never had much luck with games in W2k.  But I stopped trying back when it was a few versions of DX behind 98.

BuZz880

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 201
  • Last login:November 24, 2018, 02:59:13 pm
  • I'm a llama!
Re:(OT) Golden Tee on Win2K
« Reply #4 on: June 21, 2003, 03:32:28 pm »
Man I'm telling you guys this is something completely stupid here!... hehe.  I immediately tried a new mame.ini and a different version of mame and have the same problem.  It isn't a mame setting at all I don't think for 3 reasons:

1.  Same problem in ZSNES
2.  I can run MAME on my other computer - through my network using the setup on my cabinet with no problem!
3.  I noticed at the same timne the proble ocurred that my hardware acceleration had been turned off so I know it is one of the games I installed that did this.


DXDIAG shows no problems!!!!  Hmmmm...

BuZz880

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 201
  • Last login:November 24, 2018, 02:59:13 pm
  • I'm a llama!
Re:(OT) Golden Tee on Win2K
« Reply #5 on: June 21, 2003, 05:54:29 pm »
hmmmm, looks like MAME thinks it is only getting 2/60 FPS for some reason.  Thats why it looks fast it is autoframeskipping to try and get that up to 60 so is running 30 times faster than it should I can slow it down a little but then I am still missing 58 out of 60 frames - same deal in ZSNES... sigh.  It worked so well this morning.

Smack

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 306
  • Last login:May 07, 2013, 11:40:41 pm
  • Who changed my avatar?
Re:(OT) Golden Tee on Win2K
« Reply #6 on: June 21, 2003, 08:29:29 pm »
If I recall correctly, Golden Tee PC doesn't run on Windows 2000. I think you can't even install it from the disk.

Don't quote me though... ;D'

Smack
Never Let Donkey Kong Use Your Toilet.
(We're talkin' big processed brown bananas...)

Somebody out there stole my sig! LOL

Lilwolf

  • Trade Count: (+1)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 4943
  • Last login:May 06, 2020, 03:16:13 pm
Re:(OT) Golden Tee on Win2K
« Reply #7 on: June 21, 2003, 10:23:05 pm »
Last thing...

whats the chance that you have a HalfLife cheat (or some other online game cheat) running that allows you to get your powerups faster?

There are some that make your internal system clock think its running much faster (so all internal clocks reset themselfs faster on time based stuff).

Anyway, this kind of program could do it.



and last...  Why 2k?  

Win2k is a development platform.  98 is a gaming one.  XP is a good inbetween.  I never had much luck with 2k and games.  But man it was SO much better for development.

BuZz880

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 201
  • Last login:November 24, 2018, 02:59:13 pm
  • I'm a llama!
Re:(OT) Golden Tee on Win2K
« Reply #8 on: June 22, 2003, 11:45:10 am »
Alot of the move from WIn98SE was to get SDaphne working better but it turns out it isn't any better, it is the same as with WIn98.  

Didn't do XP Because XP was problematic it either hated my ArcadeVGA card or my ISA Slot soundblaster... anyway it wouldn't install.  I may try it again though because I noticed one of my memory cards was baked so that could have been the problem.  XP is not friendly when you are changing hardware all the time so thats a negative.  

Win98SE is decent but still basically an inferior OS.  Interestingly I now get about double the network speed off my cab using Win2k and much more stable video using all the same hardware as I did with win98SE.  Not that its all that important but it tells me something.  As for compatibility other than Golden Tee there are no compatibility issues.  If anything my emus all run better.  

This speed/FPS issue I have is tied to SP3 somehow because I reinstalled windows and everything was fine but when I reinstall SP3 it speeds up again.  Why this started is beyond me.  I am positive some old piece of software changed something I suspect it was Links LS 2000 demo.