Main Restorations Software Audio/Jukebox/MP3 Everything Else Buy/Sell/Trade
Project Announcements Monitor/Video GroovyMAME Merit/JVL Touchscreen Meet Up Retail Vendors
Driving & Racing Woodworking Software Support Forums Consoles Project Arcade Reviews
Automated Projects Artwork Frontend Support Forums Pinball Forum Discussion Old Boards
Raspberry Pi & Dev Board controls.dat Linux Miscellaneous Arcade Wiki Discussion Old Archives
Lightguns Arcade1Up --- Bug Reports --- Site News

Unread posts | New Replies | Recent posts | Rules | Chatroom | Wiki | File Repository | RSS | Submit news

  

Author Topic: My First Restoration - Galaga!  (Read 9926 times)

0 Members and 1 Guest are viewing this topic.

erlsjj

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 55
  • Last login:February 02, 2009, 06:38:31 am
My First Restoration - Galaga!
« on: December 16, 2008, 08:40:54 pm »
Sunday, 30 Nov 2008:
A good friend of mine invited me to an arcade auction up in Grandview, MO. He went home with a very nice Spy Hunter (with garbled music - which he fixed by replacing the digital analog converter), and I somehow became the proud new owner of my very own Galaga! I paid $200 for it ($197.75 if you count the 9 quarters I found inside the machine).
« Last Edit: December 17, 2008, 06:04:08 pm by erlsjj »

erlsjj

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 55
  • Last login:February 02, 2009, 06:38:31 am
Re: My First Restoration - Galaga!
« Reply #1 on: December 16, 2008, 09:01:55 pm »
Dec 1 - Dec 12, 2008:
The monitor worked, but no game. I measured the voltage going into the CPU PCB and it was reading 0.398V. Just a tad low. Variable resistor did nothing. After troubleshooting the power supply board, I found a bad 2N3055 transistor on the heat sink. I replaced the bad transistor as well as 4 bad diodes (all 4 were my fault which gave off some impressive blue smoke!), and after finding poor solder contact at the variable resistor (thanks, Jason), the power supply board was producing sufficient voltage (adjusted to +5.18V).
« Last Edit: December 17, 2008, 06:56:58 am by erlsjj »

erlsjj

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 55
  • Last login:February 02, 2009, 06:38:31 am
Re: My First Restoration - Galaga!
« Reply #2 on: December 16, 2008, 09:15:24 pm »
Friday, 12 Dec 2008:
With the power supply board now producing +5V (and +16V on the other pin - not sure why it's so high. Spec says it should be 13V?), I was hoping this would fix it, but all I see is a diagonal pattern of stars  and a high pitched single tone coming out of the speaker (I will post a video once I figure out how).


Sunday, 14 Dec 2008:
My friend helped me move my Galaga to my house. Boy, was the wife in for a surprise! ha ha! Turns out, she thought it was a pretty cool project to be working on (as did the kids).
« Last Edit: December 17, 2008, 06:03:10 pm by erlsjj »

erlsjj

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 55
  • Last login:February 02, 2009, 06:38:31 am
Re: My First Restoration - Galaga!
« Reply #3 on: December 16, 2008, 10:29:37 pm »
Monday, 15 Dec 2008:
Anyway, I took the CPU and video boards out to clean them. Pretty dusty. I pulled all the socketed chips off one by one and cleaned the legs with a small brass brush. I also checked the ribbon cable. Connectors and cable looked ok. I did notice the 1N chip on the video card was suspiciously missing with a jumper wire not attached to anything. Anyone know if I need this chip? According to the spec, 1N is supposed to be populated by a 07xx Custom IC. Did a little research and the 07xx chip is for the clock divider counter array (whatever that's for).

Tuesday, 16 Dec 2008:
Stuck for now. Started discussion thread to try and solicit any help/advice.

Wednesday, 17 Dec 2008:
I'm contemplating getting a new CPU board and/or video board, but I'd really like to isolate the problem first. Maybe it's that missing 1N chip...
« Last Edit: December 17, 2008, 07:07:04 am by erlsjj »

RayB

  • I'm not wearing pants! HA!
  • Trade Count: (+4)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 11275
  • Last login:September 20, 2019, 09:40:16 am
  • There's my post
    • RayB.com
Re: My First Restoration - Galaga!
« Reply #4 on: December 16, 2008, 11:22:21 pm »
Regarding your video... you're not supposed to use the "html" embedding code. Just click the little Youtube button when you post here (its right under the "BOLD" button) and then paste in the URL of the video.
NO MORE!!

erlsjj

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 55
  • Last login:February 02, 2009, 06:38:31 am
Re: My First Restoration - Galaga!
« Reply #5 on: December 16, 2008, 11:25:26 pm »
Thanks, RayB. I'll try that.

Mauzy

  • Trade Count: (+2)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 1191
  • Last login:December 03, 2018, 08:58:08 pm
Re: My First Restoration - Galaga!
« Reply #6 on: December 17, 2008, 12:10:06 am »
Wow. You sure work fast. Great find. My Galaga just died...

May I ask what you paid for that particular machine? (I never know when it is appropriate to ask...)
"Son, all hobbies suck. But if you keep at it, you might find you managed to kill some precious time."

erlsjj

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 55
  • Last login:February 02, 2009, 06:38:31 am
Re: My First Restoration - Galaga!
« Reply #7 on: December 17, 2008, 06:51:33 am »
No problem. I paid $200 for it (minus the 9 quarters I found inside heh heh!).

I'm really not that fast (but thanks!) - last night's postings were just a brief history going back to Thanksgiving Sunday when I bought the game. I actually only just moved it to my house last weekend. Before that it was at my friend's (that bought the Spy Hunter) warehouse since Thanksgiving so up to that point I was only able to work on the power supply board that I had removed from the machine.

I'm totally new at this, so any help or advise you or anyone else has would be greatly appreciated. I should have paid more attention in electric circuits class...

Sorry to hear your Galaga just died. What happened to it?

2600

  • Trade Count: (+7)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 1630
  • Last login:June 05, 2017, 10:20:56 am
  • I want my own arcade controls!
Re: My First Restoration - Galaga!
« Reply #8 on: December 17, 2008, 08:50:31 am »
I don't like the looks of those jumper wires.  You have a couple choices, start with the replacement 1N located
here: http://mikesarcade.com/cgi-bin/store.pl?sku=07xx

or get a working board which isn't cheap.

I wouldn't start trouble shooting the board until you replaced 1N.



Also, the rolling screen may just be the monitor is out of sync.  You may just need to adjust the sync on the back of the monitor.

Mauzy

  • Trade Count: (+2)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 1191
  • Last login:December 03, 2018, 08:58:08 pm
Re: My First Restoration - Galaga!
« Reply #9 on: December 17, 2008, 10:08:16 am »
No problem. I paid $200 for it (minus the 9 quarters I found inside heh heh!).

I'm really not that fast (but thanks!) - last night's postings were just a brief history going back to Thanksgiving Sunday when I bought the game. I actually only just moved it to my house last weekend. Before that it was at my friend's (that bought the Spy Hunter) warehouse since Thanksgiving so up to that point I was only able to work on the power supply board that I had removed from the machine.

I'm totally new at this, so any help or advise you or anyone else has would be greatly appreciated. I should have paid more attention in electric circuits class...

Sorry to hear your Galaga just died. What happened to it?

Good deal!

I'm not sure yet. I've been having problems with it blowing out processors every couple weeks. Yesterday I turned it on and it came up with garbage and tones. It actually does something different every time I plug it in. I'm probably going to send it to GLS1 electronics for repair. I don't get anything in return for this, but if you can't get your board working, I highly recommend them. I'll get you a link in a little while. He has a stand alone website, but if you go on eBay you can buy his repair services for (I think) $100 plus shipping. This includes all parts and labor, you would want to let him know of that chip missing first though.

Have you looked at the other Galaga threads on this site to get a feel for the boards? Apparently these were manufactured with low quality chip sockets. I've found that out the hard way.

"Son, all hobbies suck. But if you keep at it, you might find you managed to kill some precious time."

2600

  • Trade Count: (+7)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 1630
  • Last login:June 05, 2017, 10:20:56 am
  • I want my own arcade controls!
Re: My First Restoration - Galaga!
« Reply #10 on: December 17, 2008, 10:43:20 am »
If you guys haven't done it yet, you should also look at recapping your PCB and Power Supplies.  Unknown Power supply instability is something I prefer not to deal with while trouble shooting.

JeepMonkey

  • Trade Count: (+1)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 653
  • Last login:July 13, 2012, 01:51:24 pm
Re: My First Restoration - Galaga!
« Reply #11 on: December 17, 2008, 12:55:18 pm »
Did you get that from the auction in Grandview on November 30?  I was there and remember overhearing a guy talking to a friend about the Spy Hunter he won.  I was interested in the two Galagas there, but I have too many projects right now to take on another one.  I was really more interested in a pin, and they had a good number of them.  Unfortunately I had to way to haul anything.

Good luck and nice buy.
Pins:  Theatre Of Magic, JP The Lost World, Revenge From Mars

erlsjj

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 55
  • Last login:February 02, 2009, 06:38:31 am
Re: My First Restoration - Galaga!
« Reply #12 on: December 17, 2008, 06:13:01 pm »
I don't like the looks of those jumper wires.  You have a couple choices, start with the replacement 1N located
here: http://mikesarcade.com/cgi-bin/store.pl?sku=07xx

or get a working board which isn't cheap.

I wouldn't start trouble shooting the board until you replaced 1N.



Also, the rolling screen may just be the monitor is out of sync.  You may just need to adjust the sync on the back of the monitor.

Yeah, I don't like the look of those jumper wires either. I take it the 1N chip is essential. I think I'll order that first and possibly the 4H chip (with the other jumper). Thanks for the link, 2600! I'll have a look at the monitor sync as well.

Cheers!

erlsjj

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 55
  • Last login:February 02, 2009, 06:38:31 am
Re: My First Restoration - Galaga!
« Reply #13 on: December 17, 2008, 10:00:06 pm »
Good deal!

I'm not sure yet. I've been having problems with it blowing out processors every couple weeks. Yesterday I turned it on and it came up with garbage and tones. It actually does something different every time I plug it in. I'm probably going to send it to GLS1 electronics for repair. I don't get anything in return for this, but if you can't get your board working, I highly recommend them. I'll get you a link in a little while. He has a stand alone website, but if you go on eBay you can buy his repair services for (I think) $100 plus shipping. This includes all parts and labor, you would want to let him know of that chip missing first though.

Have you looked at the other Galaga threads on this site to get a feel for the boards? Apparently these were manufactured with low quality chip sockets. I've found that out the hard way.



I stumbled across GLS1 in my world wide interweb researching, and they seem pretty good. If I can't figure it out, I'll probably utilize their services. But even though I'm pretty new at all this, I kind of enjoy the process of trying to figure out how to fix stuff (the engineer in me, I guess).

I've read through a few of the threads, and definitely gleaned some info from them. Most impressive so far was Galaga: Diary of a Renovation. That posting really inspired me (even though my renovation won't be nearly as good).

Mauzy

  • Trade Count: (+2)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 1191
  • Last login:December 03, 2018, 08:58:08 pm
Re: My First Restoration - Galaga!
« Reply #14 on: December 17, 2008, 10:05:31 pm »
I kind of enjoy the process of trying to figure out how to fix stuff (the engineer in me, I guess).


I'm the same way to a point. I'll work on a board set only until I genuinely consider setting fire to the whole thing. THATS when it is time to let the professionals to step in.  ;D
"Son, all hobbies suck. But if you keep at it, you might find you managed to kill some precious time."

erlsjj

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 55
  • Last login:February 02, 2009, 06:38:31 am
Re: My First Restoration - Galaga!
« Reply #15 on: December 17, 2008, 10:05:51 pm »
If you guys haven't done it yet, you should also look at recapping your PCB and Power Supplies.  Unknown Power supply instability is something I prefer not to deal with while trouble shooting.

Good point, 2600. I'll put it on the list of things to do for my project. Would a bad capacitor on the power supply board have anything to do with my +V. Audio outputing more voltage than the spec (16-17V versus 13V)?

erlsjj

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 55
  • Last login:February 02, 2009, 06:38:31 am
Re: My First Restoration - Galaga!
« Reply #16 on: December 17, 2008, 10:11:43 pm »
Did you get that from the auction in Grandview on November 30?  I was there and remember overhearing a guy talking to a friend about the Spy Hunter he won.  I was interested in the two Galagas there, but I have too many projects right now to take on another one.  I was really more interested in a pin, and they had a good number of them.  Unfortunately I had to way to haul anything.

Good luck and nice buy.

Sure did! I said Kansas City in my first posting, but I meant Grandview. That was me talkinig to my friend, Jason, who bid against this guy that bought something like 13 or 14 various games and pinballs. Crazy!

Even though they got the other Galaga to work, I didn't like the condition of the cabinet. This is my first arcade project, so I'm looking forward to learning a lot from other more experienced folks like yourself.

erlsjj

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 55
  • Last login:February 02, 2009, 06:38:31 am
Re: My First Restoration - Galaga!
« Reply #17 on: December 17, 2008, 10:14:41 pm »
I'm the same way to a point. I'll work on a board set only until I genuinely consider setting fire to the whole thing. THATS when it is time to let the professionals to step in.  ;D

I think I'm going to take 2600's advice and look at replacing the 1N chip as my next step and see what happens.

Mauzy

  • Trade Count: (+2)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 1191
  • Last login:December 03, 2018, 08:58:08 pm
Re: My First Restoration - Galaga!
« Reply #18 on: December 17, 2008, 10:21:24 pm »
good idea
"Son, all hobbies suck. But if you keep at it, you might find you managed to kill some precious time."

erlsjj

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 55
  • Last login:February 02, 2009, 06:38:31 am
Re: My First Restoration - Galaga!
« Reply #19 on: December 18, 2008, 10:53:08 pm »
Thursday, 18 Dec 2008:
Progress! Looking at some other threads, I read that the 07xx chip is used in two places on Galaga boards: 1N on the video board, and 4D on the CPU board. I confirmed this in the schematics. So I moved the 07xx chip from 4D to 1N to see if that would change anything, and it did! Here's a picture of the screen now:

MikesArcade.com is currently out of stock of 07xx chips. Anyone know another reputable place to get 07xx chips?

Also noted that the high pitched tone went away.
« Last Edit: January 11, 2009, 10:19:00 pm by erlsjj »

erlsjj

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 55
  • Last login:February 02, 2009, 06:38:31 am
Re: My First Restoration - Galaga!
« Reply #20 on: December 18, 2008, 11:02:03 pm »
Also, the rolling screen may just be the monitor is out of sync.  You may just need to adjust the sync on the back of the monitor.

Where exactly is the sync adjust on the back of the monitor? I didn't want to go poking around aimlessly back there and get zapped. I did find the focus and the brightness adjust knobs.

Mauzy

  • Trade Count: (+2)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 1191
  • Last login:December 03, 2018, 08:58:08 pm
Re: My First Restoration - Galaga!
« Reply #21 on: December 18, 2008, 11:22:47 pm »
GAH!! I HATE TIMEOUTS!!!


Anyway, nice to see that change.  Definitely a good sign.


As for the sync, what kind of monitor does it have? If its the stock G07, you can find it here (remember yours will be rotated)



If you're not sure what kind of monitor you have, post a picture of the chassis (monitor boards) and we'll help you out. If you don't have a G07, the sync adjust may be in a completely different place.
"Son, all hobbies suck. But if you keep at it, you might find you managed to kill some precious time."

erlsjj

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 55
  • Last login:February 02, 2009, 06:38:31 am
Re: My First Restoration - Galaga!
« Reply #22 on: December 19, 2008, 12:15:58 am »
Thanks, Mauzy. Looks like I do have a G07. The one you have circled corresponds with mine that is labeled V. Hold. The other ones are labeled V. Lin, V. Height, and H. Freq.
And H. Cent doesn't have a control attached to it. Now that I swapped the 4D chip out to 1N, the vertical hold seems to be ok. I assume you just turn them with a screwdriver to adjust.

Any recommendations on where else to get a 07xx chip?

Mauzy

  • Trade Count: (+2)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 1191
  • Last login:December 03, 2018, 08:58:08 pm
Re: My First Restoration - Galaga!
« Reply #23 on: December 19, 2008, 09:39:04 am »
Thanks, Mauzy. Looks like I do have a G07. The one you have circled corresponds with mine that is labeled V. Hold. The other ones are labeled V. Lin, V. Height, and H. Freq.
And H. Cent doesn't have a control attached to it. Now that I swapped the 4D chip out to 1N, the vertical hold seems to be ok. I assume you just turn them with a screwdriver to adjust.

Any recommendations on where else to get a 07xx chip?

Yes sir you have a G07(or something incredibly close). A screwdriver should be fine. Theres also a little bitty tab on the top you could hit with your thumbnail, but with it mounted vertically I don't know if this would work.

H.Cent is actually changed with a jumper on one of three metal tabs on the board. Honestly, I've never had this control work when I changed the jumper.

BTW, and I'm sure you figured this out but In searching for a 07xx chip, I found the definitions for all the chips. 07xx is indeed a sync generator.

Sadly, the site I always use (mikesarcade.com) is out of the 07xx chip. Turns out they're $30 too! You might want to go to his site and contact him. I know he posts here too, but I'mnot sure of his screen name. I'm sure if you search hard enough you'll find one somewhere. 

Oh you already said that.  ;D I can't find anywhere but therealbobroberts.net . I've ordered from them before and they're great! Their only drawback is you can only pay through money order so you have to wait for them to receive that, then they ship. On the plus side his 07xx is only $20. I usually only order from them when I have a big list because he has awesome prices, might as well only wait once for everything. Be sure to read his shipping, payment, and ordering faqs if you want to order from him.
« Last Edit: December 19, 2008, 09:51:07 am by Mauzy »
"Son, all hobbies suck. But if you keep at it, you might find you managed to kill some precious time."

orion

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 648
  • Last login:January 11, 2018, 09:50:50 am
Re: My First Restoration - Galaga!
« Reply #24 on: December 19, 2008, 10:11:11 am »
Radio shack has a set of TV tuning tools for around $5.00. They are made out of plastic so you won't get zapped tuning your monitor. You will need it if you have to make an adjustment to your horizontal with coil. Don't use an allen wrench for that, it will bite you good if you do..... trust me!

erlsjj

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 55
  • Last login:February 02, 2009, 06:38:31 am
Re: My First Restoration - Galaga!
« Reply #25 on: December 20, 2008, 07:13:36 am »
Thanks for the info, Mauzy & Orion. My project will be on hold as of next Tuesday as the I'm taking my wife and kids to........Disneyworld!

Mauzy

  • Trade Count: (+2)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 1191
  • Last login:December 03, 2018, 08:58:08 pm
Re: My First Restoration - Galaga!
« Reply #26 on: December 20, 2008, 10:04:11 am »
Have fun with that. Its been 10 years since I've been to Disneyworld. I wouldn't mind going back.
"Son, all hobbies suck. But if you keep at it, you might find you managed to kill some precious time."

erlsjj

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 55
  • Last login:February 02, 2009, 06:38:31 am
Re: My First Restoration - Galaga!
« Reply #27 on: December 20, 2008, 02:15:31 pm »
I can't find anywhere but therealbobroberts.net . I've ordered from them before and they're great! Their only drawback is you can only pay through money order so you have to wait for them to receive that, then they ship. On the plus side his 07xx is only $20. I usually only order from them when I have a big list because he has awesome prices, might as well only wait once for everything. Be sure to read his shipping, payment, and ordering faqs if you want to order from him.

Great site! Thanks, Mauzy. I emailed Bob this morning with a list of parts I need:
1- .156 right angle header
1- .156 molex connector (5 pin)
1- .156 molex connector (6 pin)
1- 07xx custom chip
2- Galaga gold leaf buttons

Just waiting to hear back from him. Looks like if you are in the USA you can pay by check, bank check or money order. International orders require a bank draft or money order in US funds. I'm going to do a little houscleaning on the cabinet while I wait on that.

erlsjj

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 55
  • Last login:February 02, 2009, 06:38:31 am
Re: My First Restoration - Galaga!
« Reply #28 on: December 21, 2008, 07:00:14 am »
Bummer...Bob Roberts is is fresh out of 07xx chips  :'(
Does anyone know anywhere else I can get 07xx chips besides MikesArcade or TheRealBobRoberts?

erlsjj

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 55
  • Last login:February 02, 2009, 06:38:31 am
Re: My First Restoration - Galaga!
« Reply #29 on: December 22, 2008, 07:14:52 am »
Got a lead on a replacement for my 07xx chip from fpgaarcade.com (thanks, 2600!). Waiting to hear back...
« Last Edit: December 22, 2008, 07:10:16 pm by erlsjj »

erlsjj

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 55
  • Last login:February 02, 2009, 06:38:31 am
Re: My First Restoration - Galaga!
« Reply #30 on: January 01, 2009, 03:20:20 pm »
Thursday, Jan 1, 2009:
Just back from Christmas vacation in Florida. Parts arrived from Bob Roberts (minus 07xx chip  :-[). Got rid of power supply board hard wiring and replaced with right angle header and Molex connector.
« Last Edit: January 01, 2009, 03:23:16 pm by erlsjj »

erlsjj

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 55
  • Last login:February 02, 2009, 06:38:31 am
Re: My First Restoration - Galaga!
« Reply #31 on: January 02, 2009, 07:12:14 pm »
Friday, Jan 2, 2009:
Ordered a C07 chip for $22 (plus $6 shipping & handling) from fpgaarcade.com to replace my 07xx chip. Should be here sometime next week...

erlsjj

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 55
  • Last login:February 02, 2009, 06:38:31 am
Re: My First Restoration - Galaga!
« Reply #32 on: January 05, 2009, 12:49:07 pm »
Jan 4-5, 2009:
Removed the control panel to work on over the weekend. The control panel overlay will need replaced for sure (I guess I'll have to lose the Led Zepplin scratched into it). CPO now on order from Mike's Arcade.

erlsjj

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 55
  • Last login:February 02, 2009, 06:38:31 am
Re: My First Restoration - Galaga!
« Reply #33 on: January 05, 2009, 12:54:50 pm »
Missing joystick mounting hardware will need replaced...

erlsjj

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 55
  • Last login:February 02, 2009, 06:38:31 am
Re: My First Restoration - Galaga!
« Reply #34 on: January 05, 2009, 01:01:39 pm »
Yucky rust on the joystick! Decided to focus on that for now. Took it apart (I hope I can remember how it all goes back together!).

erlsjj

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 55
  • Last login:February 02, 2009, 06:38:31 am
Re: My First Restoration - Galaga!
« Reply #35 on: January 05, 2009, 01:03:37 pm »
CLR is what I used. Works great! I even cleaned my rusted socket set.

erlsjj

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 55
  • Last login:February 02, 2009, 06:38:31 am
Re: My First Restoration - Galaga!
« Reply #36 on: January 05, 2009, 01:05:21 pm »
Primer & paint.

erlsjj

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 55
  • Last login:February 02, 2009, 06:38:31 am
Re: My First Restoration - Galaga!
« Reply #37 on: January 06, 2009, 08:35:27 pm »
Tuesday, Jan 6, 2009:
Just like new! In hindsight, I probably shouldn't have painted the rotating shaft.

erlsjj

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 55
  • Last login:February 02, 2009, 06:38:31 am
Re: My First Restoration - Galaga!
« Reply #38 on: January 06, 2009, 08:37:49 pm »
Back together again.

Mauzy

  • Trade Count: (+2)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 1191
  • Last login:December 03, 2018, 08:58:08 pm
Re: My First Restoration - Galaga!
« Reply #39 on: January 06, 2009, 11:46:33 pm »
Jan 4-5, 2009:
Removed the control panel to work on over the weekend. The control panel overlay will need replaced for sure (I guess I'll have to lose the Led Zepplin scratched into it). CPO now on order from Mike's Arcade.

At least they had good musical taste...

The joystick looks great! Looks a helluva lot better than mine, that's for sure.
"Son, all hobbies suck. But if you keep at it, you might find you managed to kill some precious time."