Main Restorations Software Audio/Jukebox/MP3 Everything Else Buy/Sell/Trade
Project Announcements Monitor/Video GroovyMAME Merit/JVL Touchscreen Meet Up Retail Vendors
Driving & Racing Woodworking Software Support Forums Consoles Project Arcade Reviews
Automated Projects Artwork Frontend Support Forums Pinball Forum Discussion Old Boards
Raspberry Pi & Dev Board controls.dat Linux Miscellaneous Arcade Wiki Discussion Old Archives
Lightguns --- Bug Reports --- Site News

Unread posts | New Replies | Recent posts | Rules | Chatroom | Wiki | File Repository | RSS | Submit news

  

Author Topic: SB64 issues on a HP Vectra (swap from Dell)  (Read 3588 times)

0 Members and 1 Guest are viewing this topic.

danvan

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 19
  • Last login:April 14, 2008, 12:29:15 am
  • I'm a llama!
SB64 issues on a HP Vectra (swap from Dell)
« on: March 31, 2008, 08:12:11 am »
Hi all,

I have recently been having problems with my Dell P3 667 desktop that has been happily running Win98 DOS mode and AdvanceMAME for around 5 years. (I don't know the model as the case is long lost). It had been unplugged for quite some time and had started to lose BIOS settings. I removed the BIOS battery and ever since then I have been getting no video and just a 1-3-2 sequence of beeps which indicate no memory, as far as I can tell. I have swapped out the RAM with known good RAM, and tested its RAM in another PC, so I can only assume the motherboard is toast.

SO... I have switched from my brilliant piece of handy work over to a HP Vectra with a 997MHz P3 ('slot 1' CPU I think) with a Phoenix BIOS 4.0 rev 6.0 (p/n D9820-60009 I think??). I moved my Creative SB64, Diamond Viper V330 and HDD over without a problem, except... the DOS PCI Sound Blaster drivers are spitting out an error when loading...

"Could not allocate code/patch RAM below 4 MByte boundary. Try loading SBInit.com before SMARTDRV.EXE or minimising VDISK RAM. PCI audio driver NOT loading"

I am using the DOS drivers from easymamecab.mameworld.net/html/snddosdr.htm. I suspect the on-board USB ports to be causing an IRQ conflict as it appeared to be on IRQ5 in Win98's device manager (is there a DOS way to check??), but there is no way to disable them completely that I can see - only turn them off such that a PnP OS can see them. I have disabled everything else I can in BIOS (LPR, serial, etc).

Now, I have already searched high and low and there are plenty of people out there reporting the same error. Problem is none of them seem to have found a solution!!

Below are my config.sys and autoexec.bat.


CF.sys:

DOS=HIGH,UMB
FILES=15
BUFFERS=15
DEVICE=C:\WINDOWS\HIMEM.SYS
DEVICE=C:\WINDOWS\EMM386.EXE NOEMS NOVCPI
DEVICEHIGH=C:\TOOLS\OAKCDROM.SYS /D:MSCD001


AE.bat:

SET SNDSCAPE=C:\WINDOWS
set path=%path%;c:\tools;c:\mame;c:\
LH c:\tools\MSCDEX.EXE /D:mscd001 /l:f
SET BLASTER=A220 I7 D1 H7 P330 T6
SET SBPCI=C:\DOSDRV
C:\DOSDRV\SBLOAD
C:\DOSDRV\SBINIT.COM   <------------------------ this is what errors!
C:\WINDOWS\SMARTDRV.EXE
c:\tools\mouse\ctmouse.exe
SET BLASTER=A220 I7 D1 T2
c:\tools\csdpmi3b\bin\cwsdpmi -p

I have tried removing the extra drivers (CD / mouse), the path, changing the SET statements... I really think they should be okay though, as it is the same hardware configuration except for the motherboard.

So... this is a triple question.

1. Does anyone know how to fix my Dell's complaints of no memory, where I clearly do have working RAM?
2. Does anyone know how to get past the issue with my SB64 on the HP Vectra?
3. Does anyone know how to get the on-board sound card of the HP Vectra working under pure DOS?

Thanks in advance!

Cheers
Daniel

tikbalang

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 234
  • Last login:May 07, 2013, 05:04:54 pm
    • MAME BootCD's for DOS
Re: SB64 issues on a HP Vectra (swap from Dell)
« Reply #1 on: April 03, 2008, 11:48:57 pm »
already answered in the main forum.