Main Restorations Software Audio/Jukebox/MP3 Everything Else Buy/Sell/Trade
Project Announcements Monitor/Video GroovyMAME Merit/JVL Touchscreen Meet Up Retail Vendors
Driving & Racing Woodworking Software Support Forums Consoles Project Arcade Reviews
Automated Projects Artwork Frontend Support Forums Pinball Forum Discussion Old Boards
Raspberry Pi & Dev Board controls.dat Linux Miscellaneous Arcade Wiki Discussion Old Archives
Lightguns --- Bug Reports --- Site News

Unread posts | New Replies | Recent posts | Rules | Chatroom | Wiki | File Repository | RSS | Submit news

  

Author Topic: Newbie Songpath Problem  (Read 4583 times)

0 Members and 1 Guest are viewing this topic.

i_n0thing

  • Trade Count: (0)
  • Jr. Member
  • **
  • Offline Offline
  • Posts: 4
  • Last login:May 03, 2012, 12:43:17 am
Newbie Songpath Problem
« on: March 17, 2008, 04:20:20 pm »
Saw this question posted before, but I'm still having a problem. After Installing Wincab and executing, i receive the message:

FATAL ERROR
No songs found!
Check the Song Path setting in JUKEBOX.INI

This is after i can see it finding the different folders. Even specifing a band folder it still comes up. The index is set to search the drive folder:

SongPath1 = F:\MP3

and set:

MaxFolderDepth = 4.

The majority of my music files are MP3 files. I have some M4A, WMA and APE files, but they're not supported so I'm guessing that those files are just ignored. Looking throu the debug log i find:


0:00:04.23-LVL2-INDEXER-LOOP: Entering folder Xmal Deutschland...
0:00:04.23-LVL5-STATUS: Updating database/Xmal Deutschland
0:00:04.24-LVL3-INDEXER-LOOP: Art for this folder (mask 1): F:\MP3\Xmal Deutschland\Folder.jpg
0:00:04.24-LVL2-INDEXER-LOOP: Entering folder Fetisch...
0:00:04.24-LVL5-STATUS: Updating database/Fetisch
0:00:04.24-LVL3-INDEXER-LOOP: Art for this folder (mask 1): F:\MP3\Xmal Deutschland\Fetisch\Folder.jpg
0:00:04.24-LVL3-INDEXER-LOOP: Working on Xmal Deutschland - Fetisch - 01 - Qual.mp3 (5495412 bytes)...
0:00:04.24-LVL4-INDEXER-LOOP: No match (no pointer). File ID=495412XMAL

changing the artist info for all the other folders I have.

Am I receiving this error message because I have multiple file types sharing the same folder or have I missed something?

Thanks in advance for any help.

~ian~

Chris

  • Moderator
  • Trade Count: (+2)
  • Full Member
  • *****
  • Offline Offline
  • Posts: 4572
  • Last login:December 22, 2014, 10:29:47 pm
    • Chris's MAME Cabinet
Re: Newbie Songpath Problem
« Reply #1 on: March 17, 2008, 04:30:27 pm »
Having mixed media shouldn't be the problem... as you've surmised, the unsupported files should just be ignored.  And according to the log snippet you posted, at least one MP3 song should be found.

Delete the contents of the DATA directory, run the program, and look through the debiug log again.  At the end of the list of artists and songs there should be a summary that lists the number of songs found and the time it took to find them.   What does this summary say?
--Chris
DOSCab/WinCab Jukebox: http://www.dwjukebox.com

i_n0thing

  • Trade Count: (0)
  • Jr. Member
  • **
  • Offline Offline
  • Posts: 4
  • Last login:May 03, 2012, 12:43:17 am
Re: Newbie Songpath Problem
« Reply #2 on: March 17, 2008, 04:47:31 pm »
This is from the last folder to the end of the report.

0:00:04.70-LVL5-STATUS: Updating database/Zevon, Warren [skiped]
0:00:04.71-LVL3-INDEXER-LOOP: No art found for this folder
0:00:04.71-LVL3-INDEXER-LOOP: Working on Zevon, Warren - Lawyers Guns and Money.mp3 (3366912 bytes)...
0:00:04.71-LVL4-INDEXER-LOOP: No match (no pointer). File ID=366912ZEVO
0:00:04.71-LVL3-INDEXER-LOOP: Working on Zevon, Warren - Roland The Headless Thompson Gunner.mp3 (3656769 bytes)...
0:00:04.71-LVL4-INDEXER-LOOP: No match (no pointer). File ID=656769ZEVO
0:00:04.71-LVL3-INDEXER-LOOP: Working on Zevon, Warren - Werewolves Of London.mp3 (3215082 bytes)...
0:00:04.71-LVL4-INDEXER-LOOP: No match (no pointer). File ID=215082ZEVO
0:00:04.71-LVL0-INDEXER: FATAL: No songs found! Check the SongPath setting in JUKEBOX.INI
0:00:08.68-LVL1-QUEUE_EXIT: Cleaning up songbuf...
0:00:08.68-LVL1-GUI_EXIT: Cleaning up GUI...
0:00:08.68-LVL1-GUI_EXIT: Idle loop average not calculated, idle loop did not start
0:00:08.68-LVL1-SSAVER_EXIT: Cleaning up ssaver...
0:00:08.68-LVL1-SONGBUF_EXIT: Cleaning up songbuf...
0:00:08.68-LVL1-TITLESTRIPS_EXIT: Cleaning up titlestrips...
0:00:08.68-LVL1-SONGLIST_EXIT: Cleaning up songlist...
0:00:08.68-LVL0-SHUTDOWN: Unexpected shutdown
0:00:08.68-LVL5-DEBUGLOG_EXIT: DWJukebox 3.1.5 Exited

Chris

  • Moderator
  • Trade Count: (+2)
  • Full Member
  • *****
  • Offline Offline
  • Posts: 4572
  • Last login:December 22, 2014, 10:29:47 pm
    • Chris's MAME Cabinet
Re: Newbie Songpath Problem
« Reply #3 on: March 17, 2008, 09:59:29 pm »
And what files are in the DATA directory at this point?  Can you ZIP them up and attach them to this thread?
--Chris
DOSCab/WinCab Jukebox: http://www.dwjukebox.com

i_n0thing

  • Trade Count: (0)
  • Jr. Member
  • **
  • Offline Offline
  • Posts: 4
  • Last login:May 03, 2012, 12:43:17 am
Re: Newbie Songpath Problem
« Reply #4 on: March 18, 2008, 01:28:08 pm »
The DATA folder is empty, but here's the zip with that and the jbdebug file and the config file. I changed the location of the MP3s to a folder with just three bands instead of the whole 30 gig folder.

Chris

  • Moderator
  • Trade Count: (+2)
  • Full Member
  • *****
  • Offline Offline
  • Posts: 4572
  • Last login:December 22, 2014, 10:29:47 pm
    • Chris's MAME Cabinet
Re: Newbie Songpath Problem
« Reply #5 on: March 18, 2008, 01:46:17 pm »
If the DATA folder is empty it is unable to create the database file for some reason.  Check for any of the following:

- The DATA folder being marked as read-only
- The current user not having permission to write to the DATA folder
- jukebox.db being created somewhere other than the DATA folder.  This might happen if you were trying to run the jukebox as a shell or from a misconfigured batch file or front end.

--Chris
DOSCab/WinCab Jukebox: http://www.dwjukebox.com

i_n0thing

  • Trade Count: (0)
  • Jr. Member
  • **
  • Offline Offline
  • Posts: 4
  • Last login:May 03, 2012, 12:43:17 am
Re: Newbie Songpath Problem
« Reply #6 on: March 19, 2008, 06:29:02 pm »
As it turns out, I'm using TagTuner to edit the ID3 tags, and it changes all MP3 files to MPEG Audio files. That would be why I'm not able to get it to work. Go figure. Once i'm done with that I'll try it again.

I'll go bang my head against the wall now.


Thanks for all the help.


~ian~