Main Restorations Software Audio/Jukebox/MP3 Everything Else Buy/Sell/Trade
Project Announcements Monitor/Video GroovyMAME Merit/JVL Touchscreen Meet Up Retail Vendors
Driving & Racing Woodworking Software Support Forums Consoles Project Arcade Reviews
Automated Projects Artwork Frontend Support Forums Pinball Forum Discussion Old Boards
Raspberry Pi & Dev Board controls.dat Linux Miscellaneous Arcade Wiki Discussion Old Archives
Lightguns --- Bug Reports --- Site News

Unread posts | New Replies | Recent posts | Rules | Chatroom | Wiki | File Repository | RSS | Submit news

  

Author Topic: Doscab index problem  (Read 2171 times)

0 Members and 1 Guest are viewing this topic.

Alan sinking

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 13
  • Last login:December 16, 2006, 05:55:54 am
  • I want to build my own arcade controls!
Doscab index problem
« on: October 16, 2005, 10:14:52 am »
I have a problem when updating the database with doscab.
I drop a new folder (Album) into my music folder with all mp3 tracks & cover art.
If I delete all data and run Wincab it updates the index with no problems.
When I run doscab to update the index it searches my music folder finding everything and then searches again duplicating some Album folders, brings up errors and loses some cover art .
Please can you let me know if I am doing something wrong or is there a bug in doscab.

Chris

  • Moderator
  • Trade Count: (+2)
  • Full Member
  • *****
  • Offline Offline
  • Posts: 4572
  • Last login:December 22, 2014, 10:29:47 pm
    • Chris's MAME Cabinet
Re: Doscab index problem
« Reply #1 on: October 21, 2005, 01:33:36 pm »
Not sure... do you have more than one SongPath set?  What SongPath settings are you using?
--Chris
DOSCab/WinCab Jukebox: http://www.dwjukebox.com

Alan sinking

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 13
  • Last login:December 16, 2006, 05:55:54 am
  • I want to build my own arcade controls!
Re: Doscab index problem
« Reply #2 on: October 21, 2005, 05:21:58 pm »
the only songpath i have set is as follows.
SongPath1 = C:\cab\music
all the separate albums & cover art are in their own folders within the Music folder

Chris

  • Moderator
  • Trade Count: (+2)
  • Full Member
  • *****
  • Offline Offline
  • Posts: 4572
  • Last login:December 22, 2014, 10:29:47 pm
    • Chris's MAME Cabinet
Re: Doscab index problem
« Reply #3 on: October 21, 2005, 05:29:07 pm »
the only songpath i have set is as follows.
SongPath1 = C:\cab\music
all the separate albums & cover art are in their own folders within the Music folder
Hm.  Try changing SongPath1 to SongPath; this will eliminate the implied "SongPath=." from being searched.  Either way, this is a bug....
--Chris
DOSCab/WinCab Jukebox: http://www.dwjukebox.com

Alan sinking

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 13
  • Last login:December 16, 2006, 05:55:54 am
  • I want to build my own arcade controls!
Re: Doscab index problem
« Reply #4 on: October 22, 2005, 07:54:37 am »
I Tried changing SongPath1 to SongPath; to eliminate the implied "SongPath=." from being searched.
Works ok in wincab but Still the same problem in Doscab

Chris

  • Moderator
  • Trade Count: (+2)
  • Full Member
  • *****
  • Offline Offline
  • Posts: 4572
  • Last login:December 22, 2014, 10:29:47 pm
    • Chris's MAME Cabinet
Re: Doscab index problem
« Reply #5 on: October 22, 2005, 09:23:27 am »
OK.  In jukebox.ini, set your debug level to 5, go through the steps to reproduce the problem, and send me the resulting jukebox.db and jbdebug.log files, and I'll see what I can figure out.

Thanks!

--Chris
--Chris
DOSCab/WinCab Jukebox: http://www.dwjukebox.com

Alan sinking

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 13
  • Last login:December 16, 2006, 05:55:54 am
  • I want to build my own arcade controls!
Re: Doscab index problem
« Reply #6 on: October 23, 2005, 10:05:52 am »
Hi, Chris
Debug log sent to your email address
Thanks.
Alan