Main Restorations Software Audio/Jukebox/MP3 Everything Else Buy/Sell/Trade
Project Announcements Monitor/Video GroovyMAME Merit/JVL Touchscreen Meet Up Retail Vendors
Driving & Racing Woodworking Software Support Forums Consoles Project Arcade Reviews
Automated Projects Artwork Frontend Support Forums Pinball Forum Discussion Old Boards
Raspberry Pi & Dev Board controls.dat Linux Miscellaneous Arcade Wiki Discussion Old Archives
Lightguns Arcade1Up --- Bug Reports --- Site News

Unread posts | New Replies | Recent posts | Rules | Chatroom | Wiki | File Repository | RSS | Submit news

  

Author Topic: Troubleshooting Various Emulator Setups.  (Read 170 times)

0 Members and 1 Guest are viewing this topic.

DJRobbyD

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 13
  • Last login:September 16, 2020, 01:43:21 pm
  • I want to build my own arcade controls!
Troubleshooting Various Emulator Setups.
« on: September 14, 2020, 02:41:12 pm »
Pretty new to this, so please be patient and any advice is appreciated and will be used.

I bought a cheap Thrustmaster to test on my cabinet. It worked well enough on Project 64 and Demul, so I bought a mount to play comfortably. I mounted the wheel and pedals (didnt even unplug them) and it stopped steering. I read somewhere that that wheel would disconnect after idling so I bought a g920.

I can get the g920 to work fine in model 2, but when I try to set it up in project 64 or Demul it wont input. Project 64 says 'Keyboard:??' whenever I try to input a key or turn the wheel. Demul defaults to 'JOY0_ANL1_KEY+'.

Im not ready to troubleshoot MAME yet, but does anyone know why it works in Model2 and not the others? And everything works fine i the logitech app btw.

MrThunderwing

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 771
  • Last login:Yesterday at 05:50:25 pm
  • As I pass, do I give you the ass or the crotch?
Re: Troubleshooting Various Emulator Setups.
« Reply #1 on: September 15, 2020, 06:18:14 pm »
Demul's doing that because one of your pedals is always registering as on. I've got a DFGT wheel that's only got 2 pedals, so I get around this by just keeping both pedals half depressed during the setup. I think though for your wheel there should be an option to set your pedals to either combined or seperate. Whichever one of those it's currently set to try the opposite and that should allow you to set everything up OK.

BadMouth

  • Moderator
  • Trade Count: (+6)
  • Full Member
  • *****
  • Offline Offline
  • Posts: 8663
  • Last login:Today at 06:07:36 am
  • ...
Re: Troubleshooting Various Emulator Setups.
« Reply #2 on: September 15, 2020, 09:57:29 pm »
Been a while, but I remember the clutch pedal throwing things off on my G27.  If you could hold it down exactly halfway it would behave well enough to map something else.

Not sure about new versions, but IIRC back in the day demul required pedals to be marked combined.

DJRobbyD

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 13
  • Last login:September 16, 2020, 01:43:21 pm
  • I want to build my own arcade controls!
Re: Troubleshooting Various Emulator Setups.
« Reply #3 on: September 16, 2020, 01:08:56 pm »
In case anyone else has problems like this in the future, one solution I have for n64 driving games:

Project64k with N-Rage Input Plugin V2 2.3c works for the G920. The inputs are hard to map because something is still fighting it, but with trial and error and good timing, you can map things and they play fine. I did put the clutch mapped to the b button for break because the axis for gas and break were giving me a hard time.

On to fine tuning Demul.