Main Restorations Software Audio/Jukebox/MP3 Everything Else Buy/Sell/Trade
Project Announcements Monitor/Video GroovyMAME Merit/JVL Touchscreen Meet Up Retail Vendors
Driving & Racing Woodworking Software Support Forums Consoles Project Arcade Reviews
Automated Projects Artwork Frontend Support Forums Pinball Forum Discussion Old Boards
Raspberry Pi & Dev Board controls.dat Linux Miscellaneous Arcade Wiki Discussion Old Archives
Lightguns Arcade1Up --- Bug Reports --- Site News

Unread posts | New Replies | Recent posts | Rules | Chatroom | Wiki | File Repository | RSS | Submit news

  

Author Topic: CRT-emudriver / groovymame display issue  (Read 1069 times)

0 Members and 1 Guest are viewing this topic.

deezdrama

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 365
  • Last login:April 12, 2020, 02:57:57 pm
  • I want to figure out Hyperspin hehe
    • forum.arcadecontrols.com/index.php/topic,146268.0.html
CRT-emudriver / groovymame display issue
« on: March 26, 2020, 05:24:41 pm »
I have an emulation pc im setting up for crt-emudriver/groovymame to run on my crt sony consumer set.
Im running win10 x64

I have a dual display setup.... My crt with a lcd above it for frontend navigation and want the roms to display to the crt.


I had this pc running with just the lcd hooked up.
I installed groovymame, then ran the crt emudriver setup for my card (r9 380)
After installing new drivers everything still worked fine on the lcd.
I figured Id go ahead and plug in my dvi-i to vga cable --> to my a960 transcoder --> to component cables to my crt.

As soon as I plugged in the dvi/vga cable to my video card the screen went blank. Tried unplugging but still no signal. Unplugged my lcd and plugged it back in.....no signal.
Restarted computer....no signal.
Only after restarting and unplugging and plugging back in the hdmi for the lcd did I get a signal back to my lcd panel.

I figured I could plug in the dvi-i/vga/transcoder/component setup thats plugged into my tv and it would still output a signal fine to my lcd but thats not the case.
I havnt even forced out a 15hz signal on the dvi-i analog port yet and yet as soon as i plugged it in I lost signal to my hdmi.

Am I going to have issues trying to run this pc with dual displays?
Can anyone explain or know why this is happening?
Should I continue with the guide and setup my 15hz signal with hot swapping etc and try to get the lcd added later?


EDIT>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
I went ahead and ran vmmaker, followed the guide and disabled extend desktop on restart, selected arcade 15.7hz, selected output to analog 0 , and enabled EDID emulation. my lcd flickered then displayed its image fine again.
I then plugged in the dvi-i/vga cord to the analog port and everything went black on the lcd but no image output to the tv. I then heard my pc beep so it rebooted and posted.

Back in win10 (still black on lcd) I unplugged dvi-i/vga and plugged it back in and pc beeped so it rebooted again and again am in windows with neither display showing an image.


Do i need to dig out my crt computer monitor and use it on the dvi-i/vga analog port durring install and setup to get this working?
« Last Edit: March 26, 2020, 05:52:44 pm by deezdrama »

Calamity

  • Moderator
  • Trade Count: (0)
  • Full Member
  • *****
  • Offline Offline
  • Posts: 6888
  • Last login:Today at 02:26:08 am
  • Quote me with care
Re: CRT-emudriver / groovymame display issue
« Reply #1 on: March 26, 2020, 06:41:30 pm »
Dual display is certainly possible but it may be tricky to setup. You don't need a crt computer monitor for this. However, the transcoder part adds some complexity to troubleshooting. I mean that you shouldn't be getting a black screen on both ends. At least the analogue screen should show something even if distorted. Unless the transcoder is blocking the video because it's out of sync.

Quote
I then heard my pc beep so it rebooted and posted.

This sounds like the driver is crashing W10. Are you using the latest release? (CRT Tools 2.0 beta 15 (Adrenalin 18.5.1 for GCN* cards) for Windows 10 64-bits) You definitely should be using this one on W10.
Important note: posts reporting GM issues without a log will be IGNORED.
Steps to create a log:
 - From command line, run: groovymame.exe -v romname >romname.txt
 - Attach resulting romname.txt file to your post, instead or pasting it.

CRT Emudriver, VMMaker & Arcade OSD downloads, documentation and discussion:  Eiusdemmodi

deezdrama

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 365
  • Last login:April 12, 2020, 02:57:57 pm
  • I want to figure out Hyperspin hehe
    • forum.arcadecontrols.com/index.php/topic,146268.0.html
Re: CRT-emudriver / groovymame display issue
« Reply #2 on: March 26, 2020, 07:26:35 pm »
CRT Emudriver & CRT Tools 2.0 beta 15 (Adrenalin 18.5.1 for GCN* cards) for Windows 10 64-bits is the one im using.
I hooked up a crt monitor and enabled edid.... it pushed a 15hz signal I assume because it was out of range for the crt monitor.

I then plugged in the vga/transcoder from my sony crt and nothing.

Ive tried 3 different transcoders, an audio authority a960 $100 transcoder and 2 different monprice type transcoders, no signal. I would get a tiny slight white line scrolling across the top of the screen.

I tried several different vga cords, 2 different component cords, ive even drug a 27" panasonic tau from my closet to try it...... I would get a scrambled image but it came from the transcoder itself because i would get it whether the vga is plugged in or not. I think at one point i tried enabling composite sync but no help there either.
Not sure whats going on.
I have so much time and money setup in this and had to fight for time off work to try and get this going. Not sure what else to try at this point :(

Calamity

  • Moderator
  • Trade Count: (0)
  • Full Member
  • *****
  • Offline Offline
  • Posts: 6888
  • Last login:Today at 02:26:08 am
  • Quote me with care
Re: CRT-emudriver / groovymame display issue
« Reply #3 on: March 26, 2020, 07:40:04 pm »
With your CRT monitor plugged in, try enabling EDID emulation but with the *arcade_31* preset. This will allow you seeing something on the CRT. Then, make sure EDID emulation works. You should see the CRT listed as "ARCADE_31" in VMMaker's device drop-down menu. Only once you have established that this works, you can go on with setting 15 kHz. Please make sure composite sync is NOT enabled.
Important note: posts reporting GM issues without a log will be IGNORED.
Steps to create a log:
 - From command line, run: groovymame.exe -v romname >romname.txt
 - Attach resulting romname.txt file to your post, instead or pasting it.

CRT Emudriver, VMMaker & Arcade OSD downloads, documentation and discussion:  Eiusdemmodi

deezdrama

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 365
  • Last login:April 12, 2020, 02:57:57 pm
  • I want to figure out Hyperspin hehe
    • forum.arcadecontrols.com/index.php/topic,146268.0.html
Re: CRT-emudriver / groovymame display issue
« Reply #4 on: March 26, 2020, 07:48:24 pm »
With your CRT monitor plugged in, try enabling EDID emulation but with the *arcade_31* preset. This will allow you seeing something on the CRT. Then, make sure EDID emulation works. You should see the CRT listed as "ARCADE_31" in VMMaker's device drop-down menu. Only once you have established that this works, you can go on with setting 15 kHz. Please make sure composite sync is NOT enabled.
Ill give it a go and report back.

ok, i enabled edid on analog out to 31hz and its working and have an image now on my lg ultrawide lcd and the crt monitor so looks like the driver is doing its thing.
« Last Edit: March 26, 2020, 07:59:26 pm by deezdrama »

deezdrama

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 365
  • Last login:April 12, 2020, 02:57:57 pm
  • I want to figure out Hyperspin hehe
    • forum.arcadecontrols.com/index.php/topic,146268.0.html
Re: CRT-emudriver / groovymame display issue
« Reply #5 on: March 26, 2020, 08:03:33 pm »
ok, i enabled edid on analog out to 31hz and its working and have an image now on my lg ultrawide lcd and the crt monitor so looks like the driver is doing its thing.
im so frustrated id almost just settle with running my emulation pc on this crt monitor....would definitely simplify things. I think ive read you can emulate scanlines on a crt monitor by custom refresh of 120hz or something like that Ive forgot the details.

But ive spent a bit on these transcoders and component cables and built a custom stand for the crt tv...uggggg.... gotta keep trying and testing  :dizzy:

By the way....I really appreciate the replies and help, you must have a strong passion to keep active and helping all us noobs ontop of all the software you create!

EDIT>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
Tried again using all 3 transcoders with 15.7hz arcade edid enabled on analog.
With the expensive audio authority transcoder i get nothing
with both the monoprice style transcoders I get a scrambled image but its there whether I have the vga input plugged in or not.

When I plug the vga back into the crt pc monitor---- It says out of range. So I think its outputting the right signal but how could 3 transcoders be bad? Ive tried 3 transcoders,2 component cables, 2 vga cables, 2 crt tv's  :banghead:
« Last Edit: March 26, 2020, 08:29:11 pm by deezdrama »

deezdrama

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 365
  • Last login:April 12, 2020, 02:57:57 pm
  • I want to figure out Hyperspin hehe
    • forum.arcadecontrols.com/index.php/topic,146268.0.html
Re: CRT-emudriver / groovymame display issue
« Reply #6 on: March 26, 2020, 08:53:42 pm »
 :applaud: :applaud: :applaud: :applaud: :applaud: :applaud: :applaud: Finally got it to work!!!!!!!!!!!!
Guess what it was  :dunno




The stupid belkin universal power adapter I just bought.
It lit up the led on the transcoders but must not be outputting the right voltages (switcheable)
As soon as I dug out a ac power adapter that was right voltage for the transcoder..........................

deezdrama

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 365
  • Last login:April 12, 2020, 02:57:57 pm
  • I want to figure out Hyperspin hehe
    • forum.arcadecontrols.com/index.php/topic,146268.0.html
Re: CRT-emudriver / groovymame display issue
« Reply #7 on: March 26, 2020, 10:36:21 pm »
Thanks for the help calamity!

I followed your install guide and got it up and running, installed all my super resolutions plus extras for retroarch, and both my crt and lcd are working.


Now I just need to figure out how to output signal to my crt only when launching groovy mame.

It keeps outputting mame to my lcd nomatter what i do. And if i make my crt primary and disable the lcd and try to launch groovymame it fails to load and crashes.
I followed the guide and in vmmaker i pointed to mame exe, and selected export settings to groovymame.

I also tried going into the mame ini file and put
 OSD PER-WINDOW VIDEO OPTIONS
#
screen                    \\.\DISPLAY2


(windows shows my crt as display 2)
but that did not work either.
Ive tried running from command prompt and from exe but crashes unless i have lcd monitor enabled then it only opens to it
« Last Edit: March 26, 2020, 11:10:46 pm by deezdrama »

Calamity

  • Moderator
  • Trade Count: (0)
  • Full Member
  • *****
  • Offline Offline
  • Posts: 6888
  • Last login:Today at 02:26:08 am
  • Quote me with care
Re: CRT-emudriver / groovymame display issue
« Reply #8 on: March 27, 2020, 12:01:18 pm »
Assuming you have \\.\DISPLAY1 as your LCD (enabled as primary desktop) and \\.\DISPLAY2 as your CRT (enabled as secondary desktop).

From command-line: mame64 sf2 -screen \\.\DISPLAY2

This should launch GM on your CRT. If this doesn't work, then please post a log so I can see what's going on.
Important note: posts reporting GM issues without a log will be IGNORED.
Steps to create a log:
 - From command line, run: groovymame.exe -v romname >romname.txt
 - Attach resulting romname.txt file to your post, instead or pasting it.

CRT Emudriver, VMMaker & Arcade OSD downloads, documentation and discussion:  Eiusdemmodi

deezdrama

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 365
  • Last login:April 12, 2020, 02:57:57 pm
  • I want to figure out Hyperspin hehe
    • forum.arcadecontrols.com/index.php/topic,146268.0.html
Re: CRT-emudriver / groovymame display issue
« Reply #9 on: March 27, 2020, 01:20:31 pm »
Assuming you have \\.\DISPLAY1 as your LCD (enabled as primary desktop) and \\.\DISPLAY2 as your CRT (enabled as secondary desktop).

From command-line: mame64 sf2 -screen \\.\DISPLAY2

This should launch GM on your CRT. If this doesn't work, then please post a log so I can see what's going on.

I tried it and it made my crt flicker like it was about to load then got the following in the command line window...

L:\LaunchBox\Emulators\Mame Groovy>mame64 sf2 -screen \\.\DISPLAY2

SwitchRes: [sf2] (1) horizontal (384x224@59.637405)->(2560x224@59.637405)

-----------------------------------------------------
Exception at EIP=00007ff9989ea146 (register_frame_ctor+0x8fb081e6): ACCESS VIOLATION
While attempting to read memory at 0000000000000048
-----------------------------------------------------
RAX=0000000000000000 RBX=00000000116b0b88 RCX=0000000000000001 RDX=0000000000000000
RSI=0000000000000001 RDI=00000000116b0b88 RBP=000000000ef0ea30 RSP=000000000ef0e930
 R8=0000000000000008  R9=0000000000000000 R10=00007ff9cac615c0 R11=000000000ef0e984
R12=0000000000000000 R13=000000000ef0ef80 R14=0000000014ee3f78 R15=0000000000000000
-----------------------------------------------------
Stack crawl:
  000000000ef0ea90: 00007ff9989ea146 (OpenAdapter+0x553b6)
  000000000ef0ed50: 00007ff9989786a5 (DllMain+0x6a65)
  000000000ef0ef30: 00007ff99897997d (DllMain+0x7d3d)
  000000000ef0efd0: 00007ff998979ca2 (DllMain+0x8062)
  000000000ef0f040: 00007ff9acd8998e (register_frame_ctor+0xa3ea7a2e)
  000000000ef0f0d0: 00007ff9acdba5dd (Direct3DCreate9+0x9dcd)
  000000000ef0f150: 00007ff9acd8a7f8 (register_frame_ctor+0xa3ea8898)
  000000000ef0f2c0: 00007ff9acd8b49a (register_frame_ctor+0xa3ea953a)
  000000000ef0f310: 00007ff9acdbdc48 (Direct3DCreate9+0xd438)
  000000000ef0f360: 00007ff9acdc682e (Direct3DCreate9+0x1601e)
  000000000ef0f3e0: 000000000265dce4 (renderer_d3d9::device_create_resources()+0x0434)
  000000000ef0f470: 000000000265e1d3 (renderer_d3d9::device_create(HWND__*)+0x0363)
  000000000ef0f4e0: 000000000265ea4c (renderer_d3d9::create()+0x00dc)
  000000000ef0f5f0: 000000000262146a (win_window_info::complete_create()+0x041a)
  000000000ef0f900: 000000000262207c (win_window_info::create(running_machine&, int, std::shared_ptr<osd_monitor_info>, osd_window_config const*)+0x09bc)
  000000000ef0f970: 000000000261d8cb (windows_osd_interface::video_init()+0x008b)
  000000000ef0fa90: 000000000260dc85 (osd_common_t::init_subsystems()+0x19c5)
  000000000ef0fd90: 0000000002605b9c (windows_osd_interface::init(running_machine&)+0x02cc)
  000000000ef0fe90: 0000000003f98134 (running_machine::start()+0x0364)
  000000000ef0ff30: 0000000003f9a030 (running_machine::run(bool)+0x0060)
  000000000ef1f210: 00000000026c384a (mame_machine_manager::execute()+0x020a)
  000000000ef1f4c0: 0000000002731984 (cli_frontend::start_execution(mame_machine_manager*, std::vector<std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> >, std::allocator<std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> > > > const&)+0x03f4)
  000000000ef1f630: 0000000002731e45 (cli_frontend::execute(std::vector<std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> >, std::allocator<std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> > > >&)+0x0045)
  000000000ef1f690: 00000000026c17ea (emulator_info::start_frontend(emu_options&, osd_interface&, std::vector<std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> >, std::allocator<std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> > > >&)+0x002a)
  000000000ef1fe50: 0000000008cf965d (main+0x016d)
  000000000ef1ff20: 00000000004013f7 (__tmainCRTStartup+0x0247)
  000000000ef1ff50: 000000000040152b (mainCRTStartup+0x001b)
  000000000ef1ff80: 00007ff9c86b8364 (BaseThreadInitThunk+0x0014)
  000000000ef1ffd0: 00007ff9cabb70d1 (RtlUserThreadStart+0x0021)






EDIT>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
I then tried with display 1 incase windows is reporting dispay number wrong and got the following.....

L:\LaunchBox\Emulators\Mame Groovy>mame64 sf2 -screen \\.\DISPLAY1

SwitchRes: [sf2] (1) horizontal (384x224@59.637405)->(640x480@59.637405)
sf2e_30g.11e NOT FOUND (tried in sf2 sf2)
sf2e_37g.11f NOT FOUND (tried in sf2 sf2)
sf2e_31g.12e NOT FOUND (tried in sf2 sf2)
sf2e_38g.12f NOT FOUND (tried in sf2 sf2)
sf2e_28g.9e NOT FOUND (tried in sf2 sf2)
sf2e_35g.9f NOT FOUND (tried in sf2 sf2)
sf2_29b.10e NOT FOUND (tried in sf2 sf2)
sf2_36b.10f NOT FOUND (tried in sf2 sf2)
sf2-5m.4a NOT FOUND (tried in sf2 sf2)
sf2-7m.6a NOT FOUND (tried in sf2 sf2)
sf2-1m.3a NOT FOUND (tried in sf2 sf2)
sf2-3m.5a NOT FOUND (tried in sf2 sf2)
sf2-6m.4c NOT FOUND (tried in sf2 sf2)
sf2-8m.6c NOT FOUND (tried in sf2 sf2)
sf2-2m.3c NOT FOUND (tried in sf2 sf2)
sf2-4m.5c NOT FOUND (tried in sf2 sf2)
sf2-13m.4d NOT FOUND (tried in sf2 sf2)
sf2-15m.6d NOT FOUND (tried in sf2 sf2)
sf2-9m.3d NOT FOUND (tried in sf2 sf2)
sf2-11m.5d NOT FOUND (tried in sf2 sf2)
sf2_9.12a NOT FOUND (tried in sf2 sf2)
sf2_18.11c NOT FOUND (tried in sf2 sf2)
sf2_19.12c NOT FOUND (tried in sf2 sf2)
buf1 NOT FOUND (tried in sf2 sf2)
ioa1 NOT FOUND (tried in sf2 sf2)
prg1 NOT FOUND (tried in sf2 sf2)
rom1 NOT FOUND (tried in sf2 sf2)
sou1 NOT FOUND (tried in sf2 sf2)
stf29.1a NOT FOUND (tried in sf2 sf2)
iob1.11d NOT FOUND (tried in sf2 sf2)
c632.ic1 NOT FOUND (tried in sf2 sf2)
Fatal error: Required files are missing, the machine cannot be run.





But when running the mame64 exe it outputs to the lcd in 480
« Last Edit: March 27, 2020, 01:41:12 pm by deezdrama »

Calamity

  • Moderator
  • Trade Count: (0)
  • Full Member
  • *****
  • Offline Offline
  • Posts: 6888
  • Last login:Today at 02:26:08 am
  • Quote me with care
Re: CRT-emudriver / groovymame display issue
« Reply #10 on: March 27, 2020, 02:32:17 pm »
Is that my GM build? Latest version? Without a log I can't provide much help.
Important note: posts reporting GM issues without a log will be IGNORED.
Steps to create a log:
 - From command line, run: groovymame.exe -v romname >romname.txt
 - Attach resulting romname.txt file to your post, instead or pasting it.

CRT Emudriver, VMMaker & Arcade OSD downloads, documentation and discussion:  Eiusdemmodi

Calamity

  • Moderator
  • Trade Count: (0)
  • Full Member
  • *****
  • Offline Offline
  • Posts: 6888
  • Last login:Today at 02:26:08 am
  • Quote me with care
Re: CRT-emudriver / groovymame display issue
« Reply #11 on: March 27, 2020, 02:33:47 pm »
Is that my GM build? Latest version? Without a log I can't provide much help.
Ok I'm seeing it's 203. Not that it matters too much, but you must use the D3D9ex based build.
Important note: posts reporting GM issues without a log will be IGNORED.
Steps to create a log:
 - From command line, run: groovymame.exe -v romname >romname.txt
 - Attach resulting romname.txt file to your post, instead or pasting it.

CRT Emudriver, VMMaker & Arcade OSD downloads, documentation and discussion:  Eiusdemmodi

deezdrama

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 365
  • Last login:April 12, 2020, 02:57:57 pm
  • I want to figure out Hyperspin hehe
    • forum.arcadecontrols.com/index.php/topic,146268.0.html
Re: CRT-emudriver / groovymame display issue
« Reply #12 on: March 27, 2020, 04:24:51 pm »
My mame romset is 203 so thats the groovymame version I downloaded and installed from the link in your download post.

Is 203 not d3d9ex based?
I dont know how to get mame to dump a log file, any info on this?

Arroyo

  • Trade Count: (0)
  • Full Member
  • ***
  • Online Online
  • Posts: 1234
  • Last login:Today at 10:04:12 pm
  • Budgets are boring
    • newforum.arcadecontrols.com/index.php/topic,156267.0.html
Re: CRT-emudriver / groovymame display issue
« Reply #13 on: March 27, 2020, 05:19:47 pm »
Youíre gonna have trouble with a number of Arcade games with that Sony TV.  Myself and a number of other members have toyed with them for hours and that chassis on those TVís donít like sub 60hz frequencies which a number of games use (lot of Midway games from the late 80ís and 90ís and a number of older 80ís vertical games).

deezdrama

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 365
  • Last login:April 12, 2020, 02:57:57 pm
  • I want to figure out Hyperspin hehe
    • forum.arcadecontrols.com/index.php/topic,146268.0.html
Re: CRT-emudriver / groovymame display issue
« Reply #14 on: March 27, 2020, 05:26:11 pm »
Youíre gonna have trouble with a number of Arcade games with that Sony TV.  Myself and a number of other members have toyed with them for hours and that chassis on those TVís donít like sub 60hz frequencies which a number of games use (lot of Midway games from the late 80ís and 90ís and a number of older 80ís vertical games).
me and my son took the trinitron to the basement, in needs yoke adjusted and a cap replacement, I got the panasonic tau setup now

Arroyo

  • Trade Count: (0)
  • Full Member
  • ***
  • Online Online
  • Posts: 1234
  • Last login:Today at 10:04:12 pm
  • Budgets are boring
    • newforum.arcadecontrols.com/index.php/topic,156267.0.html
Re: CRT-emudriver / groovymame display issue
« Reply #15 on: March 27, 2020, 05:27:34 pm »
me and my son took the trinitron to the basement, in needs yoke adjusted and a cap replacement, I got the panasonic tau setup now

Ah, hopefully that is a more forgiving chassis.  Good luck!
« Last Edit: March 28, 2020, 06:48:53 pm by Arroyo »

deezdrama

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 365
  • Last login:April 12, 2020, 02:57:57 pm
  • I want to figure out Hyperspin hehe
    • forum.arcadecontrols.com/index.php/topic,146268.0.html
Re: CRT-emudriver / groovymame display issue
« Reply #16 on: March 28, 2020, 02:10:51 pm »
Calamity .... here is the log file  (sorry... I didnt notice it was in your signature)  ;D
« Last Edit: March 28, 2020, 02:15:40 pm by deezdrama »

Calamity

  • Moderator
  • Trade Count: (0)
  • Full Member
  • *****
  • Offline Offline
  • Posts: 6888
  • Last login:Today at 02:26:08 am
  • Quote me with care
Re: CRT-emudriver / groovymame display issue
« Reply #17 on: March 28, 2020, 03:10:35 pm »
Important note: posts reporting GM issues without a log will be IGNORED.
Steps to create a log:
 - From command line, run: groovymame.exe -v romname >romname.txt
 - Attach resulting romname.txt file to your post, instead or pasting it.

CRT Emudriver, VMMaker & Arcade OSD downloads, documentation and discussion:  Eiusdemmodi

deezdrama

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 365
  • Last login:April 12, 2020, 02:57:57 pm
  • I want to figure out Hyperspin hehe
    • forum.arcadecontrols.com/index.php/topic,146268.0.html
Re: CRT-emudriver / groovymame display issue
« Reply #18 on: March 28, 2020, 03:23:55 pm »
Download the D3D9x build, here: https://drive.google.com/open?id=1akx3RZHL5FdBqT55OBBePSNwvAr3-N0r
So i have the wrong version  :banghead:  :laugh2:
Also curious..... what is the arcade osd and radeon settings file that come with your emudriver suite?

deezdrama

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 365
  • Last login:April 12, 2020, 02:57:57 pm
  • I want to figure out Hyperspin hehe
    • forum.arcadecontrols.com/index.php/topic,146268.0.html
Re: CRT-emudriver / groovymame display issue
« Reply #19 on: March 28, 2020, 03:44:24 pm »
It works and looks sooooooo good! Ive tried a few favs and they look amazing! Better than I remember at the arcade or on my old wells gardner  31hz mame cab I had before I built my lcd slimcab.
the pic doesnt do it justice and need to get back in service menu and fix geometry since it looks like it went back to default since i stowed this tv in the closet  :angry:
Thanks calamity!  :applaud: :applaud: :applaud:
Its running in super speed now though. Is this issue covered somewhere?
And should I adjust the screen offset in mame/retroarch or just get into my tv's service menu and center it?
Thanks again!
« Last Edit: March 28, 2020, 03:58:19 pm by deezdrama »

deezdrama

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 365
  • Last login:April 12, 2020, 02:57:57 pm
  • I want to figure out Hyperspin hehe
    • forum.arcadecontrols.com/index.php/topic,146268.0.html
Re: CRT-emudriver / groovymame display issue
« Reply #20 on: March 28, 2020, 06:47:35 pm »
Got mame launching on correct screen, and working with launchbox, but still have the emulation speed issue and not sure whats causing it, also the cursor stays on the screen. Anyone have any ideas?

Heres a vid
https://www.youtube.com/watch?v=GJbcE-xdu4E&feature=youtu.be
« Last Edit: March 28, 2020, 07:05:28 pm by deezdrama »

Calamity

  • Moderator
  • Trade Count: (0)
  • Full Member
  • *****
  • Offline Offline
  • Posts: 6888
  • Last login:Today at 02:26:08 am
  • Quote me with care
Re: CRT-emudriver / groovymame display issue
« Reply #21 on: March 28, 2020, 07:03:43 pm »
Try launching GM from command line, and post a new log.
Important note: posts reporting GM issues without a log will be IGNORED.
Steps to create a log:
 - From command line, run: groovymame.exe -v romname >romname.txt
 - Attach resulting romname.txt file to your post, instead or pasting it.

CRT Emudriver, VMMaker & Arcade OSD downloads, documentation and discussion:  Eiusdemmodi

deezdrama

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 365
  • Last login:April 12, 2020, 02:57:57 pm
  • I want to figure out Hyperspin hehe
    • forum.arcadecontrols.com/index.php/topic,146268.0.html
Re: CRT-emudriver / groovymame display issue
« Reply #22 on: March 28, 2020, 07:11:08 pm »
Heres that log file  :dunno  ;D
How can I give u a little donation? I feel bad you been helping me for 2 days  :notworthy:



hmmmmm... I been following this guide for groovymame setup and config settings...
http://geedorah.com/eiusdemmodi/forum/viewtopic.php?id=433

I edited the config as follows according to guide
sound                    portaudio
audio latency          0
pa_api                   "Windows WDM-KS"
pa_device                 none
pa_latency                 0.001

but in my log file it says something about adding 10ms of audio latency which strikes me as odd....wonder if I should set the audio settings back to default?

Also notice at the bottom of the log it says im running at %500 speed  :dizzy: but dont know why



EDIT>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
Got everything running for the most part but groovymame is still running at like 5x speed and cant figure out why.
I feel like all the emulators running in retroarch are outputting 480i as well instead of 240p-ish from the super resolutions.
They seem soft whereas groovymame looks nice and scanlines look good, just got the speed problem but the games look amazing whereas all the retroarch emulation looks good but soft, and not amazing lol.
Any idea how I can check to see what resolution retroarch is pushing?

Thanks again!!!!!
« Last Edit: March 29, 2020, 06:00:09 am by deezdrama »

Calamity

  • Moderator
  • Trade Count: (0)
  • Full Member
  • *****
  • Offline Offline
  • Posts: 6888
  • Last login:Today at 02:26:08 am
  • Quote me with care
Re: CRT-emudriver / groovymame display issue
« Reply #23 on: March 29, 2020, 03:53:59 am »
You need to disable Windows 10's game bar (google "windows 10 game bar disable").
Important note: posts reporting GM issues without a log will be IGNORED.
Steps to create a log:
 - From command line, run: groovymame.exe -v romname >romname.txt
 - Attach resulting romname.txt file to your post, instead or pasting it.

CRT Emudriver, VMMaker & Arcade OSD downloads, documentation and discussion:  Eiusdemmodi

deezdrama

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 365
  • Last login:April 12, 2020, 02:57:57 pm
  • I want to figure out Hyperspin hehe
    • forum.arcadecontrols.com/index.php/topic,146268.0.html
Re: CRT-emudriver / groovymame display issue
« Reply #24 on: March 29, 2020, 06:12:34 am »
You need to disable Windows 10's game bar (google "windows 10 game bar disable").

I tried.... I thought it was....did u notice it in last vid?
Does anything jump out at you in this log file as to why groovymame would be running at 500% ?
Thanks
« Last Edit: March 29, 2020, 02:10:20 pm by deezdrama »

Calamity

  • Moderator
  • Trade Count: (0)
  • Full Member
  • *****
  • Offline Offline
  • Posts: 6888
  • Last login:Today at 02:26:08 am
  • Quote me with care
Re: CRT-emudriver / groovymame display issue
« Reply #25 on: March 29, 2020, 02:57:47 pm »
The speed issue can be either the Windows 10 game's bar (or its associated crap, W10 DVR, these things change with each upgrade, turn off all that), or maybe some remote desktop app you might be using. Whatever that tries to set a layer above D3D9ex will cause that. I thought it could be your frontend that's why I asked to you run from command line (always test from command line, never from the frontend, only when things work from command line go back to the frontend).

Also, make sure you don't have vsync accidentaly forced to off in your AMD control panel, it must be set so that it lets each app decide.

If nothing works, try forcing frame_delay on. For this, it'd be better if you updated to current GM (it has built in access to frame delay in the ui).
Important note: posts reporting GM issues without a log will be IGNORED.
Steps to create a log:
 - From command line, run: groovymame.exe -v romname >romname.txt
 - Attach resulting romname.txt file to your post, instead or pasting it.

CRT Emudriver, VMMaker & Arcade OSD downloads, documentation and discussion:  Eiusdemmodi

deezdrama

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 365
  • Last login:April 12, 2020, 02:57:57 pm
  • I want to figure out Hyperspin hehe
    • forum.arcadecontrols.com/index.php/topic,146268.0.html
Re: CRT-emudriver / groovymame display issue
« Reply #26 on: March 29, 2020, 08:42:13 pm »
I still have the AMD software installed from before I installed emudriver. When I try to open amd control panel it gives an error message that my versions dont match.
When I downloaded crt-emudriver I also got a folder "radeon settings 18.5.1" Am I suppossed to run that?

I disabled gamebar and all that from what I can remember. Its weird , If I right click start button, I dont have a "settings" option anymore, and dont have a gaming tab anywhere, which is where the gamebar options used to be.

deezdrama

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 365
  • Last login:April 12, 2020, 02:57:57 pm
  • I want to figure out Hyperspin hehe
    • forum.arcadecontrols.com/index.php/topic,146268.0.html
Re: CRT-emudriver / groovymame display issue
« Reply #27 on: March 29, 2020, 09:33:17 pm »
I enabled frame delay and now the speed is correct and sound is fine but when launching from bigbox I have no sound. Any idea why that could be?
I edited config file of mame when I first set it up with the following....
sound                    portaudio
audio latency          0
pa_api                   "Windows WDM-KS"
pa_device                 none
pa_latency                 0.001

according to this guide...
http://geedorah.com/eiusdemmodi/forum/viewtopic.php?id=433


Could these port audio settings be conflicting with bigbox? sound works fine launching mame outside of launchbox
« Last Edit: March 30, 2020, 01:39:28 am by deezdrama »

deezdrama

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 365
  • Last login:April 12, 2020, 02:57:57 pm
  • I want to figure out Hyperspin hehe
    • forum.arcadecontrols.com/index.php/topic,146268.0.html
Re: CRT-emudriver / groovymame display issue
« Reply #28 on: March 30, 2020, 06:08:04 pm »
Well I fixed the audio issue by just setting config back to default audio settings instead of the suggested ones for groovymame.
I didnt notice any audio out of sync or anything so im happy.

Fixed the speed issue by enabling frame delay like you suggested. All the games Ive tested seem fine. Is there any negatives to using frame delay or am I ok to just keep it like this?



Groovymame looks amazing on the crt! I couldnt of done it without you Calamity! Thanks again!

The only other question I had was about my radeon control panel software. It says it doesnt mach with emudriver now. What/where can I get the compatible version?
« Last Edit: March 30, 2020, 06:22:10 pm by deezdrama »