Main Restorations Software Audio/Jukebox/MP3 Everything Else Buy/Sell/Trade
Project Announcements Monitor/Video GroovyMAME Merit/JVL Touchscreen Meet Up Retail Vendors
Driving & Racing Woodworking Software Support Forums Consoles Project Arcade Reviews
Automated Projects Artwork Frontend Support Forums Pinball Forum Discussion Old Boards
Raspberry Pi & Dev Board controls.dat Linux Miscellaneous Arcade Wiki Discussion Old Archives
Lightguns Arcade1Up --- Bug Reports --- Site News

Unread posts | New Replies | Recent posts | Rules | Chatroom | Wiki | File Repository | RSS | Submit news

  

Author Topic: Rock-ola 477 Max Help Required  (Read 55 times)

0 Members and 1 Guest are viewing this topic.

Ribeye55

  • Trade Count: (0)
  • Jr. Member
  • **
  • Offline Offline
  • Posts: 1
  • Last login:Yesterday at 04:58:29 am
  • Rock-Ola
Rock-ola 477 Max Help Required
« on: March 26, 2020, 05:51:22 am »
Hi. Iíve had Rock-ola 477 Max for almost 18 years.  16 of those itís not been working.
As I have more time on my hands now, Iím giving it a go to get working. Reaching out from UAE.  Itís been stored well, not damp etc.  Unfortunately I donít have much electronic knowledge but I have done the following by following guidance etc from the forums.  I have a service manual with the unit.
Unseized gripper mechanism as it was jammed.  Checked what I think all fuses.  I do have spare boards and relays (apart from Play Control Relay).
I have following symptoms;
AMP does not appear to be working, however currently leaving that as a last item to investigate.
Popularity meter, the 3v cell is dead, replacement on order.  Popularity meter therefore not connected.
All lights/ballasts/starters disconnected for now.
Carousel not stopping in correct position, but reckon I can follow manual and sort that.
Test procedure for Logic Board Ė works.  It puts records on, however record not ejecting when finished nor eject button not working on back of AMP (under volume knob), however reverse relay on mech pwr board is clicking.
Eventually, although painful to watch and hear, record does return after some time, about 2 mins, moving very slowly. At the same time the gripper motor (nipple on the bottom) seems to be trying to spin both ways at the same time/?
After Logic Board test procedure, switch back up and Carousel turning as well as turntable, however not stopping. Continuous, revolutions.
Any help appreciated.  Be patientÖ Rob from UK in UAE.