Main Restorations Software Audio/Jukebox/MP3 Everything Else Buy/Sell/Trade
Project Announcements Monitor/Video GroovyMAME Merit/JVL Touchscreen Meet Up Retail Vendors
Driving & Racing Woodworking Software Support Forums Consoles Project Arcade Reviews
Automated Projects Artwork Frontend Support Forums Pinball Forum Discussion Old Boards
Raspberry Pi & Dev Board controls.dat Linux Miscellaneous Arcade Wiki Discussion Old Archives
Lightguns Arcade1Up --- Bug Reports --- Site News

Unread posts | New Replies | Recent posts | Rules | Chatroom | Wiki | File Repository | RSS | Submit news

  

Author Topic: Asteroids Deluxe WHITE DOT help  (Read 261 times)

0 Members and 1 Guest are viewing this topic.

SpaceTimeGuy

  • Trade Count: (0)
  • Jr. Member
  • **
  • Offline Offline
  • Posts: 2
  • Last login:February 17, 2020, 11:45:40 am
  • I want to build my own arcade controls!
Asteroids Deluxe WHITE DOT help
« on: February 15, 2020, 07:10:31 am »
Hi,
This is my first time fixing an arcade game so please cut me a little slack if I ask a dumb question ...

I have an Asteroids Deluxe ... When I got it > only half of the screen was lighting up and the red LED (spot killer) on the deflection board was ON.  I reflowed the solder on the pins on the DB and the red LED is Off and now have a great looking full screen image > great except there is a WHITE DOT in middle of screen !  I have tried "googling" this and see it mentioned in posts but only saw one post where anyone said how to fix this (they said they replaced some transistors and capacitors on the deflection board) ... Should that solve the white dot problem?  If it does not > what to do next?   

On that DB there are 2 large white ?ceramic? resistors (maybe 100 and 101??) ... I saw a post that said Atari issued a service bulletin that said to remove them and install jumpers wires instead ... Is that true?  In a home use environment where it will get very limited use > is it worth doing this if the resistors test "Good" ??

Also > red LED on the Main board is On > does that mean there is a problem ? or is it suppose to be On to show the board is getting power?   If it is suppose to be Off > could something on the main board be causing the white dot?

Thanks for any help !

cw

  • Trade Count: (+7)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 775
  • Last login:Yesterday at 07:01:59 pm
  • Game over man game over
    • The Cab
Re: Asteroids Deluxe WHITE DOT help
« Reply #1 on: February 16, 2020, 07:02:00 pm »
turn down your brightness and or contrast...
red led on main board is for 5v. if its on then your 5v is good. not sure about upgrading the deflection to later ver.

SpaceTimeGuy

  • Trade Count: (0)
  • Jr. Member
  • **
  • Offline Offline
  • Posts: 2
  • Last login:February 17, 2020, 11:45:40 am
  • I want to build my own arcade controls!
Re: Asteroids Deluxe WHITE DOT help
« Reply #2 on: February 17, 2020, 11:45:40 am »
OK ... THANK YOU for replying ... Deflection Board > I already sent the board to guy to check it out (but will let him know that board may be OK) ... and when I get it back I will adjust Brightness and Contrast ...   Red light lit on Main board > "suppose to be ON" ... Whew ... that is a relief !   THANK YOU !

cw

  • Trade Count: (+7)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 775
  • Last login:Yesterday at 07:01:59 pm
  • Game over man game over
    • The Cab
Re: Asteroids Deluxe WHITE DOT help
« Reply #3 on: February 24, 2020, 07:21:12 am »
if memory serves you will want to turn them both down. then turn up the brightness until you can just start to see it and then bring up the contrast.


https://www.arcade-museum.com/manuals-monitors/FAQ%20Black%20and%20White%20XY%20Version%201.1%20dated%207%20Feb%2002.pdf


faq for black and white vectors