Main Restorations Software Audio/Jukebox/MP3 Everything Else Buy/Sell/Trade
Project Announcements Monitor/Video GroovyMAME Merit/JVL Touchscreen Meet Up Retail Vendors
Driving & Racing Woodworking Software Support Forums Consoles Project Arcade Reviews
Automated Projects Artwork Frontend Support Forums Pinball Forum Discussion Old Boards
Raspberry Pi & Dev Board controls.dat Linux Miscellaneous Arcade Wiki Discussion Old Archives
Lightguns Arcade1Up --- Bug Reports --- Site News

Unread posts | New Replies | Recent posts | Rules | Chatroom | Wiki | File Repository | RSS | Submit news

  

Author Topic: Golden Tee Fore Complete "right" input sometimes acting stuck  (Read 525 times)

0 Members and 1 Guest are viewing this topic.

ccie38296

  • Trade Count: (0)
  • Jr. Member
  • **
  • Offline Offline
  • Posts: 3
  • Last login:January 17, 2020, 05:32:24 pm
  • I want to build my own arcade controls!
Golden Tee Fore Complete "right" input sometimes acting stuck
« on: January 16, 2020, 10:50:42 am »
Hi All!

Last weekend I purchased a Golden Tee Fore! Complete cabinet with Silver Strike Bowling and the Perfect Solution switcher installed. Got it home and everything tested out OK just like when I was picking it up from the seller. It's in decent shape, but needs some cleanup. The monitor was filthy and there is some sketchy wiring on the power cord which I will need to replace.

Anyway, over the last couple days I've powered it on to test out and whatnot, and I've noticed that sometimes, and only sometimes, GT acts like the "Right" button input is stuck. It's _not_ the button itself, I've disconnected the input wires from the switch and the game keeps spinning around like someone is holding the button. I've checked the wiring for that button reasonably well and it doesn't *appear* to be damaged in any way. The Fly-By button wiring is all jacked up but that button isn't giving me a problem.

Other observations: If I switch over to SSB using the selection buttons from the Perfect Solution, the "Right" input is not stuck and the button works normally. Switch back to GT and it's still spinning around like the input is stuck. Also, if I press the "Test" button and go into the Player Controls test menu, the input does not appear to be stuck. When I then exit the settings menus and the game restarts it usually seems OK. a couple times it did then "stick" again but after going into Test mode a second time it was OK.

When it acts stuck, it does so immediately after reaching the first tee-off, and it happens on its own even if I have not pressed the "Right" button. It really acts like that input is intermittently shorting but if it is I haven't found the spot yet.

As some additional investigation, I verified with a continuity tester that the button itself is not stuck and the input is not shorted (at least not continuously). I also found that when just the Golden Tee board is running (SSB Nighthawk is shut off), I see 4.5-5V of voltage potential from all other inputs to ground, but on the button in question the voltage potential from that pin on the JAMMA edge connector of the GT Red board is 1.3-1.6V. So I'm wondering if there is either a partial short somewhere (reinspected the wiring and still don't see anything damaged), or if maybe that pin is being driven at a low voltage that is then tripping the board to think the input it being hit.

When I boot up SSB, then I seem to see the 4.5-5V across that pin. In fact, unlike the other day when I seemed to see the issue persist even when SSB was running and selected, last night booting SSB actually stopped the stuck input on Golden Tee and I started seeing a normal voltage across that input from GT's JAMMA edge connector.

I guess next I will try disconnecting the JAMMA connector from the board and powering it up (it's a Red board so it gets its power from the ATX connector) and check the voltage across that input again to confirm it's originating on the board and not on the Perfect Solution switcher or something. I'm pretty new to troubleshooting these things so still trying to wrap my head around where the voltage for the input originates from, etc.

Anyone have any thoughts on why I'd see lower voltage potential on that input pin? Would that imply the input gate on the input chip (74LS541 chips, from my research) is bad? Or is that indicative of something like one of the inline components on that input (resistors, caps, etc) going bad? I guess I'd need to trace that input and check the voltage closer to the 541 chip to see where it's changing from 5V. I read a few posts from the very knowledgable "ed12" on here that pointed me that way, but I also just read that unfortunately it sounds like he has passed on.

Any help or suggestions are appreciated!

ccie38296

  • Trade Count: (0)
  • Jr. Member
  • **
  • Offline Offline
  • Posts: 3
  • Last login:January 17, 2020, 05:32:24 pm
  • I want to build my own arcade controls!
Re: Golden Tee Fore Complete "right" input sometimes acting stuck
« Reply #1 on: January 17, 2020, 03:15:45 pm »
An update with additional info if it gives anyone any ideas:

I just disconnected the JAMMA connector from the GT board and powered it up (since it uses the ATX power supply for the board power). Still consistently seeing 1.4V from ground to button 2, all other inputs see 4.5-5V against the same ground. I didn't bypass the switcher completely, but the board seems to still be exhibiting the problem when no external wiring besides power is connected to it.

The actual input "sticking" issue wasn't manifesting immediately after I reconnected the JAMMA harness, despite the low voltage on that input, but I just have to believe this one input pin showing low voltage and that being the same input that seems to intermittently inject an input event (which would normally be read by the pin going low) has to be related.

Any suggestions?

ccie38296

  • Trade Count: (0)
  • Jr. Member
  • **
  • Offline Offline
  • Posts: 3
  • Last login:January 17, 2020, 05:32:24 pm
  • I want to build my own arcade controls!
Re: Golden Tee Fore Complete "right" input sometimes acting stuck
« Reply #2 on: January 17, 2020, 05:32:24 pm »
Further troubleshooting:

I bypassed the switcher completely, and confirmed that even then I see 1.4V between ground and the JAMMA pin for the "Right" movement, whether the JAMMA harness is connected or not. I'm convinced it's on the board, I just don't really know what to do from here. Even when the pin is at 1.4V, the symptom doesn't always manifest, sometimes it plays just fine. I am wondering if something on the board is getting flakey, and the voltage to that pin is fluttering between 4.9-5V and 1.4V, which is causing the input system to register it as a button input. It has to be something like that, because I noticed that even if you actually hold the physical button down it only makes a single "turn right" action, it doesn't just keep going. But when my problem manifests, it does keep turning over and over, so some state must be triggering the input condition over and over.

jimmyfloyd

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 43
  • Last login:April 04, 2020, 04:48:41 pm
  • I want to build my own arcade controls!
Re: Golden Tee Fore Complete "right" input sometimes acting stuck
« Reply #3 on: March 30, 2020, 02:59:44 pm »
Have you resolved this?

I would try and follow the traces to see if you see a break someplace. Also check the capacitors on the board and reseat the chips that you can as a general start on that board. Given you have the ATX power supple, you should have a red board. What version of GT is it? What version is your boot chip? What type of hard drive do you have? Those will be helpful to know.