Main Restorations Software Audio/Jukebox/MP3 Everything Else Buy/Sell/Trade
Project Announcements Monitor/Video GroovyMAME Merit/JVL Touchscreen Meet Up Retail Vendors
Driving & Racing Woodworking Software Support Forums Consoles Project Arcade Reviews
Automated Projects Artwork Frontend Support Forums Pinball Forum Discussion Old Boards
Raspberry Pi & Dev Board controls.dat Linux Miscellaneous Arcade Wiki Discussion Old Archives
Lightguns Arcade1Up --- Bug Reports --- Site News

Unread posts | New Replies | Recent posts | Rules | Chatroom | Wiki | File Repository | RSS | Submit news

  

Author Topic: Dramas with ATOM-15  (Read 150 times)

0 Members and 1 Guest are viewing this topic.

Zebidee

  • Trade Count: (+4)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 1198
  • Last login:June 03, 2020, 09:21:36 pm
Dramas with ATOM-15
« on: May 13, 2020, 09:32:20 pm »
I wanted to relate my first experience flashing the BIOS of my video card (ATI/AMD HD4650), as it was not easy at all.

So, I followed the ATOM-15 guide on the Geedorah site, and the guides that they linked to.
 http://geedorah.com/eiusdemmodi/forum/viewtopic.php?id=64

Firstly, the ATIflash guide sites linked to from there were quite out-of-date. The Windows version utility is still being updated, but not the DOS version. It is difficult to find the latest DOS version (4.17) but it is still out there. I also downloaded/created a Win98 USB DOS boot disc to put it on.

With my new bootable Win98 USB key I booted into DOS, and tried to save the video BIOS with the command "atiflash -s 0 bios.rom". However, that gave me a "no DPMI" error so I moved onto trying to do it on the same PC in Windows 7. In Win7 I was advised that the program needs a minimum resolution of 800x600, and I'd already CRT_Emudriver-ed my PC so that wasn't easily possible. Hurrr.

So I tried saving the BIOS via DOS again, this time using another PC, and it worked, no error! I was able to save the BIOS from the video card! I don't know why I didn't get the "no DPMI" error this time.

I had no problems using ATOM-15 (v1.5) software to mod the BIOS, it worked first time I tried in Win7. That bit was easy. However I couldn't get the BIOS-testing program "lbios.com" to work from DOS, kept getting the message "error loading file". I triple checked the online guide, my syntax etc, and everything I was doing seemed right ("c:\lbios BIOS.ROM"), but the errors continued. So I moved on (without testing the modded BIOS).

I decided I had no choice but to live dangerously and try to flash the new-but-untested ATOM-modded BIOS to my card. So I tried using the Winflash utility in Windows 7, this time on my second PC that hadn't been CRT-EMU'd (that is, still had high-res modes that the app complained about before). The PC kept complaining that I needed to run the program as Administrator, but as it needed to be run from command line that was awkward. I could right-click it and choose "Run as Administrator", but then I couldn't pass the command-line parameters needed. I tried opening the cmd window as Administrator, but this didn't get around the problem. There's probably a couple of other things I might have tried, but it was all getting firmly into PITA territory so.....

So I went back to DOS and tried to flash the BIOS that way (ie "atiflash -p 0 bios-mod.rom"), on the PC that didn't complain about "no DPMI" when I saved the BIOS in the first place. NOPE, got the "no DPMI" error message when trying to run atiflash! Eventually I guessed that I needed to run "CWSDPMI.EXE" first, which is available with the Win98 boot disc files, and yes that solved the "no DPMI" error problem! I was finally able to flash the video BIOS with the modded image.

PHEW! I'm now happy with my video card booting/loading at 15khz.  :applaud:

Hope this helps someone.
Check out my completed projects!