Main Restorations Software Audio/Jukebox/MP3 Everything Else Buy/Sell/Trade
Project Announcements Monitor/Video GroovyMAME Merit/JVL Touchscreen Meet Up Retail Vendors
Driving & Racing Woodworking Software Support Forums Consoles Project Arcade Reviews
Automated Projects Artwork Frontend Support Forums Pinball Forum Discussion Old Boards
Raspberry Pi & Dev Board controls.dat Linux Miscellaneous Arcade Wiki Discussion Old Archives
Lightguns Arcade1Up --- Bug Reports --- Site News

Unread posts | New Replies | Recent posts | Rules | Chatroom | Wiki | File Repository | RSS | Submit news

  

Author Topic: Hantarex MTC900e - white screen  (Read 891 times)

0 Members and 1 Guest are viewing this topic.

CathalDublin

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 258
  • Last login:March 08, 2020, 09:26:02 pm
Hantarex MTC900e - white screen
« on: September 29, 2019, 04:04:37 am »
Iíve a hantarex MTC900e
Itís the European model that takes 128v and 220v for the degaus.
I acquired this a long time ago but hadnít got a stepdown isolation transformer to test it.
Finally came across an isolation/stepdown the other day and plugged it in and nothing, finding some posts from grantspain I found heíd mentioned the most common issue with these chassis is corroded coil/TR20 which indeed it was corroded and broken, I repaired this and the monitor now comes on but all Iím getting is a white screen, if I plug in a game the picture does kinda roll, see video with game running. Iíve re-capped the neck board and adjusted the screen pot which just makes the black area brighter/darker. The resistor on the left hand side does get very hot.
I have only the 128v connected, I havenít got the 220v connected but I believe this is only for degaus.
Any ideas

Defender(multiwilliams), SF2CE
Whirlwind, Lethal Weapon 3

grantspain

  • I personally prefer "bog trotter"
  • Trade Count: (+1)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 5943
  • Last login:Today at 05:25:12 am
Re: Hantarex MTC900e - white screen
« Reply #1 on: September 29, 2019, 05:30:25 am »
next test voltages, 200v video b+ and 12v and -5
refer to the schematic for test points

CathalDublin

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 258
  • Last login:March 08, 2020, 09:26:02 pm
Re: Hantarex MTC900e - white screen
« Reply #2 on: September 30, 2019, 06:09:26 pm »
My b+(Sp4)is reading about 180ish v, my 12v(SP8)is 10v and my -5v(sp7)seems to be reading +5v, is that possible?
Iím measuring these from the neck board
« Last Edit: September 30, 2019, 06:25:48 pm by CathalDublin »
Defender(multiwilliams), SF2CE
Whirlwind, Lethal Weapon 3

grantspain

  • I personally prefer "bog trotter"
  • Trade Count: (+1)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 5943
  • Last login:Today at 05:25:12 am
Re: Hantarex MTC900e - white screen
« Reply #3 on: October 01, 2019, 01:49:58 am »
if someone has replaced the 7905 at ic1 with a +5 reg then yes
the +12 is a bit low, you can read again at ic4

CathalDublin

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 258
  • Last login:March 08, 2020, 09:26:02 pm
Re: Hantarex MTC900e - white screen
« Reply #4 on: October 01, 2019, 07:13:14 am »
I may have read it wrong, doesnít look like anyoneís every worked on this before, Iíll re-check them tonight at ic4
Thanks
Defender(multiwilliams), SF2CE
Whirlwind, Lethal Weapon 3

grantspain

  • I personally prefer "bog trotter"
  • Trade Count: (+1)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 5943
  • Last login:Today at 05:25:12 am
Re: Hantarex MTC900e - white screen
« Reply #5 on: October 01, 2019, 10:45:54 am »
ic4 is the +12 reg

CathalDublin

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 258
  • Last login:March 08, 2020, 09:26:02 pm
Re: Hantarex MTC900e - white screen
« Reply #6 on: October 01, 2019, 05:47:41 pm »
OK I re checked my voltages from the main board, see video, maybe Iím doing something really stupid but Iím getting 19.2 on the 12v and 13.9 on the -5v
Measuring from here



See video


Measuring the input on IC1(7905) reads 0 and the output reads 13.9/14
« Last Edit: October 01, 2019, 06:00:26 pm by CathalDublin »
Defender(multiwilliams), SF2CE
Whirlwind, Lethal Weapon 3

grantspain

  • I personally prefer "bog trotter"
  • Trade Count: (+1)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 5943
  • Last login:Today at 05:25:12 am
Re: Hantarex MTC900e - white screen
« Reply #7 on: October 01, 2019, 05:59:34 pm »
i read at the neck card with chassis fully connected and running

CathalDublin

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 258
  • Last login:March 08, 2020, 09:26:02 pm
Re: Hantarex MTC900e - white screen
« Reply #8 on: October 01, 2019, 06:13:23 pm »
19.3 and 14 from the neck card with a game running
Can see interference on screen with game running, no colour, everythingís white
Defender(multiwilliams), SF2CE
Whirlwind, Lethal Weapon 3

grantspain

  • I personally prefer "bog trotter"
  • Trade Count: (+1)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 5943
  • Last login:Today at 05:25:12 am
Re: Hantarex MTC900e - white screen
« Reply #9 on: October 01, 2019, 06:48:06 pm »
what is the chassis b+ reading, use one of the centre 2 pins of the deflection coil connector and frame as ground- should be around 126v

CathalDublin

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 258
  • Last login:March 08, 2020, 09:26:02 pm
Re: Hantarex MTC900e - white screen
« Reply #10 on: October 01, 2019, 07:07:50 pm »
Itís 217.

Edit: actually I should be testing DC? Iíve my meter set to AC.
So thatís 138v b+
12v is bang on 12v
And Iíll need to retest my -5 tomorrow 🤦🏻‍♂️
« Last Edit: October 01, 2019, 07:20:39 pm by CathalDublin »
Defender(multiwilliams), SF2CE
Whirlwind, Lethal Weapon 3

grantspain

  • I personally prefer "bog trotter"
  • Trade Count: (+1)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 5943
  • Last login:Today at 05:25:12 am
Re: Hantarex MTC900e - white screen
« Reply #11 on: October 01, 2019, 10:00:04 pm »
yes dc volts
set your b+ to 126vdc by adjusting RV12

test the video b+ at SP4 neck card- should be around 190-200vdc
test the -5 at SP7 neck card

CathalDublin

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 258
  • Last login:March 08, 2020, 09:26:02 pm
Re: Hantarex MTC900e - white screen
« Reply #12 on: October 03, 2019, 07:24:04 pm »
Iíve my b+ Dialled in at 126v now, and at SP4 itís about 215v
My 12v is stable at 12v
But my -5v is reading 7.5v
« Last Edit: October 03, 2019, 07:28:03 pm by CathalDublin »
Defender(multiwilliams), SF2CE
Whirlwind, Lethal Weapon 3

grantspain

  • I personally prefer "bog trotter"
  • Trade Count: (+1)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 5943
  • Last login:Today at 05:25:12 am
Re: Hantarex MTC900e - white screen
« Reply #13 on: October 04, 2019, 02:13:18 am »
check the following
c25, c83, c36- replace in any case
all diodes around that area
ic1 7905  -5v regulator

the input to ic1 should be 12v