Main Restorations Software Audio/Jukebox/MP3 Everything Else Buy/Sell/Trade
Project Announcements Monitor/Video GroovyMAME Merit/JVL Touchscreen Meet Up Retail Vendors
Driving & Racing Woodworking Software Support Forums Consoles Project Arcade Reviews
Automated Projects Artwork Frontend Support Forums Pinball Forum Discussion Old Boards
Raspberry Pi & Dev Board controls.dat Linux Miscellaneous Arcade Wiki Discussion Old Archives
Lightguns Arcade1Up --- Bug Reports --- Site News

Unread posts | New Replies | Recent posts | Rules | Chatroom | Wiki | File Repository | RSS | Submit news

  

Author Topic: RetroPie only seeing 1 gamepad (SJ@JX CY-2121) ** SOLVED **  (Read 107 times)

0 Members and 1 Guest are viewing this topic.

Deek069

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 10
  • Last login:Today at 03:50:53 am
  • I want to build my own arcade controls!
RetroPie only seeing 1 gamepad (SJ@JX CY-2121) ** SOLVED **
« on: August 08, 2019, 02:14:43 pm »
So this had me stumped for a while but I've resolved it now - so I thought I'd share incase anybody else has the same issue.

1. Plug a keyboard in and configure the keyboard as a controller.

2. Very important: Update RetroPie - even if you've just installed the latest image. To do this go to the RetroPie menu, select RetroPie Setup and select Update. Answer yes to all questions. It takes a while so just be patient :)

2. Reboot your system

3. Go to RetroPie, File Manager, navigate to /boot and highlight *cmdline.txt and press F4.

4. Go to the end of the line - do not start a new line, and type the following: usbhid.quirks=0x0810:0xe001:0x00000040

Note the above only works with the exact model SJ@JX CY-2121 - if you have something different then run the following command from the command line "lsusb". Find you USB controller and replace 0x0810:0xe001 with the values for your controller.

5. Reboot your system again

6. Now when you configure your controllers it should be seeing two gamepads rather than one.

7. If your gamepads are in the wrong order you can fix this by going to RetroPie, Configuration Editor, Configure basic libretro emulator options, and then Configure default options. Option 7 is choose joypad order.

Hope this helps somebody :)

Sorry if this has already been posted - I did search but couldn't find this solution.
« Last Edit: August 08, 2019, 02:16:43 pm by Deek069 »