Main Restorations Software Audio/Jukebox/MP3 Everything Else Buy/Sell/Trade
Project Announcements Monitor/Video GroovyMAME Merit/JVL Touchscreen Meet Up Retail Vendors
Driving & Racing Woodworking Software Support Forums Consoles Project Arcade Reviews
Automated Projects Artwork Frontend Support Forums Pinball Forum Discussion Old Boards
Raspberry Pi & Dev Board controls.dat Linux Miscellaneous Arcade Wiki Discussion Old Archives
Lightguns Arcade1Up --- Bug Reports --- Site News

Unread posts | New Replies | Recent posts | Rules | Chatroom | Wiki | File Repository | RSS | Submit news

  

Author Topic: Two UltraStik 360s - cannot get Joystick 1 to stay Joystick 1  (Read 376 times)

0 Members and 1 Guest are viewing this topic.

darthclem

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 10
  • Last login:July 28, 2019, 09:16:52 am
  • I want to build my own arcade controls!
I'm at my wits end trying to upgrade my arcade cabinet.  I have two UltraStik 360s in my cabinet.  While in the process of configuring HyperHQ and RocketLauncher with JoytoKey and testing out emulators like MAME and Stella, I was noticing some really perplexing behavior from the controllers.  If I had just one plugged in, it worked fine as Joystick 1 (mounted on the left of my cabinet).  Once I connected the second controller, Joystick 2 (mounted on the right) became Joystick 1 and vice versa in Hyperspin, MAME and other emulators.  However, they still appeared and behaved properly in the USB controller section of the Windows 10 control panel.

I've tried setting the IDs with UltraMap.  I've swapped the USB cables.  I've swapped the USB ports they are plugged into.  I even physically swapped the two sticks in cabinet, thinking that if the right stick wants to be player 1, I'll just move that stick to the left mount.  As soon as I rebooted the cabinet, the controller on the left had become Joystick #2 again and the one one the right had become #1.

If this problem only happened in MAME, I could just configure it accordingly -- but since I also see the same issue in Stella, I believe it to be a bigger configuration issue.  Also, this problem happens whether I'm launching emulators via Hyperspin or directly through Windows Explorer.

Any thoughts?