Main Restorations Software Audio/Jukebox/MP3 Everything Else Buy/Sell/Trade
Project Announcements Monitor/Video GroovyMAME Merit/JVL Touchscreen Meet Up Retail Vendors
Driving & Racing Woodworking Software Support Forums Consoles Project Arcade Reviews
Automated Projects Artwork Frontend Support Forums Pinball Forum Discussion Old Boards
Raspberry Pi & Dev Board controls.dat Linux Miscellaneous Arcade Wiki Discussion Old Archives
Lightguns Arcade1Up --- Bug Reports --- Site News

Unread posts | New Replies | Recent posts | Rules | Chatroom | Wiki | File Repository | RSS | Submit news

  

Author Topic: Problem with Groovy Mame - Attract mode on Sega Astro  (Read 2463 times)

0 Members and 1 Guest are viewing this topic.

Delvis

  • Trade Count: (0)
  • Jr. Member
  • **
  • Offline Offline
  • Posts: 3
  • Last login:March 17, 2019, 03:30:07 am
  • I want to build my own arcade controls!
Problem with Groovy Mame - Attract mode on Sega Astro
« on: March 15, 2019, 02:02:15 am »
Hello together

I bought a New Sega Astro City and now a want to use PC as Emu Station.
I use a AMD Radeaon 6450. Mame and Groovy mame are installed. The CRT Emu Drivers as well. As front end I am using Attract Mode.

In VMaker i installed the modlines and if i run AM in window mode - everything seems ok. If i switch to FullSize screen - the screen is doubled.
Cant figure out what i am doing wrong :(

I will add some screenshots of the picture on the Sega and the Modelines.
Would be great if you guys could help me.

Many thanks in advance



Many thanks in advance

keilmillerjr

  • Trade Count: (+5)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 1796
  • Last login:Today at 02:53:17 pm
  • Web Developer.
Re: Problem with Groovy Mame - Attract mode on Sega Astro
« Reply #1 on: March 15, 2019, 06:23:38 am »
Try fill screen (default). Full screen sometimes has issues. Some commits pulled in git repo today to help wirg sone window mode issues.

Calamity

  • Moderator
  • Trade Count: (0)
  • Full Member
  • *****
  • Offline Offline
  • Posts: 6861
  • Last login:Today at 05:44:02 pm
  • Quote me with care
Re: Problem with Groovy Mame - Attract mode on Sega Astro
« Reply #2 on: March 15, 2019, 01:46:26 pm »
Delvis, try this:

 1 - Stop and Disable service: AMD External events utility
 2 - Ensure that the Windows advanced display option is enable: "hide modes that is monitor cannot display"


@keilmillerjr, not sure if you're a contributor to AM. I believe this issue happens with software that sets the fullscreen resolution by a width & height pair of values, omitting the refresh, instead of using the correct width x height @ refresh unambiguous formula. If you allow Windows freedom to pick the refresh, it'll go to 31 kHz most of the times. Stopping AMD's service as described above masks this problem by not making those refresh rates available to Windows, but the underlying issue is still there in the weak mode setting logic inside the frontend/emulator.
Important note: posts reporting GM issues without a log will be IGNORED.
Steps to create a log:
 - From command line, run: groovymame.exe -v romname >romname.txt
 - Attach resulting romname.txt file to your post, instead or pasting it.

CRT Emudriver, VMMaker & Arcade OSD downloads, documentation and discussion:  Eiusdemmodi

Delvis

  • Trade Count: (0)
  • Jr. Member
  • **
  • Offline Offline
  • Posts: 3
  • Last login:March 17, 2019, 03:30:07 am
  • I want to build my own arcade controls!
Re: Problem with Groovy Mame - Attract mode on Sega Astro
« Reply #3 on: March 15, 2019, 02:30:37 pm »
Hi guys,

thanks for your reply.

first: fill screen causes the same problem as fullscreen

The AMD External events utility is not installed - at least i cant find it

When i go in Monitor Display settings - I have the checkmark at "hide modes which the moni cant display"

I also can choose between 30khz and 60 - currently it is on 30 with "rowjump"

BR


SteelRush

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 60
  • Last login:Today at 03:40:24 pm
  • I want to build my own arcade controls!
Re: Problem with Groovy Mame - Attract mode on Sega Astro
« Reply #4 on: March 16, 2019, 01:58:17 pm »
Hi guys,

thanks for your reply.

first: fill screen causes the same problem as fullscreen

The AMD External events utility is not installed - at least i cant find it

Look for the service named AMD External Events.  Stop the service and set it to manual or disabled to prevent it from running.  Once you do this, it should stop running the wrong resolution in AM.  Search for Services.msc to find the services manager.

Delvis

  • Trade Count: (0)
  • Jr. Member
  • **
  • Offline Offline
  • Posts: 3
  • Last login:March 17, 2019, 03:30:07 am
  • I want to build my own arcade controls!
Re: Problem with Groovy Mame - Attract mode on Sega Astro
« Reply #5 on: March 17, 2019, 03:30:26 am »
Hi

i do not have it installed. I found the services file but in there, there is no AMD utility at all...

I only installed the CRT Emudriver & CRT Tools 2.0 beta 15 (Catalyst 12.6) for Windows 7/8/10 64-bits. I have Win7(64bits) running and an ATI Radeon6450

today another problem occured: i turned the Win Testsign to "off" - and now i after booting the screen on my Sega stays black...

Help would highly be appreciated :)

Many thanks

Calamity

  • Moderator
  • Trade Count: (0)
  • Full Member
  • *****
  • Offline Offline
  • Posts: 6861
  • Last login:Today at 05:44:02 pm
  • Quote me with care
Re: Problem with Groovy Mame - Attract mode on Sega Astro
« Reply #6 on: March 17, 2019, 05:26:25 am »
today another problem occured: i turned the Win Testsign to "off" - and now i after booting the screen on my Sega stays black...

Surprise   ;D

Just curious where you got the idea you can simply turn testsigning off with CRT Emudriver installed.

Anyway, once you reenable testsigning and get things working again, there's something you can test:

- I think AM messes video since it tries to set fullscreen over the current desktop mode (640x480) without specifying the refresh. This causes a 31 kHz modeo to get invoked. This is possible because 640x480@31kHz is a built-in default native mode.

- With that in mind, if you set your desktop to whatever that has no 31 kHz native version counterpart, AM won't probably be able to mess it.

- Launch VMMaker, and in settings/user modes, edit user_modes_super.ini file, and below "640x480@60.000 destkop", add a new line with "648x486@60.000 desktop". Save.

- Generate and install modes again.

- Now, launch Arcade OSD and select 648x486 as your new desktop mode. Lauch AM and see what happens.

Important note: posts reporting GM issues without a log will be IGNORED.
Steps to create a log:
 - From command line, run: groovymame.exe -v romname >romname.txt
 - Attach resulting romname.txt file to your post, instead or pasting it.

CRT Emudriver, VMMaker & Arcade OSD downloads, documentation and discussion:  Eiusdemmodi

bjt42

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 34
  • Last login:July 02, 2019, 05:22:20 am
  • I want to build my own arcade controls!
Re: Problem with Groovy Mame - Attract mode on Sega Astro
« Reply #7 on: March 18, 2019, 06:53:28 am »
I also have this issue with AM and don't have the AMD External Events service (using the older Catalyst based CRT Emudriver on a HD5450).
My workaround was to use windowed (borderless) mode in AM, so it doesn't attempt to change the mode.