Main Restorations Software Audio/Jukebox/MP3 Everything Else Buy/Sell/Trade
Project Announcements Monitor/Video GroovyMAME Merit/JVL Touchscreen Meet Up Retail Vendors
Driving & Racing Woodworking Software Support Forums Consoles Project Arcade Reviews
Automated Projects Artwork Frontend Support Forums Pinball Forum Discussion Old Boards
Raspberry Pi & Dev Board controls.dat Linux Miscellaneous Arcade Wiki Discussion Old Archives
Lightguns --- Bug Reports --- Site News

Unread posts | New Replies | Recent posts | Rules | Chatroom | Wiki | File Repository | RSS | Submit news

  

Author Topic: Image disappearing on Trinitron TV  (Read 304 times)

0 Members and 1 Guest are viewing this topic.

Professor Jones

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 27
  • Last login:Yesterday at 05:51:09 am
  • Ain't nothing like the real thing
Image disappearing on Trinitron TV
« on: March 04, 2019, 04:01:14 pm »
Hey,

An annoying problem recently started to occur on my Sony crt. The image suddenly disappears and I see a fading dot in the center of the screen before it completely blacks out. The sound is still working when this occurs and the led blinks to signify that there's an error. The image sometimes reappears without any action on my part, other times turning the TV off and on makes the image reappear. I recently changed the caps (after I first noticed the problem) but it did not correct that problem. I set the G2/screen pot on the flyback by making the retrace lines appear then slowly turing the pot just enough to make them disappear. The TV can go for hours without the problem occuring, it seems to happen rarely and randomly. What could be causing this ?

silmalik

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 73
  • Last login:March 09, 2019, 12:41:36 pm
  • I want to build my own arcade controls!
Re: Image disappearing on Trinitron TV
« Reply #1 on: March 04, 2019, 04:58:20 pm »
Hi Professor,

Maybe obvious but the service menu may give a lead.
There is a kind of debug section, with error code that the service manual can explain.

Professor Jones

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 27
  • Last login:Yesterday at 05:51:09 am
  • Ain't nothing like the real thing
Re: Image disappearing on Trinitron TV
« Reply #2 on: March 04, 2019, 05:05:26 pm »
The error count is 30 for "no vertical synch" and "AKB".

buttersoft

  • Trade Count: (+1)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 792
  • Last login:Yesterday at 02:13:31 am
  • Is running at 15kHz
Re: Image disappearing on Trinitron TV
« Reply #3 on: March 04, 2019, 08:57:05 pm »
If this is the same KV-21C5B please keep everything in the one thread :)

Google doesn't think that model exists. Can you link to a service manual for it?

Vertical sync is part of the deflection section, obviously, but AKB is like the master brightness feedback, and controls the beam current and power going into the picture itself, perhaps through the grids. I'm not sure if the two are linked, let alone how. If i had to guess, i'd say it was a power supply issue, again possibly connector related.

I doubt i'll be able to help much, but with the service manual someone else might.

Professor Jones

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 27
  • Last login:Yesterday at 05:51:09 am
  • Ain't nothing like the real thing
Re: Image disappearing on Trinitron TV
« Reply #4 on: March 05, 2019, 03:28:18 am »
Sorry about the multiple threads, I thought it would make things clearer to create a new one.

My understanding is that the AKB error triggers the "no vertical sync" one. The way I set the G2 (is that synonymous with AKB ?) is not the way that's described in the service manual, because I would need an oscilloscope to do so and I don't.

Here is a link to the service manual :

https://drive.google.com/file/d/1tfvby8XssWN4aR0rr0Hp9rOrz1BUo95S/view?usp=sharing

I'm thinking there might be a cold solder joint on the flyback, but it's just a wild guess. I will redo them just in case.

buttersoft

  • Trade Count: (+1)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 792
  • Last login:Yesterday at 02:13:31 am
  • Is running at 15kHz
Re: Image disappearing on Trinitron TV
« Reply #5 on: March 05, 2019, 06:04:04 pm »
G2 is the screen grid voltage, the AKB is to do with regulating beam current and image brightness and helps limit the set for x-ray protection. The two are very much linked in that the higher the screen grid voltage the the higher the beam current, causing AKB to regulate other voltages and make sure the beam current doesn't get too high.

Unless i have this totally wrong, and AKB is like the black level balance. This is related to the timing of the back porch following the sync interval and preceding a new burst/line, and would actually have more to do with the vertical sync pulse not being caught, now i think about it. If this is the case, i don't think it will be flyback-related.

None of which helps you in particular, sorry! Just telling you to have a look at the vertical sync section is pretty vague, but so is telling you to look at voltages.

Professor Jones

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 27
  • Last login:Yesterday at 05:51:09 am
  • Ain't nothing like the real thing
Re: Image disappearing on Trinitron TV
« Reply #6 on: March 07, 2019, 06:27:19 am »
I managed to sort out the problem by redoing the solder joints on the main PCB and RGB amp pcb. One or more of them was giving the TV problems (maybe the ones that were related to the G2). So if someone has the same problem, that is a good thing to try.

Thanks to buttersoft and silmalik for replying to the topic :)