Main Restorations Software Audio/Jukebox/MP3 Everything Else Buy/Sell/Trade
Project Announcements Monitor/Video GroovyMAME Merit/JVL Touchscreen Meet Up Retail Vendors
Driving & Racing Woodworking Software Support Forums Consoles Project Arcade Reviews
Automated Projects Artwork Frontend Support Forums Pinball Forum Discussion Old Boards
Raspberry Pi & Dev Board controls.dat Linux Miscellaneous Arcade Wiki Discussion Old Archives
Lightguns Arcade1Up --- Bug Reports --- Site News

Unread posts | New Replies | Recent posts | Rules | Chatroom | Wiki | File Repository | RSS | Submit news

  

Author Topic: Rowe cd100a power supply  (Read 483 times)

0 Members and 1 Guest are viewing this topic.

JimM3

  • Trade Count: (0)
  • Jr. Member
  • **
  • Offline Offline
  • Posts: 2
  • Last login:December 27, 2018, 07:10:58 am
Rowe cd100a power supply
« on: December 17, 2018, 07:26:55 pm »
Hi all I have a cd100a have had it for 7 year or so. This past summer I turned it on and nothing. I finally got around to digging in to it and noticed no 8v led. Do I need a power supply?  Can it be repaired? Is there any upgraded models? Thanks in advance Jim

Ken Layton

  • Guru
  • Trade Count: (0)
  • Full Member
  • ****
  • Offline Offline
  • Posts: 6885
  • Last login:Yesterday at 11:32:27 pm
  • Technician
Re: Rowe cd100a power supply
« Reply #1 on: December 17, 2018, 09:44:37 pm »
You probably have a blown fuse and a shorted diode on the power supply board.

JimM3

  • Trade Count: (0)
  • Jr. Member
  • **
  • Offline Offline
  • Posts: 2
  • Last login:December 27, 2018, 07:10:58 am
Re: Rowe cd100a power supply
« Reply #2 on: December 18, 2018, 03:03:48 pm »
The fuses test ok. So must be a diode.

Will any of the other power supply’s work like a 40770612 or do I need an original 40770607 ?

Or do I need to get the exact unit