Main Restorations Software Audio/Jukebox/MP3 Everything Else Buy/Sell/Trade
Project Announcements Monitor/Video GroovyMAME Merit/JVL Touchscreen Meet Up Retail Vendors
Driving & Racing Woodworking Software Support Forums Consoles Project Arcade Reviews
Automated Projects Artwork Frontend Support Forums Pinball Forum Discussion Old Boards
Raspberry Pi & Dev Board controls.dat Linux Miscellaneous Arcade Wiki Discussion Old Archives
Site News

Unread posts | New Replies | Recent posts | Rules | Chatroom | Wiki | File Repository | RSS | Submit news


  

Author Topic: Button Mapping Problem in Emulation Station under RetroPie  (Read 149 times)

0 Members and 1 Guest are viewing this topic.

belfastrab

  • Trade Count: (0)
  • Jr. Member
  • **
  • Offline Offline
  • Posts: 2
Button Mapping Problem in Emulation Station under RetroPie
« on: November 05, 2018, 10:54:27 am »
Hi All

I building a full sized arcade cabinet at the moment using a Pi 3B+, RetroPie v4.4 and 3 zero delay USB Keyboard Encoders with arcade style joysticks and buttons connected to the encoder boards.

I have 2 players so one usb keyboard encoder per player and a third usb encoder just for a coin mechanism and a hidden credit button. So the plan is that both the hidden credit button and coin mech are connected to the same input on the 3rd usb keyboard encoder.

Emulation Station on first boot sees that there is 3 usb input devices and the 1 and 2 player encoders work perfectly in setting up the buttons and then when I run out of physical buttons I can just hold any button to skip the rest of the buttons on the setup on screen and job done. However with the 3rd encoder I press the hidden credit button and it maps fine to button A and for the rest of the button mapping onscreen I should be able to press and hold the one button to skip through the rest of it but it won't let me. I press and hold the button for anything up to 30 seconds and it just won't skip like it did on the 1 and 2 player button setup. I tried adding a few spare buttons to the 3rd usb encoder just to see if having the extra physical buttons would allow me to skip but they don't. Is there a minimum number of buttons that need to be setup in Emulation Station before it allows me to skip the rest of the setup?

Just to be clear as I say the 3rd usb keyboard encoder is just for credit / coin input with a single button and coin mech sharing the same input so the player has the choice of pressing the button for a credit or putting a coin into the coin mech.

Is there a way to manually edit the button config for this 3rd usb encoder from the command line or something rather than having to use the emulation station gui config that unless you can get to the end of it by skipping which it won't allow me to do there is no way to save it just the option to F4 out of it.

I did try going into the MAME setup while in an arcade game and add the credit button there but it didn't work and I think I remember seeing somewhere that if you don't set up the controller via the emulation station button config then MAME or other emulators won't see it in their own set up menu.

If anyone has any ideas or suggestions I would be most grateful as I have Googled for hours trying to figure this out and haven't found anything to fix the situation yet.

Also just for your information... the 1 player and 2 player usb encoders are for illuminated buttons and work by passing a voltage not just to the bulb / led on the buttons but across the switch / button and registers a keypress when the voltage / circuit is broken which is fine I suppose but therefore doesn't allow me to use the coin mech on either of these boards because the coin mech pulses a voltage to register a keypress so hence why having to use a 3rd usb keyboard encoder board for the coin mech.

Thanks

Rab

Titchgamer

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 2808
  • I have a gaming addiction.....
Re: Button Mapping Problem in Emulation Station under RetroPie
« Reply #1 on: November 05, 2018, 01:00:20 pm »
Sounds like you made this more complicated than needed :p

But, I am not sure if there is a minimum button count, I presume there is so you could temporarily hook up buttons to the 3rd encoder to get it through the setup script.

Or (possibly easier) you can edit a text file on the pi itself.
I can not remember which it is but a quick google search should tell you.

Just edit the file, save it and job done.

barrymossel

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 430
  • Spectrum
    • forum.arcadecontrols.com/index.php/topic,157647.0.html
Re: Button Mapping Problem in Emulation Station under RetroPie
« Reply #2 on: November 06, 2018, 09:30:49 am »
First: the Zero delay encoders aren't keyboard encoders, but gamepad encoders. Second: why use the third encoder while the select button on P1 and P2 actually are used as the coin buttons? Third: the Zero delay encoders will have to have all buttons attached to the same inputs on the board as far as I know.

So, read my second point again and just use two encoders and attach the coin door as well as the secret coin button both to the P1 select input. Some games use two different coin buttons though, so if you only have one secret coin buttons and one coin acceptor, you could wire the coin door to P2 select and the coin button to P1 select (or the other way around). I believe when just one coin button is used in mame, both P1 and P2 select will work for coins. When two coin buttons are used, you can use the secret coin button for P1 and the coin door for P2 (or the other way around).

  
 

Sitemap 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31