Main Restorations Software Audio/Jukebox/MP3 Everything Else Buy/Sell/Trade
Project Announcements Monitor/Video GroovyMAME Merit/JVL Touchscreen Meet Up Retail Vendors
Driving & Racing Woodworking Software Support Forums Consoles Project Arcade Reviews
Automated Projects Artwork Frontend Support Forums Pinball Forum Discussion Old Boards
Raspberry Pi & Dev Board controls.dat Linux Miscellaneous Arcade Wiki Discussion Old Archives
Site News

Unread posts | New Replies | Recent posts | Rules | Chatroom | Wiki | File Repository | RSS | Submit news


  

Author Topic: Advice on fixing some new input lag with Groovymame 197.  (Read 444 times)

0 Members and 1 Guest are viewing this topic.

Zebra

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 88
  • I want to build my own arcade controls!
Advice on fixing some new input lag with Groovymame 197.
« on: October 31, 2018, 03:34:34 pm »
What are some of the potential causes of new (and excessive) input lag in Groovymame?

My mame set-up used to run very well with no noticeable input delay but recently, my joystick feels slow with a visible delay between button press and movement on-screen.

My PC runs an Intel I7 3930 overclocked to 4.2ghz but I have been having a lot of problems with it lately and I have changed some stuff:

- Downgraded my GPU from a 4890 to a 5450
- Upgraded Windows XP 32 / soft 15khz to Windows 7 pro 64 / crt emu
- Switched to Groovymame 197 from regular mame 158

I don't think the issue is from Groovymame unless GM 197 is know to run worse than other versions? Are there any settings I should check in mame that effect input delay / joystick sensitivity (digital)?

Could the lower spec gpu cause the issue? I read that mame needs a good CPU but doesn't make use of the GPU. Is this really true?

Could mame be effected by the SSD hard drive being too full?

I am getting a lot of new over-clocking errors when I boot up. Could a drop from 4.2ghz to 3.8ghz make a noticeable difference to mame?

krick

  • Trade Count: (+1)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 1925
  • Gotta have blue hair.
Re: Advice on fixing some new input lag with Groovymame 197.
« Reply #1 on: October 31, 2018, 09:29:39 pm »
If you overclock your CPU too high without adequate cooling, the CPU will throttle the clock back to keep itself cool, which defeats the whole point of overclocking.

You might want to check it out using the Intel Extreme Tuning Utility.  It should tell you if it's throttling or not...
https://downloadcenter.intel.com/download/24075/Intel-Extreme-Tuning-Utility-Intel-XTU-

Your PC specs seem decent and the Radeon HD 5xxx series is a better choice for CRT Emudriver than the 4xxx series.

When you "switched" from regular MAME to GroovyMAME, did you start with a clean install folder for the GroovyMAME distribution or did you just copy the EXE file into your old directory?

Are you having problems with specific games?

Remember, as Calamity says....

Quote
Important note: posts reporting GM issues without a log will be IGNORED.
Steps to create a log:
 - From command line, run: groovymame.exe -v romname >romname.txt
 - Attach resulting romname.txt file to your post, instead or pasting it.
Hantarex Polo 15KHz
Sapphire Radeon HD 7750 2GB (GCN)
GroovyMAME 0.197.017h_d3d9ex
CRT Emudriver & CRT Tools 2.0 beta 13 (Crimson 16.2.1 for GCN cards)
Windows 7 Home Premium 64-bit
Intel Core i7-4790K @ 4.8GHz
ASUS Z87M-PLUS Motherboard

jimmer

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 517
  • I want to play Defender like at the arcade.
Re: Advice on fixing some new input lag with Groovymame 197.
« Reply #2 on: November 01, 2018, 07:33:04 am »

Have you got frame_delay 1 (or 2,3,4) in your  mame.ini   

I can never remember the full details, but in some variations  frame_delay 0 can give you multiple frames of lag.

On forums jimmer speaks for himself as a Defender fan, not as proprietor of www.jbgaming.co.uk  << Is that advertising or disclosure ? or both ?

Zebra

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 88
  • I want to build my own arcade controls!
Re: Advice on fixing some new input lag with Groovymame 197.
« Reply #3 on: November 01, 2018, 01:17:13 pm »
If you overclock your CPU too high without adequate cooling, the CPU will throttle the clock back to keep itself cool, which defeats the whole point of overclocking.

You might want to check it out using the Intel Extreme Tuning Utility.  It should tell you if it's throttling or not...
https://downloadcenter.intel.com/download/24075/Intel-Extreme-Tuning-Utility-Intel-XTU-

Your PC specs seem decent and the Radeon HD 5xxx series is a better choice for CRT Emudriver than the 4xxx series.

When you "switched" from regular MAME to GroovyMAME, did you start with a clean install folder for the GroovyMAME distribution or did you just copy the EXE file into your old directory?

Are you having problems with specific games?

Remember, as Calamity says....

Quote
Important note: posts reporting GM issues without a log will be IGNORED.
Steps to create a log:
 - From command line, run: groovymame.exe -v romname >romname.txt
 - Attach resulting romname.txt file to your post, instead or pasting it.

Thanks. I didn't think to try the intel extreme utility. I was just using the Asus software that they include with the general motherboard pack. I'll give it a try.

I don't think there is anything for Calamity to do in this. This is a new problem and is most likely related to something I did as it used to work well.

I started with a new install folder for GM but I didn't start with a clean Windows 7 install. The Windows desktop turned black after I installed CRT EMU and it still says "test mode" in the bottom right corner. Is that something I need to change?
If you overclock your CPU too high without adequate cooling, the CPU will throttle the clock back to keep itself cool, which defeats the whole point of overclocking.

You might want to check it out using the Intel Extreme Tuning Utility.  It should tell you if it's throttling or not...
https://downloadcenter.intel.com/download/24075/Intel-Extreme-Tuning-Utility-Intel-XTU-

Your PC specs seem decent and the Radeon HD 5xxx series is a better choice for CRT Emudriver than the 4xxx series.

When you "switched" from regular MAME to GroovyMAME, did you start with a clean install folder for the GroovyMAME distribution or did you just copy the EXE file into your old directory?

Are you having problems with specific games?

Remember, as Calamity says....

Quote
Important note: posts reporting GM issues without a log will be IGNORED.
Steps to create a log:
 - From command line, run: groovymame.exe -v romname >romname.txt
 - Attach resulting romname.txt file to your post, instead or pasting it.

Zebra

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 88
  • I want to build my own arcade controls!
Re: Advice on fixing some new input lag with Groovymame 197.
« Reply #4 on: November 01, 2018, 01:18:52 pm »

Have you got frame_delay 1 (or 2,3,4) in your  mame.ini   

I can never remember the full details, but in some variations  frame_delay 0 can give you multiple frames of lag.

I'll check. Are there any other settings in the GM ini that specifically effect input lag if set wrong?

krick

  • Trade Count: (+1)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 1925
  • Gotta have blue hair.
Re: Advice on fixing some new input lag with Groovymame 197.
« Reply #5 on: November 01, 2018, 02:26:49 pm »

I'll check. Are there any other settings in the GM ini that specifically effect input lag if set wrong?


Try a clean GM install with the default ini file and see if the lag problem is present.  Then compare your ini files with a diff tool like BeyondCompare to find the differences.
Hantarex Polo 15KHz
Sapphire Radeon HD 7750 2GB (GCN)
GroovyMAME 0.197.017h_d3d9ex
CRT Emudriver & CRT Tools 2.0 beta 13 (Crimson 16.2.1 for GCN cards)
Windows 7 Home Premium 64-bit
Intel Core i7-4790K @ 4.8GHz
ASUS Z87M-PLUS Motherboard

Zebidee

  • Trade Count: (+3)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 1029
Re: Advice on fixing some new input lag with Groovymame 197.
« Reply #6 on: November 01, 2018, 09:30:11 pm »

Have you got frame_delay 1 (or 2,3,4) in your  mame.ini   

I can never remember the full details, but in some variations  frame_delay 0 can give you multiple frames of lag.

Leave autoframeskip and frameskip=0, which they should be by default, at least for latest versions of GM.

I second that you follow krick's advice, and do a clean install of GM. Or at least delete mame.ini and everything in your /ini and /cfg folders then run VMM again with the "export settings" box ticked.

Quote
I started with a new install folder for GM but I didn't start with a clean Windows 7 install. The Windows desktop turned black after I installed CRT EMU and it still says "test mode" in the bottom right corner. Is that something I need to change?

Make sure that you have set the new custom 640x480i 15khz mode for your desktop (or whatever works for you). You will need to re-boot after installing CRTEMU (this is covered in the documentation) or any new modes via VMM.

Quote
My PC runs an Intel I7 3930 overclocked to 4.2ghz but I have been having a lot of problems with it lately

Do really need to overclock an i7 4.2GHz to play MAME? Seems like overkill, everything should be at 100% already? Don't forget that overclocking can stress your PC components beyond spec & likely reduces their lifespan.

Just an idea, check that you have DirectX installed. You can check by going to start menu, select "run", type "dxdiag" at the prompt.

If problems persist, don't see your doctor. Post log files per Calamity's instructions.
Check out my completed projects!


Zebra

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 88
  • I want to build my own arcade controls!
Re: Advice on fixing some new input lag with Groovymame 197.
« Reply #7 on: November 02, 2018, 04:23:04 pm »
If you overclock your CPU too high without adequate cooling, the CPU will throttle the clock back to keep itself cool, which defeats the whole point of overclocking.

You might want to check it out using the Intel Extreme Tuning Utility.  It should tell you if it's throttling or not...
https://downloadcenter.intel.com/download/24075/Intel-Extreme-Tuning-Utility-Intel-XTU-

Your PC specs seem decent and the Radeon HD 5xxx series is a better choice for CRT Emudriver than the 4xxx series.

When you "switched" from regular MAME to GroovyMAME, did you start with a clean install folder for the GroovyMAME distribution or did you just copy the EXE file into your old directory?

Are you having problems with specific games?

Remember, as Calamity says....

Quote
Important note: posts reporting GM issues without a log will be IGNORED.
Steps to create a log:
 - From command line, run: groovymame.exe -v romname >romname.txt
 - Attach resulting romname.txt file to your post, instead or pasting it.


That fixed the problem. To use the Intel utility, I had to disable the Asus software. Turns out that, in my attempts to fix my overclocking problem, I accidentally set all the Asus software to load with every Windows boot and then run in the background... as it turns out, they were a huge drain on performance.

And.... they stopped all of my USB 3 ports from working which didn't help.

I spent some time turning off everything unnecessary that Windows likes to run in the background and I am back to running Groovymame as it should be. It's a delight.

On to the next problem. How to make SNES emulators work again and to fix my "overclocking errors".

krick

  • Trade Count: (+1)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 1925
  • Gotta have blue hair.
Re: Advice on fixing some new input lag with Groovymame 197.
« Reply #8 on: November 02, 2018, 07:01:48 pm »
The ASUS P8Z77-M motherboard in my desktop PC came with an Intel USB 3.0 Driver.  If you don't have it, you might want to check the ASUS website for your motherboard, click on the "support" tab, then click on "Driver & Tools".  Personally, I'd download the latest available versions of all of the motherboard and chipset drivers and make sure everything is up-to-date.  Also make sure you have the latest full DirectX9 package installed...   https://www.microsoft.com/en-us/download/details.aspx?id=8109


I'm not sure what you mean about "overclocking errors".  Can you be more specific?

What is your exact motherboard model?  Usually overclocking in the BIOS only requires a few changes.  I never use windows-based overclocking tools or the "ASUS AI auto tune" stuff because the results are often not optimal.
Hantarex Polo 15KHz
Sapphire Radeon HD 7750 2GB (GCN)
GroovyMAME 0.197.017h_d3d9ex
CRT Emudriver & CRT Tools 2.0 beta 13 (Crimson 16.2.1 for GCN cards)
Windows 7 Home Premium 64-bit
Intel Core i7-4790K @ 4.8GHz
ASUS Z87M-PLUS Motherboard

Zebra

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 88
  • I want to build my own arcade controls!
Re: Advice on fixing some new input lag with Groovymame 197.
« Reply #9 on: November 04, 2018, 06:35:42 pm »
The ASUS P8Z77-M motherboard in my desktop PC came with an Intel USB 3.0 Driver.  If you don't have it, you might want to check the ASUS website for your motherboard, click on the "support" tab, then click on "Driver & Tools".  Personally, I'd download the latest available versions of all of the motherboard and chipset drivers and make sure everything is up-to-date.  Also make sure you have the latest full DirectX9 package installed...   https://www.microsoft.com/en-us/download/details.aspx?id=8109


I'm not sure what you mean about "overclocking errors".  Can you be more specific?

It's one of those "extreme gaming" motherboards so it has a whole lot of over-clocking options that I don't understand. This wasn't an issue until recently because it worked fine on it's default settings. Now, when I turn it on, it doesn't boot unless I unplug it, hold the reset button on the motherboard until the light goes out and then try booting for a second time.

I have to go through that annoying ritual every time I turn it on. On the 2nd boot attempt, it says "overclocking failed" but, if left, it then goes on to boot in some type of safer (slightly less over-clocked) mode. Apparently, it's a common issue with Asus motherboards....

I was able to reinstate USB 3 functionality by reinstalling the Asmedia drivers and then changing some settings on the bios menu.

What is your exact motherboard model?  Usually overclocking in the BIOS only requires a few changes.  I never use windows-based overclocking tools or the "ASUS AI auto tune" stuff because the results are often not optimal.

The motherboard is an Asus Maximus V extreme.

  
 

Sitemap 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31