Main Restorations Software Audio/Jukebox/MP3 Everything Else Buy/Sell/Trade
Project Announcements Monitor/Video GroovyMAME Merit/JVL Touchscreen Meet Up Retail Vendors
Driving & Racing Woodworking Software Support Forums Consoles Project Arcade Reviews
Automated Projects Artwork Frontend Support Forums Pinball Forum Discussion Old Boards
Raspberry Pi & Dev Board controls.dat Linux Miscellaneous Arcade Wiki Discussion Old Archives
Site News

Unread posts | New Replies | Recent posts | Rules | Chatroom | Wiki | File Repository | RSS | Submit news


  

Author Topic: rowe ami r83  (Read 334 times)

0 Members and 1 Guest are viewing this topic.

bryn.321

  • Trade Count: (0)
  • Jr. Member
  • **
  • Offline Offline
  • Posts: 5
rowe ami r83
« on: October 14, 2018, 02:37:44 pm »
hi need to replace foam on front mid high speaker, can anyone advice on where to purchase  this and the size thnx
 

ami-man

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 1040
Re: rowe ami r83
« Reply #1 on: October 19, 2018, 07:56:58 am »
Hello Bryn,

We do offer a replace foam surround service.

Send me a PM for details.

Regards
Alan

Alan Hood
ami-man
UK

bryn.321

  • Trade Count: (0)
  • Jr. Member
  • **
  • Offline Offline
  • Posts: 5
Re: rowe ami r83
« Reply #2 on: October 20, 2018, 12:09:31 pm »
hi Alan fixed the speaker  but now another problem on my r83, until I removed speaker the 1 under the key board all was fine its been ok since you fixed all the boards for me then later serv the amp, but now it wont select and carousel keeps turning, would it be me when removing speaker ?? thanks bryn.

ami-man

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 1040
Re: rowe ami r83
« Reply #3 on: October 23, 2018, 07:01:06 am »
Hello Bryn,

It was good to speak to you yesterday, once we have your boards back for testing/repair we can sort out the problem and also fix your missing pixels on the display.

Regards
Alan

Alan Hood
ami-man
UK

bryn.321

  • Trade Count: (0)
  • Jr. Member
  • **
  • Offline Offline
  • Posts: 5
Re: rowe ami r83
« Reply #4 on: October 28, 2018, 07:03:37 am »
Hi Alan, after pulling out plugs to selector and back in all seems fine now tried it a dozen times over the wk and works with out a fault, still need pixels doing on key board and need to no what parts you need now to do this many thanks Bryn.

ami-man

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 1040
Re: rowe ami r83
« Reply #5 on: October 29, 2018, 07:31:58 am »
Hello Bryn,

To sort out the display pixel problem out I would need the display board complete with its atached loom and the selector logic board.

Regards
Alan

Alan Hood
ami-man
UK

bryn.321

  • Trade Count: (0)
  • Jr. Member
  • **
  • Offline Offline
  • Posts: 5
Re: rowe ami r83
« Reply #6 on: November 06, 2018, 02:05:56 pm »
Hi Alan, still got fault with selector so will send all 3 boards and pixel display to you with in the next day many thanks Bryn.

ami-man

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 1040
Re: rowe ami r83
« Reply #7 on: November 08, 2018, 08:02:19 am »
Hello Bryn,

I will let you know what I find on receipt of your boards.

Regards
Alan

Alan Hood
ami-man
UK

  
 

Sitemap 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31