Main Restorations Software Audio/Jukebox/MP3 Everything Else Buy/Sell/Trade
Project Announcements Monitor/Video GroovyMAME Merit/JVL Touchscreen Meet Up Retail Vendors
Driving & Racing Woodworking Software Support Forums Consoles Project Arcade Reviews
Automated Projects Artwork Frontend Support Forums Pinball Forum Discussion Old Boards
Raspberry Pi & Dev Board controls.dat Linux Miscellaneous Arcade Wiki Discussion Old Archives
Lightguns Arcade1Up --- Bug Reports --- Site News

Unread posts | New Replies | Recent posts | Rules | Chatroom | Wiki | File Repository | RSS | Submit news

  

Author Topic: GPWiz49 & Ultimarc AimTrac lightgun  (Read 767 times)

0 Members and 1 Guest are viewing this topic.

Topgun_68

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 16
  • Last login:August 15, 2018, 12:05:41 pm
  • I'm a llama!
GPWiz49 & Ultimarc AimTrac lightgun
« on: August 15, 2018, 12:03:50 pm »
Has anyone ever seen this issue before. My USB GPwiz49 joystick worked fine as Joy 1 in Mame, but once I hooked up a new USB AimTrac lightgun, it constantly conflicts with the GPWiz joystick. If I go into mame and try to program player 1 control the GPWiz is coming up as Joy 2 and not working. If I unplug the USB Aimtrac lightgun the GPwiz goes back to joy 1 in mame and works. I tried changing the lightgun to Device 2, but that didn't get rid of the conflict.  I didn't see any way to change game controllers to force them as device 1 or 2. I am running Windows 7.

Thanks for any ideas!!
« Last Edit: August 15, 2018, 12:05:41 pm by Topgun_68 »

Titchgamer

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 3399
  • Last login:Today at 05:28:43 pm
  • I have a gaming addiction.....
Re: GPWiz49 & Ultimarc AimTrac lightgun
« Reply #1 on: August 15, 2018, 01:29:24 pm »
Windows is changing the USB device IDís.

You can either fix them in mame or use a program to fix them in windows.

It will happen whenever you have more than 1 USB control otherwise.