Main Restorations Software Audio/Jukebox/MP3 Everything Else Buy/Sell/Trade
Project Announcements Monitor/Video GroovyMAME Merit/JVL Touchscreen Meet Up Retail Vendors
Driving & Racing Woodworking Software Support Forums Consoles Project Arcade Reviews
Automated Projects Artwork Frontend Support Forums Pinball Forum Discussion Old Boards
Raspberry Pi & Dev Board controls.dat Linux Miscellaneous Arcade Wiki Discussion Old Archives
Site News

Unread posts | New Replies | Recent posts | Rules | Chatroom | Wiki | File Repository | RSS | Submit news


  

Author Topic: Error: The certificate of goo.gl is not trusted  (Read 605 times)

0 Members and 1 Guest are viewing this topic.

KenToad

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 858
  • Flap Flap Flap
Error: The certificate of goo.gl is not trusted
« on: May 07, 2018, 01:35:02 pm »
Hey,

I recently bought a Kintaro Super Kuma 9000 case and tried to install the safe power reset script through the f4 terminal. I got an error message basically saying that the target domain's certificate hadn't been activated. I've been researching the issue. It seems like maybe it's a date/time issue. My Pi is connected to the internet and localized correctly, but it is stuck on april 24, 2017.

Anybody have any clue? Need more information? I'm running Retropie, basically Mad Little Pixel's Hyperpie setup from 6 months ago or so. I haven't had any trouble installing stuff on this image from Github.

The command line is:
sudo wget -O - https://goo.gl/22RsN3 | bash

Thanks so much in advance.
Just Say No to Partially Hydrogenated Oil  www.bantransfats.com

Malenko

  • KNEEL BEFORE ZODlenko!
  • Trade Count: (+58)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 12907
    • forum.arcadecontrols.com/index.php/topic,142404.msg1475162.html
Re: Error: The certificate of goo.gl is not trusted
« Reply #1 on: May 07, 2018, 04:45:40 pm »
cert wont pass if the date/time is that far off
No matter one's station in life, the Dance of Death unites us all.

lilshawn

  • Trade Count: (+3)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 6069
  • I break stuff...then fix it...sometimes
Re: Error: The certificate of goo.gl is not trusted
« Reply #2 on: May 07, 2018, 04:47:40 pm »
I would first try "http" instead of "https". it might skirt around the security certificate date being "invalid"  due to the clock discrepancy. It should still redirect properly.

barrymossel

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 309
  • RetroPie all the way!
Re: Error: The certificate of goo.gl is not trusted
« Reply #3 on: May 08, 2018, 01:28:12 pm »
Hey,

I recently bought a Kintaro Super Kuma 9000 case and tried to install the safe power reset script through the f4 terminal. I got an error message basically saying that the target domain's certificate hadn't been activated. I've been researching the issue. It seems like maybe it's a date/time issue. My Pi is connected to the internet and localized correctly, but it is stuck on april 24, 2017.

Anybody have any clue? Need more information? I'm running Retropie, basically Mad Little Pixel's Hyperpie setup from 6 months ago or so. I haven't had any trouble installing stuff on this image from Github.

The command line is:
sudo wget -O - https://goo.gl/22RsN3 | bash

Thanks so much in advance.
Try: sudo wget -O - https://www.dropbox.com/s/gmziwqpipzpe38l/kintaroinstaller.sh | bash

Otherwise:

First: curl -s https://packagecloud.io/install/repositories/kintaro/pcb/script.deb.sh | sudo bash
Then: sudo apt-get -y install kintarosnes
« Last Edit: May 08, 2018, 01:30:35 pm by barrymossel »

KenToad

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 858
  • Flap Flap Flap
Re: Error: The certificate of goo.gl is not trusted
« Reply #4 on: May 09, 2018, 10:04:35 am »
Thanks all for the suggestions.

Despite having the timezone set correctly, my pi was stuck on a particular date and time. Here is what I did to get the time corrected.

sudo apt update; sudo apt install ntpdate
sudo systemctl stop ntp
sudo ntpdate -s pool.ntp.org

After that, the time showed correctly and I was able to download and install the package.

The source is a comment on this thread. https://www.reddit.com/r/RetroPie/comments/56ehgc/pi_3_date_and_time_not_setting/

A Reddit user named suprjami posted this as an explanation of the above command logic:

Quote
No worries mate, more than happy to help and glad to hear it's working well for you :)

sudo apt update

This refreshes the package manager, so if you search or download packages, you get the latest versions of any package you use.

sudo apt install ntpdate

This tells the package manager to install the ntpdate package, which contains the ntpdate program. This program can set the system clock by querying an NTP time server.

sudo systemctl stop ntp

This stops the background NTP service. We need to stop it because we can't manually update the system clock using ntpdate while the NTP service is trying to update the system clock as well.

Raspbian comes with this background NTP service enabled by default and it really should be already working and updating the time for you, but it's not for some reason.

sudo ntpdate -s pool.ntp.org

This uses the ntpdate program we installed prior, queries a freely available community time server in the NTP Pool project and uses that reliable internet time server to set the system clock.

    still good after reboots as well!

That's actually quite surprising, I expected if you rebooted then the clock would reset back to the old value. I'm honestly not sure why the background NTP service wasn't working for you before sorry. Maybe NTP had something "stuck" on an old value and just needed a little manual jog forward? I don't know the NTP service and its operation that deeply sorry.
« Last Edit: May 09, 2018, 10:06:44 am by KenToad »
Just Say No to Partially Hydrogenated Oil  www.bantransfats.com

  
 

Sitemap 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31