Main Restorations Software Audio/Jukebox/MP3 Everything Else Buy/Sell/Trade
Project Announcements Monitor/Video GroovyMAME Merit/JVL Touchscreen Meet Up Retail Vendors
Driving & Racing Woodworking Software Support Forums Consoles Project Arcade Reviews
Automated Projects Artwork Frontend Support Forums Pinball Forum Discussion Old Boards
Raspberry Pi & Dev Board controls.dat Linux Miscellaneous Arcade Wiki Discussion Old Archives
Site News

Unread posts | New Replies | Recent posts | Rules | Chatroom | Wiki | File Repository | RSS | Submit news


  

Author Topic: Megatouch force evo touchscreen  (Read 78 times)

0 Members and 1 Guest are viewing this topic.

nyramm

  • Trade Count: (0)
  • Jr. Member
  • **
  • Offline Offline
  • Posts: 1
  • I want to build my own arcade controls!
Megatouch force evo touchscreen
« on: May 06, 2018, 04:16:10 pm »
Hi,
I just purchased a Megatouch force evo which was working when I picked it up. Five hours later when I got it home it does not.

When turned on the bill acceptor makes noise , the fans move about 1/4 inch. Then nothing no boot, nothing on screen

The motherboard has a red light on in the center but the green one is not on

None of the caps are bulging

I have checked all the connections.

 :banghead: please help

Megatouchmike

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 14
  • I want to build my own arcade controls!
Re: Megatouch force evo touchscreen
« Reply #1 on: May 07, 2018, 10:31:04 pm »
Try bending a paperclip and joining the green wire and adjacent black wire on the ATX connector from the power supply to the motherboard

  
 

Sitemap 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31