Main Restorations Software Audio/Jukebox/MP3 Everything Else Buy/Sell/Trade
Project Announcements Monitor/Video GroovyMAME Merit/JVL Touchscreen Meet Up Retail Vendors
Driving & Racing Woodworking Software Support Forums Consoles Project Arcade Reviews
Automated Projects Artwork Frontend Support Forums Pinball Forum Discussion Old Boards
Raspberry Pi & Dev Board controls.dat Linux Miscellaneous Arcade Wiki Discussion Old Archives
Site News

Unread posts | New Replies | Recent posts | Rules | Chatroom | Wiki | File Repository | RSS | Submit news


  

Author Topic: Is there a command in MA to allow the console boot/logo/bios screen to display?  (Read 805 times)

0 Members and 1 Guest are viewing this topic.

goukuma

  • Trade Count: (0)
  • Jr. Member
  • **
  • Offline Offline
  • Posts: 9
  • I want to build my own arcade controls!
When SSF launches, the game starts up immediately, instead of seeing the Sega Saturn boot animation first.  I noticed that the bios isn't being used either, effecting games that need it to run properly(World Heroes Perfect).  When I run SSF outside of MA, the Saturn logo screen and bios are not an issue.  Any help is appreciated.

goukuma

  • Trade Count: (0)
  • Jr. Member
  • **
  • Offline Offline
  • Posts: 9
  • I want to build my own arcade controls!
Well, perhaps you are not selecting the game through SSF, rather through MA, which is mounting the cue, etc and then running SSF as the executable, and SSF is using the default settings.ini vs the individual games' ini used when launching the game from SSF, which saves your preferences on a game to game basis, giving you the illusion that it's not picking up on the bios, because a bios file was not chosen for the default settings.ini, and dang this is a long sentence!  Test this theory asap and report your findings back here.  Cross all your digits...

goukuma

  • Trade Count: (0)
  • Jr. Member
  • **
  • Offline Offline
  • Posts: 9
  • I want to build my own arcade controls!
I'm on it!  brb...  (ninja smoke bomb - poof!!!)

goukuma

  • Trade Count: (0)
  • Jr. Member
  • **
  • Offline Offline
  • Posts: 9
  • I want to build my own arcade controls!
I think you are on to something, but hear me out...  The SSF .ini file (default emulator settings) is not assigned a bios to start, which might explain why you are not seeing the logo screen, however once entered, I believe that you will indeed see it.  Here's the catch 22 - If you choose to use a bios (the only reason would be able to run a game that requires it), then you will need to choose a Region number and ensure that all your games match, or they won't be recognized (i.e. all Japanese games for Areacode 1, Japan).  You would have to change the Areacode before each MA session if you wanted to play a game from another region, or simply run multiple instances of SSF through Max Arcade, each with a different areacode assigned.  Good luck.

goukuma

  • Trade Count: (0)
  • Jr. Member
  • **
  • Offline Offline
  • Posts: 9
  • I want to build my own arcade controls!
I was wrong on all accounts - setting up the base SSF ini isn't the issue.  MA does a fine job mounting the .cue's and launching the game through SSF, but it somehow skips the logo/bios screen and cuts right to the game.  Coming out of fullscreen, I was able to check in the options tab to verify that there was indeed a bios and areacode set.  By ignoring the bios, games that require one to run properly, don't.  For example, the backgrounds in World Heroes Perfect are missing.  If anyone has any idea how to fix this, you are a hero in my book.

  
 

Sitemap 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31