Main Restorations Software Audio/Jukebox/MP3 Everything Else Buy/Sell/Trade
Project Announcements Monitor/Video GroovyMAME Merit/JVL Touchscreen Meet Up Retail Vendors
Driving & Racing Woodworking Software Support Forums Consoles Project Arcade Reviews
Automated Projects Artwork Frontend Support Forums Pinball Forum Discussion Old Boards
Raspberry Pi & Dev Board controls.dat Linux Miscellaneous Arcade Wiki Discussion Old Archives
Site News

Unread posts | New Replies | Recent posts | Rules | Chatroom | Wiki | File Repository | RSS | Submit news


  

Author Topic: Arm Champs II issue  (Read 932 times)

0 Members and 1 Guest are viewing this topic.

lilshawn

  • Trade Count: (+3)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 6135
  • I break stuff...then fix it...sometimes
Arm Champs II issue
« on: March 10, 2017, 06:06:02 pm »
Someone brought me a Arm Champs II machine to be looked at. Unfortunately It does not have a manual, nor, can I locate on online.

If anybody has some kind of experience with this machine...

it's failing the motor test at startup. When I go into the service mode and test everything, the left limit, center, right limit switches all operate and the pot for the rotation seems to pick up just fine. the "count" of the a/d conversion appears to be smooth with no jumping back and forth at all.

If I do a manual motor test in the service menu with the arm on the max left limit switch... press start...the motor operates until the limit switch disengages then stops. every time i press the start button, the motor pulses and moves the arm a tiny bit. once the arm has hit the right limit switch, the motor will no longer pulse.

now, the unusual bit...

If i uncouple the motor drive, and re run the above test...manually moving the arm to simulate it being hooked up... the motor stops when the limit switch is deactivated as before...but if i push the arm back onto the switch again, the motor will run again, but this time continue to run even if the arm is brought up and back over until it hits the right limit switch where the motor stops.

I thought there might be a fault with the motor, but I disassembled it and literally cleaned and rebuilt it in it's entirety.

it's hard to get a voltage measurement with a meter because it seems to PWM a speed control. even with a fluke 87 (measures 3vdc @ 15khz 58% duty cycle)

it seems to work in test, but it just don't.

any ideas?

lilshawn

  • Trade Count: (+3)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 6135
  • I break stuff...then fix it...sometimes
Re: Arm Champs II issue
« Reply #1 on: May 16, 2017, 12:23:44 pm »
ended up being an issue with the motor driver board (spill in a voltage comparator section), and the center detect switch (wired NO should have been NC position (someone messed with it before me))

partial schematic here:

kyle.boggs.9

  • Trade Count: (0)
  • Jr. Member
  • **
  • Offline Offline
  • Posts: 4
  • I want to build my own arcade controls!
Re: Arm Champs II issue
« Reply #2 on: July 10, 2018, 08:36:15 am »
Do you happen to have a manual for that machine?

Sent from my Pixel XL using Tapatalk


lilshawn

  • Trade Count: (+3)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 6135
  • I break stuff...then fix it...sometimes
Re: Arm Champs II issue
« Reply #3 on: July 10, 2018, 11:22:30 am »
no, unfortunatly just the partial schematic I posted here. I basically just got what I needed to fix the machine.

I got that document from a user over on KLOV forum... but searching through my history there, doesn't say who it was. (maybe mrsodapop?) There are a bunch of arm champs II threads there asking for schematics. maybe post in some of those users threads and see if anyone has one.

kyle.boggs.9

  • Trade Count: (0)
  • Jr. Member
  • **
  • Offline Offline
  • Posts: 4
  • I want to build my own arcade controls!
Re: Arm Champs II issue
« Reply #4 on: July 10, 2018, 08:18:41 pm »
no, unfortunatly just the partial schematic I posted here. I basically just got what I needed to fix the machine.

I got that document from a user over on KLOV forum... but searching through my history there, doesn't say who it was. (maybe mrsodapop?) There are a bunch of arm champs II threads there asking for schematics. maybe post in some of those users threads and see if anyone has one.
Lucky for you guys I have some awesome friends that tracked it down today.....


http://www.aurcade.com/games/manuals/00001340.pdf

Sent from my Pixel XL using Tapatalk


Mike A

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 2410
  • Buy a Multimeter
Re: Arm Champs II issue
« Reply #5 on: July 11, 2018, 08:29:25 am »
nice work. :cheers:

  
 

Sitemap 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31