Main Restorations Software Audio/Jukebox/MP3 Everything Else Buy/Sell/Trade
Project Announcements Monitor/Video GroovyMAME Merit/JVL Touchscreen Meet Up Retail Vendors
Driving & Racing Woodworking Software Support Forums Consoles Project Arcade Reviews
Automated Projects Artwork Frontend Support Forums Pinball Forum Discussion Old Boards
Raspberry Pi & Dev Board controls.dat Linux Miscellaneous Arcade Wiki Discussion Old Archives
Site News

Unread posts | New Replies | Recent posts | Rules | Chatroom | Wiki | File Repository | RSS | Submit news


  

Author Topic: Mala - Ledwiz : how to let admin button led ON? [RESOLVED]  (Read 666 times)

0 Members and 1 Guest are viewing this topic.

superbigjay

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 666
  • I'll always be a kid...
    • superbigjay website
Mala - Ledwiz : how to let admin button led ON? [RESOLVED]
« on: December 20, 2015, 06:18:19 pm »
Anyone have experience with the ledwiz plugin for mala?

I have setup the different buttons in the configurators and in the global settings, I have tick the checkboxes to let the control buttons on.

In Mala, when I scroll the games, I see the player buttons turning on and off to identify the button used.
The control button however are all OFF and I can't find where to specify that option (apart from the checkboxes mentionned above).

Also, I'd like to know if it is possible to leave all button ON after I quit Mala.
Right now, when I exit Mala, all buttons turn off.

Regards
« Last Edit: January 02, 2016, 12:39:47 am by superbigjay »

superbigjay

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 666
  • I'll always be a kid...
    • superbigjay website
Re: Mala - Ledwiz : how to let control button led ON?
« Reply #1 on: December 26, 2015, 08:06:04 pm »
Sorry to bump this thread, but I'm still stuck...


This is my config file:

 

Code: [Select]
1,1,1,1,0,5,1,3,200,0,0,,1,0,0,0,0
P1_START,1,SINGLE,0,0,0,0,0,0,0,18,48,0
P1_BUTTON1,1,SINGLE,0,0,0,0,0,0,0,8,48,0
P1_BUTTON2,1,SINGLE,0,0,0,0,0,0,0,9,48,0
P1_BUTTON3,1,SINGLE,0,0,0,0,0,0,0,10,48,0
P1_BUTTON4,1,SINGLE,0,0,0,0,0,0,0,11,48,0
P1_BUTTON5,1,SINGLE,0,0,0,0,0,0,0,12,48,0
P1_BUTTON6,1,SINGLE,0,0,0,0,0,0,0,13,48,0
P1_BUTTON7,1,SINGLE,0,0,0,0,0,0,0,14,48,0
P1_TRACKBALL,1,SINGLE,0,0,0,0,0,0,0,15,48,0
P2_START,1,SINGLE,0,0,0,0,0,0,0,25,48,0
P2_BUTTON1,1,SINGLE,0,0,0,0,0,0,0,1,48,0
P2_BUTTON2,1,SINGLE,0,0,0,0,0,0,0,2,48,0
P2_BUTTON3,1,SINGLE,0,0,0,0,0,0,0,3,48,0
P2_BUTTON4,1,SINGLE,0,0,0,0,0,0,0,4,48,0
P2_BUTTON5,1,SINGLE,0,0,0,0,0,0,0,5,48,0
P2_BUTTON6,1,SINGLE,0,0,0,0,0,0,0,6,48,0
P2_BUTTON7,1,SINGLE,0,0,0,0,0,0,0,7,48,0
ADMIN_PAUSE-P1,1,SINGLE,0,0,0,0,0,0,0,17,48,0
ADMIN_PAUSE-P2,1,SINGLE,0,0,0,0,0,0,0,26,48,0
ADMIN_VOLUME,1,SINGLE,0,0,0,0,0,0,0,19,48,0
ADMIN_EMU,1,SINGLE,0,0,0,0,0,0,0,20,48,0
ADMIN_URO,1,SINGLE,0,0,0,0,0,0,0,21,48,0
ADMIN_MOUSE-L,1,SINGLE,0,0,0,0,0,0,0,22,48,0
ADMIN_MOUSE-C,1,SINGLE,0,0,0,0,0,0,0,23,48,0
ADMIN_MOUSE-R,1,SINGLE,0,0,0,0,0,0,0,24,48,0
ADMIN_PINBALL-L1,1,SINGLE,0,0,0,0,0,0,0,32,48,0
ADMIN_PINBALL-L2,1,SINGLE,0,0,0,0,0,0,0,31,48,0
ADMIN_PINBALL-R1,1,SINGLE,0,0,0,0,0,0,0,29,48,0
ADMIN_PINBALL-R2,1,SINGLE,0,0,0,0,0,0,0,30,48,0
ADMIN_POWER-CAB,1,SINGLE,0,0,0,0,0,0,0,28,48,0


As you can see, all buton are setup to use single intensity.
Also, the first line that specify to lit the ctrl buttons, seems to be setup properly.

Any idea why the control button won't stay ON while in Mala or when Mame game is launched?

Note: All leds ramp up and flash when Mala launch. So I can confirm that they are properly connected/controlled on the ledwiz.

PS:you can disregard my question about when exiting mala. If needed, I'll use a command line at mala's exit...

superbigjay

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 666
  • I'll always be a kid...
    • superbigjay website
Re: Mala - Ledwiz : how to let control button led ON?
« Reply #2 on: January 02, 2016, 12:39:05 am »
Problem is resolved...

For the admin I left the effect at their default value NONE.
By changing them to ALWAYS_ON, it fixes the problem.

I didn't realized it at first because the action button where also left at NONE, but where ON/OFF depending on the game selected.

Well... my bad.
At least, I finally made it work.

Jay

  
 

Sitemap 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31