Main Restorations Software Audio/Jukebox/MP3 Everything Else Buy/Sell/Trade
Project Announcements Monitor/Video GroovyMAME Merit/JVL Touchscreen Meet Up Retail Vendors
Driving & Racing Woodworking Software Support Forums Consoles Project Arcade Reviews
Automated Projects Artwork Frontend Support Forums Pinball Forum Discussion Old Boards
Raspberry Pi & Dev Board controls.dat Linux Miscellaneous Arcade Wiki Discussion Old Archives
Lightguns --- Bug Reports --- Site News

Unread posts | New Replies | Recent posts | Rules | Chatroom | Wiki | File Repository | RSS | Submit news

  

Author Topic: GORF Aliens Missing on first screen! Whaaaaaa?  (Read 1053 times)

0 Members and 1 Guest are viewing this topic.

monkplayer

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 16
  • Last login:July 07, 2017, 07:32:31 pm
GORF Aliens Missing on first screen! Whaaaaaa?
« on: July 16, 2015, 06:23:23 pm »
On the first screen the top row of each of the aliens are represented as two dots, and my mussels and the aliens bombs aren't seen. What is the issue?
Taa Taa Taa, I eat Coins!

lilshawn

  • Trade Count: (+3)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 6236
  • Last login:Yesterday at 07:41:36 pm
  • I break stuff...then fix it...sometimes
Re: GORF Aliens Missing on first screen! Whaaaaaa?
« Reply #1 on: July 17, 2015, 03:08:03 pm »
1st rule, remove and reseat all the ROMs. almost 1/2 the time this is the issue. the ROM get's a ditty connection on one of the legs and stuff goes missing.

failing that, you may have a corrupted ROM. check to make sure all the ROM chips have their "windows" (if so equipped) covered with a sticker or tape or something to block the light out. any amount of light entering the ROM window can result in corrupted data.

monkplayer

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 16
  • Last login:July 07, 2017, 07:32:31 pm
Re: GORF Aliens Missing on first screen! Whaaaaaa?
« Reply #2 on: July 17, 2015, 05:54:37 pm »
I'm brand new to fixing arcades, because I've owned my Gorf for a month. Which board would be the most likely culprit?
Taa Taa Taa, I eat Coins!

SavannahLion

  • Wiki Contributor
  • Trade Count: (+1)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 5986
  • Last login:December 19, 2015, 02:28:15 am
Re: GORF Aliens Missing on first screen! Whaaaaaa?
« Reply #3 on: July 17, 2015, 11:37:29 pm »
No offense. Might want to download the GORF manual and learn a few bits on the basics.

http://www.crazykong.com/manuals/#G

Save that manual, print it if you want.

Check the table contents and you'll find the pages of interest start at 62 or 64 depending on your locale. Check those other pages too, they're helpful as well. I have some GORF pieces and there are some minor discrepancies on what I have but nothing to concern yourself over right now.

I also suggest reading up on the proper way to extract and reseat those IC's.

monkplayer

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 16
  • Last login:July 07, 2017, 07:32:31 pm
Re: GORF Aliens Missing on first screen! Whaaaaaa?
« Reply #4 on: July 18, 2015, 07:52:14 am »
I reseated all the chips last night, and I've tried reading the manual already as well as the schematics. The first thing I did was download the manual after buying the game. I also took a knife and cleaned both sides of each prong on almost all the chips. The reseating/cleaning of the chips didn't help.
Taa Taa Taa, I eat Coins!

SavannahLion

  • Wiki Contributor
  • Trade Count: (+1)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 5986
  • Last login:December 19, 2015, 02:28:15 am
Re: GORF Aliens Missing on first screen! Whaaaaaa?
« Reply #5 on: July 18, 2015, 05:51:12 pm »
I don't have working experience with this machine and I don't recall all of the details about it but if  Google search doesn't turn up someone with similar problems I would look at voltage levels going into the board. Look for burned, heat damaged or corroded contacts, traces and components like resistors and blown or bulging caps.

Check for hot components that shouldn't be that hot like RAM or ROM ICs. This is usually the first thing I look at after reseati g the ICs if strange behavior occurs over time. Like if it works for an hour then goes apeshit.

IIRC Gorfs uses several RAM chips but I can't recall the configuration. It's likely if one RAM IC is dead it causes weird sprites and stuff.

monkplayer

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 16
  • Last login:July 07, 2017, 07:32:31 pm
Re: GORF Aliens Missing on first screen! Whaaaaaa?
« Reply #6 on: July 18, 2015, 06:07:58 pm »
This sounds like great advice, because when I reseated all the chips I had accidentally put the last one in backwards. I noticed it after only having the game on for 30 seconds, because I touched the chip accidentally and noticed it was very warm.

I reseated the chip and everything is back to the original problem described above.
« Last Edit: July 19, 2015, 08:24:54 pm by monkplayer »
Taa Taa Taa, I eat Coins!

lilshawn

  • Trade Count: (+3)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 6236
  • Last login:Yesterday at 07:41:36 pm
  • I break stuff...then fix it...sometimes
Re: GORF Aliens Missing on first screen! Whaaaaaa?
« Reply #7 on: July 19, 2015, 03:25:13 pm »
yep, that chips done for. you are going to have to purchase a new one and have it reprogrammed with the relevant data.

you should be able to find gorf someplace on the internet as a set of MAME roms and find they are named the "U" IC positions. you'll burn the relevant chip (Uxx) data to that chip.

Slippyblade

  • Trade Count: (+2)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 3156
  • Last login:April 26, 2019, 02:25:09 pm
  • And to the death god we say, "Not today!"
Re: GORF Aliens Missing on first screen! Whaaaaaa?
« Reply #8 on: July 19, 2015, 04:14:20 pm »
Send a PM to Yotsuya, he's been having good luck burning new EPROMS for original boards.  He'll probably have you order the chip and then charge ya a couple bucks for the service, but at least you'll have a good board again.

SavannahLion

  • Wiki Contributor
  • Trade Count: (+1)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 5986
  • Last login:December 19, 2015, 02:28:15 am
Re: GORF Aliens Missing on first screen! Whaaaaaa?
« Reply #9 on: July 19, 2015, 06:13:46 pm »
Pro tip.

Steal your wife's nail polish. Preferably white or some other light color and put a single small dot on the IC next to the first leg if the IC lacks a notch and a single dot next to the same pin on the PCB. Always do leg 1 for consistency!

This is useful for IC's that use a small depression for the first leg or if the markings on the board isn't obvious. Don't use those metallic markers but the white "chalk" markers might work. I never tried them.

If you have no female to steal from, pretend you're gay, married or grow balls and go to the store and buy one. Avoid the el cheap ---steaming pile of meadow muffin--- .99 cent specials. These tend to smell like Elmors glue and are worthless. They gotta smell like they'll get you sky high.

Note: you can probably huff them if you desire but that's your perogative and not something I would advise anyone.

yotsuya

  • Trade Count: (+21)
  • Full Member
  • ***
  • Online Online
  • Posts: 18747
  • Last login:Today at 02:57:57 pm
  • 2014 UCA Winner, 2014, 2015, 2016 ZapCon Winner
    • forum.arcadecontrols.com/index.php/topic,137636.msg1420628.html
Re: GORF Aliens Missing on first screen! Whaaaaaa?
« Reply #10 on: July 19, 2015, 07:30:11 pm »
I'd be happy to help with the EPROMS if you need 'em. Just PM me.
***Build what you dig, bro. Build what you dig.***