Main Restorations Software Audio/Jukebox/MP3 Everything Else Buy/Sell/Trade
Project Announcements Monitor/Video GroovyMAME Merit/JVL Touchscreen Meet Up Retail Vendors
Driving & Racing Woodworking Software Support Forums Consoles Project Arcade Reviews
Automated Projects Artwork Frontend Support Forums Pinball Forum Discussion Old Boards
Raspberry Pi & Dev Board controls.dat Linux Miscellaneous Arcade Wiki Discussion Old Archives
Lightguns Arcade1Up --- Bug Reports --- Site News

Unread posts | New Replies | Recent posts | Rules | Chatroom | Wiki | File Repository | RSS | Submit news

  

Author Topic: UltraStik 360 randomly "disappears" on Lubuntu  (Read 1262 times)

0 Members and 1 Guest are viewing this topic.

digitalhobbit

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 22
  • Last login:April 13, 2016, 02:59:15 am
  • I want to build my own arcade controls!
UltraStik 360 randomly "disappears" on Lubuntu
« on: February 03, 2013, 02:53:27 am »
I'm using two UltraStik 360 joysticks on Lubuntu with Wahcade (Mahcade) and Mame. Everything generally works fine, but every once in a while, one of my 360s randomly "disappears". It simply stops working (usually in the middle of a game). After that, the joystick works neither in Mame nor Wahcade. Even jstest no longer reports any input from that joystick. The green LED underneath the 360 is still lit. Unplugging and replugging the joystick has no effect, but a reboot fixes the problem (for a while).

I'm not sure whether this is a software (Linux specific?) or hardware issue, but the fact that this happens with both joysticks seems to suggest the former. Any ideas what could be causing this, or how I could further debug the issue?

Thanks,

-Mirko

sairuk

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 26
  • Last login:August 25, 2019, 02:24:17 am
    • mameau
Re: UltraStik 360 randomly "disappears" on Lubuntu
« Reply #1 on: February 08, 2013, 12:23:41 pm »
You may consider booting a live cd and testing the controllers under that environment to see if the problem remains

There is an open bug for wahcade for controller dropouts but I believe some/most users still have joy control in emulators without a reboot. May not be related.

mameau - My random bits | Wah!Ki - A Wah!Cade wiki | Mah!Cade - Experimental Wah!cade Branch | ListGen | Lazarus

digitalhobbit

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 22
  • Last login:April 13, 2016, 02:59:15 am
  • I want to build my own arcade controls!
Re: UltraStik 360 randomly "disappears" on Lubuntu
« Reply #2 on: February 08, 2013, 12:53:21 pm »
Thanks Sairuk. I may give it a shot with a live CD. The tricky thing is that the problem is not very deterministic, with no specific steps to reproduce. Sometimes I can play for an hour or longer without the joystick disappearing.

The Wahcade bug does sound different (since the joystick doesn't even work with jstest or mame any more, once this happens), but I'll try to dig this open bug up anyway, and perhaps see if the problem ever happens when I run mame directly, bypassing wahcade.

-Mirko