Main Restorations Software Audio/Jukebox/MP3 Everything Else Buy/Sell/Trade
Project Announcements Monitor/Video GroovyMAME Merit/JVL Touchscreen Meet Up Retail Vendors
Driving & Racing Woodworking Software Support Forums Consoles Project Arcade Reviews
Automated Projects Artwork Frontend Support Forums Pinball Forum Discussion Old Boards
Raspberry Pi & Dev Board controls.dat Linux Miscellaneous Arcade Wiki Discussion Old Archives
Lightguns Arcade1Up --- Bug Reports --- Site News

Unread posts | New Replies | Recent posts | Rules | Chatroom | Wiki | File Repository | RSS | Submit news

  

Author Topic: Judge Dredd - Problems with droptarget "D"  (Read 1674 times)

0 Members and 1 Guest are viewing this topic.

Chiraz

  • Trade Count: (0)
  • Newbie
  • *
  • Offline Offline
  • Posts: 1
  • Last login:March 15, 2012, 11:38:43 am
Judge Dredd - Problems with droptarget "D"
« on: March 14, 2012, 09:12:53 am »
Hello everyone, newbie from Sweden here!  :)

I have a very irritating problem with my Judge Dredd pinball I bought about a month ago. At first everything worked fine, but then a strange thing happened with
the droptarget "D". It went down as it should, but when I get to modes such as Safecracker or multiball where the mission is to shoot the ball in the middle of
the droptarget place it seems jammed and keeps klicking like it doesn't register it is down.

I've tried opening it up, cleaning the optos after some advice and at first it works but after a few games the problem occurs again. I've also had a friend soldering
the optos apart and assemble them together again without any positive results. After that I noticed that the opto card can be adjusted left/right/up/down even
when the lock-bricks are set (a total of 4 bricks). Had the same result here - sometimes it works and fails shortly efter, and sometimes the problem is there directly.
I thought of buying a new opto card since I've heard that the old design was crap and problems like these often happen with the old board. What do you guys think?


The other droptargets seem to be working better, but sometimes the "G" and the "E" get stuck and you have to manually push them up (kinda irritating too). I don't
see this as a major problem though but I'd like some advice here too on what to do to fix it.

lilshawn

  • Trade Count: (+3)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 6276
  • Last login:Today at 02:09:00 am
  • I break stuff...then fix it...sometimes
Re: Judge Dredd - Problems with droptarget "D"
« Reply #1 on: March 21, 2012, 03:20:26 pm »
hows it registering in the switch test?

when it's up does it randomly come on (or when down randomly turn off) it might be a bad opto.

switch an opto from another target to that one and see if it's still there... if it hasn't moved to the other switch, then there is an issue with the decoder chip on the return side or an issue with the drive.

Dawgz Rule

  • Trade Count: (+1)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 716
  • Last login:Today at 05:53:55 am
  • The more people I meet, the more I like my dogs
Re: Judge Dredd - Problems with droptarget "D"
« Reply #2 on: March 21, 2012, 04:50:26 pm »
Check the plug connections before replacing the opto board.  I ran into an issue on my TZ where an opto worked and then didn't work.  I replaced the opto and it seemed good but than failed again.  Turned out to be a connector issue.  Problem went away after crimping on a new connector.