Main Restorations Software Audio/Jukebox/MP3 Everything Else Buy/Sell/Trade
Project Announcements Monitor/Video GroovyMAME Merit/JVL Touchscreen Meet Up Retail Vendors
Driving & Racing Woodworking Software Support Forums Consoles Project Arcade Reviews
Automated Projects Artwork Frontend Support Forums Pinball Forum Discussion Old Boards
Raspberry Pi & Dev Board controls.dat Linux Miscellaneous Arcade Wiki Discussion Old Archives
Lightguns Arcade1Up --- Bug Reports --- Site News

Unread posts | New Replies | Recent posts | Rules | Chatroom | Wiki | File Repository | RSS | Submit news

  

Author Topic: Adding hardware id in CRT_Emudriver  (Read 1473 times)

0 Members and 1 Guest are viewing this topic.

galsia

  • Trade Count: (0)
  • Jr. Member
  • **
  • Offline Offline
  • Posts: 3
  • Last login:June 12, 2012, 04:26:35 pm
Adding hardware id in CRT_Emudriver
« on: January 27, 2012, 04:11:59 am »
Hi,

I'm trying to install CRT_Emudriver 9.3 1.2a on Windows XP x64. My card is a VTX3D Radeon HD 4850, it is not in the driver list so I tried adding its hardware id by myself.

The card hardware id is PCI\VEN_1002&DEV_944A&SUBSYS_30001787&REV_00

In XP6A_INF\CA_76826.inf I added:
Code: [Select]
"ATI Radeon HD 4800 Series" = ati2mtag_M9x8, PCI\VEN_1002&DEV_944A
in CA_76826.INI and INSTALL.INI:
Code: [Select]
,0x944A:0x30001787at the end of the R6_43=DriverPath_R6_43 line.

After that I was able to run the setup. Rebooted my computer, device manager is reporting that driver v8.591.0 is installed, but Arcade_OSD says "CRT_Emudriver not found" and VMMaker can't find compatible device.

Did I miss something or did I add my hardware id in a wrong way?
« Last Edit: January 27, 2012, 04:13:40 am by galsia »

Calamity

  • Moderator
  • Trade Count: (0)
  • Full Member
  • *****
  • Offline Offline
  • Posts: 6626
  • Last login:Yesterday at 04:37:37 pm
Re: Adding hardware id in CRT_Emudriver
« Reply #1 on: January 27, 2012, 04:48:45 am »
Quote
In XP6A_INF\CA_76826.inf I added:
Code: [Select]
"ATI Radeon HD 4800 Series" = ati2mtag_M9x8, PCI\VEN_1002&DEV_944A

The label ati2mtag_M9x does not exist in the .inf, that's probably why driver's installation is not complete. You have to use on of the existing chipset's labels:

"ATI Radeon HD 4850 VTX3D" = ati2mtag_R7X, PCI\VEN_1002&DEV_944A

Notice that I added the VTX3D to the name so there are not duplicated names in the .inf.

Quote
in CA_76826.INI and INSTALL.INI:
Code: [Select]
,0x944A:0x30001787at the end of the R6_43=DriverPath_R6_43 line.

I always add the new ID to the end of the last label. Here it's "DriverPath_R6_78". It's more convenient as you know that all the additions are at the end of the file.
You don't need to add the subsystem number, only the main device is required and thus it makes the patch more generic.

R6_78=DriverPath_R6_78,0x4152:0x001F18D4,0x7166:0x3001148C,0x4173:0x7C21174B,0x5E6B,0x9443,0x71C3,0x3E50:0x001E1043,0x5E6B:0x0651174B,0x9460,0x9495,0x944A

Apart from CA_76826.inf, CA_76826.INF, and INSTALL.INI, you also need to edit Driver.dat:

Req_ASIC=7142,7146,7162,.........,5D77,9460,9495,944A

Try reinstalling the driver after that.

« Last Edit: January 27, 2012, 04:51:17 am by Calamity »
Important note: posts reporting GM issues without a log will be IGNORED.
Steps to create a log:
 - From command line, run: groovymame.exe -v romname >romname.txt
 - Attach resulting romname.txt file to your post, instead or pasting it.

CRT Emudriver, VMMaker & Arcade OSD downloads, documentation and discussion:  Eiusdemmodi

galsia

  • Trade Count: (0)
  • Jr. Member
  • **
  • Offline Offline
  • Posts: 3
  • Last login:June 12, 2012, 04:26:35 pm
Re: Adding hardware id in CRT_Emudriver
« Reply #2 on: January 27, 2012, 09:51:10 am »
Thanks a lot for your help, I was able to install your drivers successfully.

I have another question though: I was planning to use the VGA output of my video card, is it possible or should I use the DVI output?

Calamity

  • Moderator
  • Trade Count: (0)
  • Full Member
  • *****
  • Offline Offline
  • Posts: 6626
  • Last login:Yesterday at 04:37:37 pm
Re: Adding hardware id in CRT_Emudriver
« Reply #3 on: January 27, 2012, 11:41:33 am »
You need to use the DVI output with that card.
Important note: posts reporting GM issues without a log will be IGNORED.
Steps to create a log:
 - From command line, run: groovymame.exe -v romname >romname.txt
 - Attach resulting romname.txt file to your post, instead or pasting it.

CRT Emudriver, VMMaker & Arcade OSD downloads, documentation and discussion:  Eiusdemmodi

galsia

  • Trade Count: (0)
  • Jr. Member
  • **
  • Offline Offline
  • Posts: 3
  • Last login:June 12, 2012, 04:26:35 pm
Re: Adding hardware id in CRT_Emudriver
« Reply #4 on: January 28, 2012, 04:41:41 am »
Thanks again, I'll try the DVI output then. Would it be possible to use the HDMI output too?