Main Restorations Software Audio/Jukebox/MP3 Everything Else Buy/Sell/Trade
Project Announcements Monitor/Video GroovyMAME Merit/JVL Touchscreen Meet Up Retail Vendors
Driving & Racing Woodworking Software Support Forums Consoles Project Arcade Reviews
Automated Projects Artwork Frontend Support Forums Pinball Forum Discussion Old Boards
Raspberry Pi & Dev Board controls.dat Linux Miscellaneous Arcade Wiki Discussion Old Archives
Lightguns Arcade1Up --- Bug Reports --- Site News

Unread posts | New Replies | Recent posts | Rules | Chatroom | Wiki | File Repository | RSS | Submit news

  

Author Topic: SIGILL  (Read 1900 times)

0 Members and 1 Guest are viewing this topic.

twist

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 46
  • Last login:December 06, 2002, 04:03:20 pm
SIGILL
« on: July 01, 2002, 04:42:18 pm »
I keep getting the error:

Exiting due to signal SIGILL.
Invalid Opcode at....blah blah
Call frame traceback EIPs:
0x00000000


in VAntAGE whenever I try to run a game. What's wrong?! I need help ASAP.
« Last Edit: December 31, 1969, 07:00:00 pm by 1026619200 »

JMDickson

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 98
  • Last login:October 21, 2011, 11:22:48 pm
Re: SIGILL
« Reply #1 on: July 01, 2002, 05:27:31 pm »
That's a GCC error message.  There is a bug somewhere in the code that attepts to execute an invalid instruction.  Looks like a jump to a null pointer.  Possibly an unmapped emluated opcode, or a stack corruption.  If you give the authors the ....blah blah part, they may be able to trace the cause down in the map files.
« Last Edit: December 31, 1969, 07:00:00 pm by 1026619200 »

twist

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 46
  • Last login:December 06, 2002, 04:03:20 pm
Re: SIGILL
« Reply #2 on: July 01, 2002, 05:50:18 pm »
Yes, but it seems no one else gets this problem!
« Last Edit: December 31, 1969, 07:00:00 pm by 1026619200 »

Chazz

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 234
  • Last login:May 28, 2016, 01:49:19 pm
Re: SIGILL
« Reply #3 on: July 02, 2002, 01:40:38 pm »
I'm getting this problem too.  I can't figure out what the problem is.

« Last Edit: December 31, 1969, 07:00:00 pm by 1026619200 »