Main Restorations Software Audio/Jukebox/MP3 Everything Else Buy/Sell/Trade
Project Announcements Monitor/Video GroovyMAME Merit/JVL Touchscreen Meet Up Retail Vendors
Driving & Racing Woodworking Software Support Forums Consoles Project Arcade Reviews
Automated Projects Artwork Frontend Support Forums Pinball Forum Discussion Old Boards
Raspberry Pi & Dev Board controls.dat Linux Miscellaneous Arcade Wiki Discussion Old Archives
Lightguns Arcade1Up Try the site in https mode Site News

Unread posts | New Replies | Recent posts | Rules | Chatroom | Wiki | File Repository | RSS | Submit news

  

Author Topic: MAME not opening after CRT EMU Driver install  (Read 3535 times)

0 Members and 1 Guest are viewing this topic.

KAG

  • Trade Count: (0)
  • Jr. Member
  • **
  • Offline Offline
  • Posts: 3
  • Last login:June 27, 2024, 07:54:47 pm
  • I want to build my own arcade controls!
MAME not opening after CRT EMU Driver install
« on: February 04, 2024, 04:34:56 pm »
I'll double click the .exe, it will pop up in the task bar for a split second and disappear. No errors or anything. I've tried running from the command prompt, running as admin. I can't get it to load.

Also, where do I find older versions of GroovyMAME?

Zebidee

  • Trade Count: (+9)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 3293
  • Last login:Today at 04:14:28 am
Re: MAME not opening after CRT EMU Driver install
« Reply #1 on: February 04, 2024, 07:18:11 pm »
Run groovymame from command line and generate a log file. Post it here.

Instructions for doing this this are in the sig line for every one of Calamity's posts.
Check out my completed projects!


KAG

  • Trade Count: (0)
  • Jr. Member
  • **
  • Offline Offline
  • Posts: 3
  • Last login:June 27, 2024, 07:54:47 pm
  • I want to build my own arcade controls!
Re: MAME not opening after CRT EMU Driver install
« Reply #2 on: February 05, 2024, 05:37:07 pm »
Run groovymame from command line and generate a log file. Post it here.

Instructions for doing this this are in the sig line for every one of Calamity's posts.

I've got it figured out, not exactly sure what the issue was but here's my suspicion.

When installing the CRT Emu driver for my HD 5450 I found the computer always crashed. BSOD and reboot. However I'd find it appeared to be installed. So I'd move on. MAME would always open before reaching the VM Maker portion of the install. After that, nothing. I reset my computer twice trying to solve this. Tried tons of other random stuff. Nothing would fix it. Today I started to look farther into the driver install breaking my PC and grabbed a nearly identical PC I always use for my emulation cabinets (LCD based). It was purchased used but had been offline longer and had to have a lower Windows 10 OS version installed.

I installed the GPU, went through the steps and it worked! My assumption is a newer Windows 10 version or an update may have caused a problem installing that CRT Emu driver? I'm unsure if there are different versions of the drive as a friend sent me a thumb drive with all of the files I'd need on it. Either way ,its working now.

Just thought I'd come back and update this just in case anyone else is struggling with a similar issue.

Zebidee

  • Trade Count: (+9)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 3293
  • Last login:Today at 04:14:28 am
Re: MAME not opening after CRT EMU Driver install
« Reply #3 on: February 05, 2024, 08:45:19 pm »
Yeah. Well. Maybe. Who knows? It is not really a solution.

Your log file would likely have the right info to solve the mystery.
Check out my completed projects!


KAG

  • Trade Count: (0)
  • Jr. Member
  • **
  • Offline Offline
  • Posts: 3
  • Last login:June 27, 2024, 07:54:47 pm
  • I want to build my own arcade controls!
Re: MAME not opening after CRT EMU Driver install
« Reply #4 on: February 06, 2024, 12:50:02 am »
Yeah. Well. Maybe. Who knows? It is not really a solution.

Your log file would likely have the right info to solve the mystery.

I tried creating the log but just got an error creating the txt file.

Zebidee

  • Trade Count: (+9)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 3293
  • Last login:Today at 04:14:28 am
Re: MAME not opening after CRT EMU Driver install
« Reply #5 on: February 06, 2024, 01:13:56 am »
Then we can only assume you're doing it wrong, or the groovymame.exe file is corrupt, or is the wrong version for your OS.

EDIT: Make sure that you have set permissions to be able to run GM. Right click on the exe, under "Compatability" check the box for "Run this program as Administrator", and under security ensure that permission are set for all users to be able to at least read and execute the program.

Also, when you open a command window, make sure to "Run as administrator".

Hope this helps.
« Last Edit: February 06, 2024, 01:31:08 am by Zebidee »
Check out my completed projects!


Marcoqwerty

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 129
  • Last login:July 04, 2024, 04:25:01 pm
Re: MAME not opening after CRT EMU Driver install
« Reply #6 on: February 10, 2024, 12:10:15 pm »
Hello!

Im sorry to jump on the 3D but i have the same issue, new GM 261 and it wont load.

OS : Windows 7
CRT : 15Kz

PS: its not my first mame but i decidet to upload it from the version 199
« Last Edit: February 10, 2024, 12:27:41 pm by Marcoqwerty »

Calamity

  • Moderator
  • Trade Count: (0)
  • Full Member
  • *****
  • Offline Offline
  • Posts: 7424
  • Last login:Yesterday at 04:10:36 pm
  • Quote me with care
Re: MAME not opening after CRT EMU Driver install
« Reply #7 on: February 10, 2024, 01:02:20 pm »
You need the driver labeled "CRT Emudriver & CRT Tools 2.0 beta 15 (Crimson 16.2.1 for GCN* cards) for Windows 7/8/10 64-bits", second download link here: http://geedorah.com/eiusdemmodi/forum/viewtopic.php?id=295

You're likely using the one from the first link. Older versions of GM (before SR 2.0) could use it, newer versions require the other (newer) one.
Important note: posts reporting GM issues without a log will be IGNORED.
Steps to create a log:
 - From command line, run: groovymame.exe -v romname >romname.txt
 - Attach resulting romname.txt file to your post, instead of pasting it.

CRT Emudriver, VMMaker & Arcade OSD downloads, documentation and discussion:  Eiusdemmodi

Marcoqwerty

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 129
  • Last login:July 04, 2024, 04:25:01 pm
Re: MAME not opening after CRT EMU Driver install
« Reply #8 on: February 10, 2024, 01:46:37 pm »
Thank you!

I downloaded and install the new modeline but nothing changed. I was using correctly the Mame version 178 and 193 before.

I Attach the new files but looks similar to previous.

Calamity

  • Moderator
  • Trade Count: (0)
  • Full Member
  • *****
  • Offline Offline
  • Posts: 7424
  • Last login:Yesterday at 04:10:36 pm
  • Quote me with care
Re: MAME not opening after CRT EMU Driver install
« Reply #9 on: February 10, 2024, 02:50:36 pm »
It looks like you're still using the previous driver.
Important note: posts reporting GM issues without a log will be IGNORED.
Steps to create a log:
 - From command line, run: groovymame.exe -v romname >romname.txt
 - Attach resulting romname.txt file to your post, instead of pasting it.

CRT Emudriver, VMMaker & Arcade OSD downloads, documentation and discussion:  Eiusdemmodi

Marcoqwerty

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 129
  • Last login:July 04, 2024, 04:25:01 pm
Re: MAME not opening after CRT EMU Driver install
« Reply #10 on: February 10, 2024, 03:00:24 pm »
Damn, looks like i have no drivers installed.

This is my Graphic Card : XFX ATI RADEON HD 5450 1GB PCI-E VIDEO CARD HDMI VGA DVI 140919KLA D6-4 Genuine

https://thumbs.worthpoint.com/zoom/images1/1/0217/17/arcade-vga-5000-ultimarc-pcie-card_1_f23ef5a664252ad6de716457e56d3c4a.jpg
« Last Edit: February 10, 2024, 03:32:14 pm by Marcoqwerty »

Marcoqwerty

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 129
  • Last login:July 04, 2024, 04:25:01 pm
Re: MAME not opening after CRT EMU Driver install
« Reply #11 on: February 10, 2024, 03:45:21 pm »
Quote from: Calamity
You need the driver labeled "CRT Emudriver & CRT Tools 2.0 beta 15 (Crimson 16.2.1 for GCN* cards) for Windows 7/8/10 64-bits", second download link here: http://geedorah.com/eiusdemmodi/forum/viewtopic.php?id=295

Ok basically i cannot install the drivers from this link because my Graphic Card is not supported.
« Last Edit: February 10, 2024, 03:53:49 pm by Marcoqwerty »

Calamity

  • Moderator
  • Trade Count: (0)
  • Full Member
  • *****
  • Offline Offline
  • Posts: 7424
  • Last login:Yesterday at 04:10:36 pm
  • Quote me with care
Re: MAME not opening after CRT EMU Driver install
« Reply #12 on: February 10, 2024, 03:59:35 pm »
Are you sure you downloaded the correct package for your card?
Important note: posts reporting GM issues without a log will be IGNORED.
Steps to create a log:
 - From command line, run: groovymame.exe -v romname >romname.txt
 - Attach resulting romname.txt file to your post, instead of pasting it.

CRT Emudriver, VMMaker & Arcade OSD downloads, documentation and discussion:  Eiusdemmodi

Marcoqwerty

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 129
  • Last login:July 04, 2024, 04:25:01 pm
Re: MAME not opening after CRT EMU Driver install
« Reply #13 on: February 10, 2024, 04:07:38 pm »
Are you sure you downloaded the correct package for your card?

You tell me to download this one : CRT Emudriver & CRT Tools 2.0 beta 15 (Crimson 16.2.1 for GCN* cards) for Windows 7/8/10 64-bits

But this one dont have my card on the list and im not able to install the driver

This one i downloaded before :  Download CRT Emudriver & CRT Tools 2.0 beta 15 (Crimson 16.2.1 non-GCN* cards) for Windows 7/8/10 64-bits

That support my card but you tell me that create the issue with new version of GM

Is it correct or i miss something? (thank you for all the help  :) )
« Last Edit: February 10, 2024, 04:11:11 pm by Marcoqwerty »

Calamity

  • Moderator
  • Trade Count: (0)
  • Full Member
  • *****
  • Offline Offline
  • Posts: 7424
  • Last login:Yesterday at 04:10:36 pm
  • Quote me with care
Re: MAME not opening after CRT EMU Driver install
« Reply #14 on: February 13, 2024, 04:13:11 pm »
It's the other link, obviously, non-GCN, sorry, I copied the wrong line.
Important note: posts reporting GM issues without a log will be IGNORED.
Steps to create a log:
 - From command line, run: groovymame.exe -v romname >romname.txt
 - Attach resulting romname.txt file to your post, instead of pasting it.

CRT Emudriver, VMMaker & Arcade OSD downloads, documentation and discussion:  Eiusdemmodi

Marcoqwerty

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 129
  • Last login:July 04, 2024, 04:25:01 pm
Re: MAME not opening after CRT EMU Driver install
« Reply #15 on: February 13, 2024, 04:22:11 pm »
Sorry if i ask again, is this one?

Download CRT Emudriver & CRT Tools 2.0 beta 15 (Adrenalin 18.5.1 for GCN* cards) for Windows 7/8 64-bits

I just avoid to download it because there is written nothing about Graphic Card and compatibility.

Thank you

Calamity

  • Moderator
  • Trade Count: (0)
  • Full Member
  • *****
  • Offline Offline
  • Posts: 7424
  • Last login:Yesterday at 04:10:36 pm
  • Quote me with care
Important note: posts reporting GM issues without a log will be IGNORED.
Steps to create a log:
 - From command line, run: groovymame.exe -v romname >romname.txt
 - Attach resulting romname.txt file to your post, instead of pasting it.

CRT Emudriver, VMMaker & Arcade OSD downloads, documentation and discussion:  Eiusdemmodi

Marcoqwerty

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 129
  • Last login:July 04, 2024, 04:25:01 pm
Re: MAME not opening after CRT EMU Driver install
« Reply #17 on: February 13, 2024, 04:35:18 pm »
Sorry probably you miss one of my message

This one i downloaded before :  Download CRT Emudriver & CRT Tools 2.0 beta 15 (Crimson 16.2.1 non-GCN* cards) for Windows 7/8/10 64-bits

That support my card but you tell me that create the issue with new version of GM

Is it correct or i miss something? (thank you for all the help  :) )

I already used this one and i got stuck with this issue, then i unistalled the driver and re-download this pack and re-install again. Nothing changed.

Calamity

  • Moderator
  • Trade Count: (0)
  • Full Member
  • *****
  • Offline Offline
  • Posts: 7424
  • Last login:Yesterday at 04:10:36 pm
  • Quote me with care
Re: MAME not opening after CRT EMU Driver install
« Reply #18 on: February 13, 2024, 04:38:50 pm »
Install the driver in the link I just posted. Then install the modelines. Run GroovyMAME and get a log.
Important note: posts reporting GM issues without a log will be IGNORED.
Steps to create a log:
 - From command line, run: groovymame.exe -v romname >romname.txt
 - Attach resulting romname.txt file to your post, instead of pasting it.

CRT Emudriver, VMMaker & Arcade OSD downloads, documentation and discussion:  Eiusdemmodi

Marcoqwerty

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 129
  • Last login:July 04, 2024, 04:25:01 pm
Re: MAME not opening after CRT EMU Driver install
« Reply #19 on: February 16, 2024, 03:01:12 pm »
Nothing, the same  :badmood:  :banghead:

I attach some screenshot of my settings, if could help.

Thank you for any kind of help! :notworthy:

Marcoqwerty

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 129
  • Last login:July 04, 2024, 04:25:01 pm
Re: MAME not opening after CRT EMU Driver install
« Reply #20 on: February 22, 2024, 04:22:23 pm »
Ok i will continue my odissey about installing the drivers.  :badmood:

This guy had been the same issue as me, with the same log file, all is described on this post (also the log file is identical)

https://forum.arcadecontrols.com/index.php/topic,165352.msg1743624.html#msg1743624

As he wrote there and as Calamity said, i dont have the correct driver installed, the problem is that i follow the tips of this guy and used DDU from safe mode.

- I unistalled the driver in safe mode with DDU (unistall without reboot)
- Install the correct driver that Calamity posted here
- Reboot and genereate and install modelines
- Try again GM and i got the same identical log and error

So i need some help to understand how to unistall correctly the driver, because looks like im installing again and again the old one.

Could i see somewhere if i have installed correctly the 16.2 driver? usually i check the SETTINGS > VIDEO CARD green text , but i continue to see (as showed in the screenshot) 15.8

Thank you!  :notworthy:



Calamity

  • Moderator
  • Trade Count: (0)
  • Full Member
  • *****
  • Offline Offline
  • Posts: 7424
  • Last login:Yesterday at 04:10:36 pm
  • Quote me with care
Re: MAME not opening after CRT EMU Driver install
« Reply #21 on: February 23, 2024, 05:08:25 am »
That is the correct driver, by looking at your VMMaker picture, everything is ok.

So now please run GM and get a log as I asked you the other day.

PD: Anyway, if you're getting the "ADL initialization error", it's likely because the dll installed in your system is the one from the old driver. Something must have gone wrong and your driver installation has got corrupt.

I recommend that you remove all AMD drivers from the device manager, by selecting the video card->properties, driver, uninstall device, and clicking the check to remove its software. Do this until it's recognized a basic vga device. Then reinstall CRT Emudriver again.
« Last Edit: February 23, 2024, 05:43:29 am by Calamity »
Important note: posts reporting GM issues without a log will be IGNORED.
Steps to create a log:
 - From command line, run: groovymame.exe -v romname >romname.txt
 - Attach resulting romname.txt file to your post, instead of pasting it.

CRT Emudriver, VMMaker & Arcade OSD downloads, documentation and discussion:  Eiusdemmodi

Marcoqwerty

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 129
  • Last login:July 04, 2024, 04:25:01 pm
Re: MAME not opening after CRT EMU Driver install
« Reply #22 on: February 23, 2024, 12:54:43 pm »
Nothing

- moved to SAFE MODE and unistall driver and graphic card from system menu
- run the AMD unistall tool
- run also the other DDU tool
- reboot
- detected the card as GENERIC VGA
- install the driver and modelines

When i create the log i get the error showed on the screenshot.

Same error and same identical log files, im lost, probably i hat to format the HD.

PS: GM version pre 2.0 work, im able to open the GUI but i got a dll popup error

 :timebomb:


Marcoqwerty

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 129
  • Last login:July 04, 2024, 04:25:01 pm
Re: MAME not opening after CRT EMU Driver install
« Reply #23 on: February 24, 2024, 09:49:19 pm »
A small update if someone is interested to follow my mess  :blah:

I decided to format all, to made a pure and clean installation (obliviously after a one to one copy of the drive).

Idk (basically i dont remember from my last "long time ago" first video card installation) if its correct that im able to see the video signal immediately after the OS reboot without any trouble (just a bit out of the top and bottom border); anyway i continue to install the Emudriver and finally i lost the signal;plug the HDMI and enabled EDID emulation to finish the modelines setup.

As look like i did nothing, still the GM wont load and made the same behavior of my last tests.

Now i think there is some problem with my Video card, that works but dont care too much about which drivers i will plan to install.

Im totally out of idea  :dunno

PS: i discover that i have installed the custom bios with ATOM on my GPU, probably this affect the installation of the new driver.
« Last Edit: February 26, 2024, 05:32:35 am by Marcoqwerty »

Calamity

  • Moderator
  • Trade Count: (0)
  • Full Member
  • *****
  • Offline Offline
  • Posts: 7424
  • Last login:Yesterday at 04:10:36 pm
  • Quote me with care
Re: MAME not opening after CRT EMU Driver install
« Reply #24 on: February 26, 2024, 07:19:10 am »
My Marcoqwerty,

This is my third and last attempt to ask you for a log.

(the picture with the error you posted above has nothing to do with the first error you reported, this is the reason I'm asking for a log)
Important note: posts reporting GM issues without a log will be IGNORED.
Steps to create a log:
 - From command line, run: groovymame.exe -v romname >romname.txt
 - Attach resulting romname.txt file to your post, instead of pasting it.

CRT Emudriver, VMMaker & Arcade OSD downloads, documentation and discussion:  Eiusdemmodi

Marcoqwerty

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 129
  • Last login:July 04, 2024, 04:25:01 pm
Re: MAME not opening after CRT EMU Driver install
« Reply #25 on: February 26, 2024, 07:28:27 am »

This is my third and last attempt to ask you for a log.


Was in the same post, before the image.

Calamity

  • Moderator
  • Trade Count: (0)
  • Full Member
  • *****
  • Offline Offline
  • Posts: 7424
  • Last login:Yesterday at 04:10:36 pm
  • Quote me with care
Re: MAME not opening after CRT EMU Driver install
« Reply #26 on: February 26, 2024, 07:30:20 am »
Was in the same post, before the image.

Oh silly me, sorry I completely missed it.
Important note: posts reporting GM issues without a log will be IGNORED.
Steps to create a log:
 - From command line, run: groovymame.exe -v romname >romname.txt
 - Attach resulting romname.txt file to your post, instead of pasting it.

CRT Emudriver, VMMaker & Arcade OSD downloads, documentation and discussion:  Eiusdemmodi

Calamity

  • Moderator
  • Trade Count: (0)
  • Full Member
  • *****
  • Offline Offline
  • Posts: 7424
  • Last login:Yesterday at 04:10:36 pm
  • Quote me with care
Re: MAME not opening after CRT EMU Driver install
« Reply #27 on: February 26, 2024, 07:35:41 am »
The ADL initialization error is strange, basically it's saying that it can't find a dll that is installed along with the drivers, I don't understand why it's happening.

The crash dump you posted comes from a different place, it's caused by LUA (the plugin interface in MAME). Open plugin.ini, and set everything in there to 0, then try again.
Important note: posts reporting GM issues without a log will be IGNORED.
Steps to create a log:
 - From command line, run: groovymame.exe -v romname >romname.txt
 - Attach resulting romname.txt file to your post, instead of pasting it.

CRT Emudriver, VMMaker & Arcade OSD downloads, documentation and discussion:  Eiusdemmodi

Marcoqwerty

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 129
  • Last login:July 04, 2024, 04:25:01 pm
Re: MAME not opening after CRT EMU Driver install
« Reply #28 on: February 26, 2024, 09:06:09 am »
 :notworthy:

Again thank you to waste your time for my issue, i lurked everywhere for a DLL but there is nothing.

At home i have another GPU that is the same but its an ARCADEVGA 5000 but couldnt made a test because its incompatible with your driver (i have to flash the driver with an original 5450 that i didnt find anywhere).

I discover that the GPU that im using now its pathed with ATOM (idk if it made some mess with the new driver).


The crash dump you posted comes from a different place, it's caused by LUA (the plugin interface in MAME). Open plugin.ini, and set everything in there to 0, then try again.


Nothing also if i set 0 to all options.