Main Restorations Software Audio/Jukebox/MP3 Everything Else Buy/Sell/Trade
Project Announcements Monitor/Video GroovyMAME Merit/JVL Touchscreen Meet Up Retail Vendors
Driving & Racing Woodworking Software Support Forums Consoles Project Arcade Reviews
Automated Projects Artwork Frontend Support Forums Pinball Forum Discussion Old Boards
Raspberry Pi & Dev Board controls.dat Linux Miscellaneous Arcade Wiki Discussion Old Archives
Lightguns Arcade1Up --- Bug Reports --- Site News

Unread posts | New Replies | Recent posts | Rules | Chatroom | Wiki | File Repository | RSS | Submit news

  

Author Topic: Defender Stargate - audio out, but no other problems???  (Read 958 times)

0 Members and 1 Guest are viewing this topic.

rcahilltx

  • Trade Count: (0)
  • Jr. Member
  • **
  • Offline Offline
  • Posts: 2
  • Last login:September 22, 2019, 11:09:40 pm
Defender Stargate - audio out, but no other problems???
« on: September 12, 2008, 11:15:30 am »
I have an original Williams Defender Stargate machine.  The sound stopped coming on as of a few days ago.  I checked the speaker wires and given that the machine plays fine with no error msgs...  I am not sure what to check or what to do that might fix it.  Any ideas?

It's amazing how the sound makes the game so much better... my scores are about 1/2 with no sound   :-[

THX in Advance for any help!  rob@rcahill.com and rcahilltx on this site!  Rob

SirPeale

  • Green Mountain Man
  • Global Moderator
  • Trade Count: (+23)
  • Full Member
  • *****
  • Offline Offline
  • Posts: 12951
  • Last login:February 03, 2020, 04:31:27 pm
  • Arcade Repair in New England
    • Arcade Game and Other Coin-Op Projects
Re: Defender Stargate - audio out, but no other problems???
« Reply #1 on: September 12, 2008, 02:50:29 pm »
Press the self test button on the sound board.  Does it make sound?

If it does, your PIA is probably toast.  Replace it.

ChadTower

  • Chief Kicker - Nobody's perfect, including me. Fantastic body.
  • Trade Count: (+12)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 38216
  • Last login:Yesterday at 11:22:40 am
Re: Defender Stargate - audio out, but no other problems???
« Reply #2 on: September 13, 2008, 10:12:18 am »

Did you check the wires with the connectors connected or disconnected?  I've seen a couple games where sound didn't work and it turned out to be a disconnected ground where the connector pins weren't making the type of contact they looked like they were making - especially after moving the game.

RetroACTIVE

  • Trade Count: (+8)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 1429
  • Last login:December 21, 2019, 11:42:05 pm
  • Gramps
Re: Defender Stargate - audio out, but no other problems???
« Reply #3 on: September 13, 2008, 08:33:58 pm »
If self test and connectors aren't the issue, you need to check the output voltage on the 5V regulator of the sound board.  The sound board generates its own 5V supply to power its logic.  So the rest of the game can function just fine.

 :cheers:
« Last Edit: September 13, 2008, 08:36:14 pm by RetroACTIVE »
Happy Gaming!