Main Restorations Software Audio/Jukebox/MP3 Everything Else Buy/Sell/Trade
Project Announcements Monitor/Video GroovyMAME Merit/JVL Touchscreen Meet Up Retail Vendors
Driving & Racing Woodworking Software Support Forums Consoles Project Arcade Reviews
Automated Projects Artwork Frontend Support Forums Pinball Forum Discussion Old Boards
Raspberry Pi & Dev Board controls.dat Linux Miscellaneous Arcade Wiki Discussion Old Archives
Lightguns Arcade1Up --- Bug Reports --- Site News

Unread posts | New Replies | Recent posts | Rules | Chatroom | Wiki | File Repository | RSS | Submit news

  

Author Topic: struggeling with IPAC2! not switching to Multimode.  (Read 436 times)

0 Members and 1 Guest are viewing this topic.

darky1986

  • Trade Count: (0)
  • Jr. Member
  • **
  • Offline Offline
  • Posts: 3
  • Last login:March 01, 2020, 02:57:48 pm
  • I want to build my own arcade controls!
struggeling with IPAC2! not switching to Multimode.
« on: February 09, 2020, 02:04:26 am »
i already spent countless hours on how to configure my ipac2 to work with retroarch and my emulators.
Not a single game works as it should. Am at the point of throwing away my ipac and buying another encoder.

Could someone point me out? I already seen so many people having trouble but most of them are using a raspberry instead of a pc.
keys work for the retroarch menu but when loading a core it gets messed up.
Maby someone can tell me how to map the core keys.

Also switching to multimode doesn't work (or how do i know it works) board isn't switching modes. whats the best mode?
 it seems you have to press and hold strt button 10sec to switch mode and a led flash should show up on the board, but its not.
Also holding button 1-5 for 10 sec doesn't seem to work.

I placed my main pc build in the cab to play the latest fighting games but also retro through retroarch.

Hope to find some answers here.
« Last Edit: February 09, 2020, 02:46:35 pm by darky1986 »

meyer980

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 262
  • Last login:Yesterday at 12:21:34 pm
  • Building fun things for fun
    • sergiostuff.com/2020/04/15/felix-son-arcade-game/
    • Sergio Stuff
Re: struggeling with IPAC2! not switching to Multimode.
« Reply #1 on: February 11, 2020, 10:13:31 am »
Remember, the computer just sees an ipac as a keyboard. That's all it thinks it is really. So, if keys aren't working in certain games/emulators, it's likely a software side problem and not something with the ipac.

I can't speak to all retroarch cores - but MAME, for example in retropie, seems to keep both its keyboard bindings AND the bindings you choose on first setup. That could cause conflict. You can see what controls MAME is trying to use by hitting TAB to open the menu while the game is running. There might be similar options for other cores.

If you're still concerned it's an ipac issue, just open up notepad and start hitting keys. Does what you'd expect to happen, happen?
Good luck!