Main Restorations Software Audio/Jukebox/MP3 Everything Else Buy/Sell/Trade
Project Announcements Monitor/Video GroovyMAME Merit/JVL Touchscreen Meet Up Retail Vendors
Driving & Racing Woodworking Software Support Forums Consoles Project Arcade Reviews
Automated Projects Artwork Frontend Support Forums Pinball Forum Discussion Old Boards
Raspberry Pi & Dev Board controls.dat Linux Miscellaneous Arcade Wiki Discussion Old Archives
Lightguns Arcade1Up --- Bug Reports --- Site News

Unread posts | New Replies | Recent posts | Rules | Chatroom | Wiki | File Repository | RSS | Submit news

  

Author Topic: Static/crackle sound Rowe/AMI R86 Jukebox  (Read 290 times)

0 Members and 1 Guest are viewing this topic.

steveslotty

  • Trade Count: (0)
  • Jr. Member
  • **
  • Offline Offline
  • Posts: 3
  • Last login:October 28, 2019, 03:36:02 am
  • I want to build my own arcade controls!
Static/crackle sound Rowe/AMI R86 Jukebox
« on: October 02, 2019, 07:07:52 pm »
Hi I have 2 problems with a rowe/ami R-86 record jukebox. They both have to do with the sound. I hav3 the 125 watt stereo amp 6-07438-04 and the preamp pcb 6-08552-02 the amp output pcbs i dont know model number the stickers fell off.
Heres what is happening and what ive tried so far to fix it. It has a static kinda crackle sound. I first changed speakers but that didnt work, then i de-oxited all switches and connectors also reflowed solder on all connectors and any other solder that looked bad(i found some bad solder but it didn't fix problem), then i changed all the electro capacitors on preamp and amp pcbs with nichicon kz muse capacitors exept 15uf 50v no kz model had to use a upj series nichicon cap and the large caps on otside of amp i didnt change. That didnt help. I also made sure speakers were wired correctly according to manual.this is where im at on this. I'm thinking now that the crossover caps might be bad or the large caps on outside of amp might be bad?
The other think that is wrong is the balace dial. When i move  dial left side side stays on and right changes volume level. Im assuming that either the dial or the stereo/mono switch is bad.
Ive also reflowed solder on price pcb and button pcb

This is my first jukebox or audio repair. I have 20 some video games that i do all my own repairs on so know

ami-man

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 1075
  • Last login:November 05, 2019, 06:36:11 am
Re: Static/crackle sound Rowe/AMI R86 Jukebox
« Reply #1 on: October 03, 2019, 05:41:43 am »
Hello Steve,

My advice is that you should send your amplifier for testing/repair.
Sadly the work that you have already done will cloud any proffesional repair now and ultimately cost you more for any repair.

If you were in the UK I would work on it for you but not at our standard rate.

Regards
Alan

Alan Hood
ami-man
UK

steveslotty

  • Trade Count: (0)
  • Jr. Member
  • **
  • Offline Offline
  • Posts: 3
  • Last login:October 28, 2019, 03:36:02 am
  • I want to build my own arcade controls!
Re: Static/crackle sound Rowe/AMI R86 Jukebox
« Reply #2 on: October 05, 2019, 12:40:54 am »
Would the crossover having worn out capacitors or coils cause this? Or the speaker output transformers? I didnt mention that i unplugged every plug attached to amp one at a time to see if the problem was before the amp. And the crackle was still there. I suspect its the either the stereo mono switch and or the balance dial. I only have a user manual and not a service manual so i dont have a parts list. I dont know the part numbers of the switch and dial so i cant order them from digikey or mouser. Can anyone give me a parts list for R86 or at least the parts that i need? Also the sizes of the coils and capacitors in the crossover would be good to since its buried in bottom of unit.