Main Restorations Software Audio/Jukebox/MP3 Everything Else Buy/Sell/Trade
Project Announcements Monitor/Video GroovyMAME Merit/JVL Touchscreen Meet Up Retail Vendors
Driving & Racing Woodworking Software Support Forums Consoles Project Arcade Reviews
Automated Projects Artwork Frontend Support Forums Pinball Forum Discussion Old Boards
Raspberry Pi & Dev Board controls.dat Linux Miscellaneous Arcade Wiki Discussion Old Archives
Lightguns Arcade1Up --- Bug Reports --- Site News

Unread posts | New Replies | Recent posts | Rules | Chatroom | Wiki | File Repository | RSS | Submit news

  

Author Topic: Attract mode and windows descktop wrong resolution in monitor Hantarex  (Read 171 times)

0 Members and 1 Guest are viewing this topic.

Ravenux

  • Trade Count: (0)
  • Jr. Member
  • **
  • Offline Offline
  • Posts: 1
  • Last login:August 24, 2019, 10:45:18 am
  • I want to build my own arcade controls!
Hello,
I have a problem with attract mode with flat blue theme.
When I run  AM in my old tft 4:3 monitor works fine,  you can watch the videos and wheel snaps perfect, but then when I run AM in my  arcade monitor  Hantarex 9110 doesn´t look well, the whell snaps and video are too big, something is wrong, I think the resolution is shown in the Hantarex monitor is not correct.
I´m using groovymame in windows 7 in 1024 x 768.
I set windows in 800x600 (It is the lowest resolution it let me use) and i had a distorted image, very similar, but not the same so I supose the problem is that attract mode can not "talk" with the Hantarex to set  the correct resolution.
When I exit from attract mode windows 7 is shown in wrong resolution, the desktop is a distorted image.
I think the problem is that my old monitor is multisync and attract inherit windows resolution.

Does anybothy known how can I fix it?



Thanks for your time and your help

buttersoft

  • Trade Count: (+1)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 861
  • Last login:September 20, 2019, 04:28:11 am
  • Is running at 15kHz
AM is a particular culprit for grabbing modes it once used. It should run fine in 800x600, but IIRC there was never an option to set AM's resolution in a config file or commandline.

As a first step, trying stopping and disabling the windows service called AMD External Events Utility. Are you on AMD? Are you running crt_emudriver, or just running GM? If you have a compatible AMD card crt_emudriver would let you "talk" to your monitor via an emulated EDID. The Hantarex has no EDID of it's own. I suppose this could help. At any rate this is the only way i've been able to force AM to adopt the resolution i want it to.

You might also get better results changing the screenmode of AM between full, fit, windowed, etc.

If this fails, i'd see what parts of config files of AM you can delete. Maybe even re-install it - i.e delete everything and start again.