Main Restorations Software Audio/Jukebox/MP3 Everything Else Buy/Sell/Trade
Project Announcements Monitor/Video GroovyMAME Merit/JVL Touchscreen Meet Up Retail Vendors
Driving & Racing Woodworking Software Support Forums Consoles Project Arcade Reviews
Automated Projects Artwork Frontend Support Forums Pinball Forum Discussion Old Boards
Raspberry Pi & Dev Board controls.dat Linux Miscellaneous Arcade Wiki Discussion Old Archives
Lightguns Arcade1Up --- Bug Reports --- Site News

Unread posts | New Replies | Recent posts | Rules | Chatroom | Wiki | File Repository | RSS | Submit news

  

Author Topic: IPAC 2 - weird input failures  (Read 223 times)

0 Members and 1 Guest are viewing this topic.

hulkster

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 2382
  • Last login:June 05, 2019, 09:42:51 am
  • HulkaMAMEia is runnin' wild!
IPAC 2 - weird input failures
« on: June 04, 2019, 04:04:08 pm »
Have the USB version of the IPAC 2, and I'm having some weird issues from time to time.

---yes I've followed the troubleshooting guide---
---IPAC was donated from another co-worker and is a few years old.  it's possible it just needs cleaning.---

1st issue - controls worked great during testing and regular play, then all of a sudden, the left direction on P1 stopped working.  solid green light on the IPAC.  I opened up the IPAC program and it confirmed the up direction wasn't working.  I replaced the wire, cherry switch, and quick disconnect...no dice.  changed the terminal for the 1up input to 1A, and it worked fine.  i thought i was good to go.

2nd issue - randomly one day, left on player 2 quit working.  i did the same thing as above, and changed the inputs, etc and it worked for a while.

3rd issue - now up on player 1 isn't working again.

i've uninstalled the device in device manager, rebooted, etc.  do i just have a bum IPAC, or does it need to have some contact cleaner applied to it?  or could it be a USB power setting (Windows 10 fully patched)?

hulkster

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 2382
  • Last login:June 05, 2019, 09:42:51 am
  • HulkaMAMEia is runnin' wild!
Re: IPAC 2 - weird input failures
« Reply #1 on: June 05, 2019, 09:43:45 am »
disregard - contacts were corroded after sitting in a garage for 2 years.  finally put a flashlight on it and saw the disaster.  sprayed contact cleaner, good as new.

Zeosstud

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 390
  • Last login:Today at 04:48:42 pm
  • I want to build my own arcade controls!
Re: IPAC 2 - weird input failures
« Reply #2 on: June 05, 2019, 02:33:00 pm »
Great news.. Love the Ipac2, just learned the other day I could power a 5v light using connections in the expansion area.. :-)

Sent from my SM-G955U using Tapatalk