Main Restorations Software Audio/Jukebox/MP3 Everything Else Buy/Sell/Trade
Project Announcements Monitor/Video GroovyMAME Merit/JVL Touchscreen Meet Up Retail Vendors
Driving & Racing Woodworking Software Support Forums Consoles Project Arcade Reviews
Automated Projects Artwork Frontend Support Forums Pinball Forum Discussion Old Boards
Raspberry Pi & Dev Board controls.dat Linux Miscellaneous Arcade Wiki Discussion Old Archives
Lightguns Arcade1Up --- Bug Reports --- Site News

Unread posts | New Replies | Recent posts | Rules | Chatroom | Wiki | File Repository | RSS | Submit news

  

Author Topic: G07 monitor issue  (Read 633 times)

0 Members and 1 Guest are viewing this topic.

jamie.st

  • Trade Count: (0)
  • Jr. Member
  • **
  • Offline Offline
  • Posts: 6
  • Last login:May 14, 2019, 02:33:57 pm
  • I want to build my own arcade controls!
G07 monitor issue
« on: April 20, 2019, 05:46:48 pm »
Hi Iím looking for help on my main monitor board for a g07. It plays with sound but no video and I found on the board a bunch of resistors and things all burnt up. I see online you can buy capacitor kits but wondering what to do about the resistors and trying to test every component to see if it works. Can you get replacement boards or fix it all? Wondering on what steps to take. Pictures attached show burnt areas.

behrmr

  • Trade Count: (+1)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 427
  • Last login:Yesterday at 05:16:10 pm
Re: G07 monitor issue
« Reply #1 on: April 20, 2019, 09:49:47 pm »
That's a pretty normal looking (dirty) G07

Need to check if any fuses on the chassis are blown and go from there

Be careful if the small pigtail fuse is blow the large capacitor will still hold a charge and can bite you

What game is this out of?

I do rebuild these if you need to send it out (PM me)



jamie.st

  • Trade Count: (0)
  • Jr. Member
  • **
  • Offline Offline
  • Posts: 6
  • Last login:May 14, 2019, 02:33:57 pm
  • I want to build my own arcade controls!
Re: G07 monitor issue
« Reply #2 on: April 20, 2019, 09:56:42 pm »
Itís out of the game 1942. Was built in 1981 according to the inside. Just got the game from my wifeís father in law. Had it working for a awhile. Used it for half and hour at a time and unplugged because it was loud. We decided to play it lots one night for a couple hours. Screen went out after a long period of use.  All the fuses seem good so Iím trying to find other things to test on it. Read a few threads but not sure what to look for.