Main Restorations Software Audio/Jukebox/MP3 Everything Else Buy/Sell/Trade
Project Announcements Monitor/Video GroovyMAME Merit/JVL Touchscreen Meet Up Retail Vendors
Driving & Racing Woodworking Software Support Forums Consoles Project Arcade Reviews
Automated Projects Artwork Frontend Support Forums Pinball Forum Discussion Old Boards
Raspberry Pi & Dev Board controls.dat Linux Miscellaneous Arcade Wiki Discussion Old Archives
Lightguns Arcade1Up --- Bug Reports --- Site News

Unread posts | New Replies | Recent posts | Rules | Chatroom | Wiki | File Repository | RSS | Submit news

  

Author Topic: GM not saving rotation mame.ini settings.  (Read 471 times)

0 Members and 1 Guest are viewing this topic.

Rupert H

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 11
  • Last login:Today at 11:34:24 am
  • I want to build my own arcade controls!
GM not saving rotation mame.ini settings.
« on: February 06, 2019, 04:25:52 pm »
I'm having an issue with GroovyMAME 2.06 not saving my preferences for vertical games in the mame.ini file. I'm running it in a cab where I can rotate the screen 90 degrees for vertical games, so I've chosen to display the raw orientation and my ini setting are as below. When I change set these options the games display as intended (horizonal games displaying as normal while vertical games are rotated to fill the screen).

Code: [Select]
#
# CORE ROTATION OPTIONS
#
rotate                    0
ror                       0
rol                       0
autoror                   0
autorol                   0
flipx                     0
flipy                     0

However, as soon as I exit GroovyMAME and go back in to it, then view the settings from within GroovyMAME, the settings have reverted to the below.

Code: [Select]
#
# CORE ROTATION OPTIONS
#
rotate                    1
ror                       0
rol                       0
autoror                   1
autorol                   0
flipx                     0
flipy                     0

This occurs whether the options are changed by manually editing the ini file or through GroovyMAME, being sure to click on "save configuration" before exiting. I've checked the ini file before re-opening GroovyMAME and it still shows my saved options, but the moment I open MAME again and view either the ini file or the rotation options in MAME, they both show rotate and autoror enabled. despite me never changing them.

Any ideas?

buttersoft

  • Trade Count: (+1)
  • Full Member
  • ***
  • Online Online
  • Posts: 841
  • Last login:Today at 08:37:18 pm
  • Is running at 15kHz
Re: GM not saving rotation mame.ini settings.
« Reply #1 on: February 06, 2019, 11:07:51 pm »
There's also the monitor orientation option with the possible options horizontal, vertical, rotate_l and rotate_r? The last two only rotate for vertical games, IIRC. Or have those changed in MAME now?

Or maybe the VMM setup options for screen rotation.

krick

  • Trade Count: (+1)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 2000
  • Last login:August 18, 2019, 07:21:58 pm
  • Gotta have blue hair.
Hantarex Polo 15KHz
Sapphire Radeon HD 7750 2GB (GCN)
GroovyMAME 0.197.017h_d3d9ex
CRT Emudriver & CRT Tools 2.0 beta 13 (Crimson 16.2.1 for GCN cards)
Windows 7 Home Premium 64-bit
Intel Core i7-4790K @ 4.8GHz
ASUS Z87M-PLUS Motherboard

Rupert H

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 11
  • Last login:Today at 11:34:24 am
  • I want to build my own arcade controls!
Re: GM not saving rotation mame.ini settings.
« Reply #3 on: February 07, 2019, 09:34:10 am »
That thread was extremely helpful. I didn’t realise that GM had an “orientation “ option accessed through VM Maker. I’ve changed that to “rotate r” and now everything is displaying perfectly as intended. Thank you! MAME still seems to default it’s ini file to change to the second set of options that I posted, but it has no effect on the display so we’re all good.

Thanks again for the help. :-)