Main Restorations Software Audio/Jukebox/MP3 Everything Else Buy/Sell/Trade
Project Announcements Monitor/Video GroovyMAME Merit/JVL Touchscreen Meet Up Retail Vendors
Driving & Racing Woodworking Software Support Forums Consoles Project Arcade Reviews
Automated Projects Artwork Frontend Support Forums Pinball Forum Discussion Old Boards
Raspberry Pi & Dev Board controls.dat Linux Miscellaneous Arcade Wiki Discussion Old Archives
Lightguns Arcade1Up --- Bug Reports --- Site News

Unread posts | New Replies | Recent posts | Rules | Chatroom | Wiki | File Repository | RSS | Submit news

  

Author Topic: Injustice 2 double button press issue  (Read 411 times)

0 Members and 1 Guest are viewing this topic.

TheManuel

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 788
  • Last login:March 10, 2019, 02:11:05 pm
  • On and off hobbyist
Injustice 2 double button press issue
« on: August 23, 2018, 03:00:45 pm »
Hello, everyone.

I play Injustice 2 in my cab using the iPac interface, probably the very first or second one, as I bought it in 2001. For SFIV and its derivatives, I've always used the x360ce dll that Delusional posted.  For newer fighting games, I vjoy to convert keyboard inputs to DInput controller inputs, which the game sees as a joystick. This setup works perfectly well for MK10, Injustice GAU, UMVC3, SFV and MKKE. I've documented my experiences elsewhere in this forum but that method has been very reliable...

... until Injustice 2: everything seems to work fine until I press the light and heavy attack buttons simultaneously in order to execute a throw. Regardless of how careful I am with my timing, it never registers the throw. If I spam both buttons very rapidly, sometimes the throw is registered but it seldom does. A similar problem occurs when pressing light and medium attack for an environmental interaction where, first a light attack is registered, followed by the actual EI action. 

Sometimes shortly after restarting the aforementioned button presses register as they should but eventually the problem returns.  When I do the throw combination on an Xbox 360 controller, it works consistently. For my cab control panel, I have also tried doing yet another input conversion by employing x360ce to convert the DInput signals to XInput and disabling DInput support in the game's ini file. I thought this would fix it for sure but the same problem occurred.  I even tried the application recommended by the X-Arcade team to convert keyboard inputs from their CP's to xinput directly but to no avail.

While coming here to type this, I noticed that another user recently posted another keyboard to xinput conversion application so I'll give that a try tonight.  However, if anybody has experienced this same problem and found any solutions, please let me know.  This is a great game to have in a cab and the even the single player story mode is a blast.

Thanks in advance.
"The Manuel"