Main Restorations Software Audio/Jukebox/MP3 Everything Else Buy/Sell/Trade
Project Announcements Monitor/Video GroovyMAME Merit/JVL Touchscreen Meet Up Retail Vendors
Driving & Racing Woodworking Software Support Forums Consoles Project Arcade Reviews
Automated Projects Artwork Frontend Support Forums Pinball Forum Discussion Old Boards
Raspberry Pi & Dev Board controls.dat Linux Miscellaneous Arcade Wiki Discussion Old Archives
Lightguns Arcade1Up --- Bug Reports --- Site News

Unread posts | New Replies | Recent posts | Rules | Chatroom | Wiki | File Repository | RSS | Submit news


Author Topic: Mala and Mess  (Read 2159 times)

0 Members and 1 Guest are viewing this topic.


  • Trade Count: (0)
  • Jr. Member
  • **
  • Offline Offline
  • Posts: 1
  • Last login:January 06, 2017, 05:57:43 pm
  • I want to build my own arcade controls!
Mala and Mess
« on: January 06, 2017, 05:30:07 pm »
Just wanted to see if there's something easy I'm missing. I'm using Mala 1.74 with Mame on WinXP in an arcade cabinet with a SlikStik controller. I've played around with it now, and it works great. I wanted to try using some other emulators with the "Other Emu Config" tab in Mala. I've tried setting up command line Mess without any luck, but I've been able to get MessUI to work by itself (ie. outside of Mala) with Atari 2600 and Sega Megadrive roms. I can also get Kega Fusion to work inside of Mala using the "Other Emu Config" tab. But, when I try to run MessUI inside of Mala using the "Other Emulators" tab, it tries to open and then immediately closes. I tried using 3 different versions of MessUI (.081b, .0143u3b, and .181). They're in the same subfolder as Fusion (called C:Emulators/Programs). In the "Other Emu Config" tab, I directed Mala to the MessUI executable file, directed Mala to the ROMs path (Emulators/Programs/Messui/Software/Atari 2600 Roms), added "a26" for Atari and "bin" for Sega under "Rom extensions", and chose the preset Command Lines for Atari 2600 and Sega Megadrive. As I mentioned, Fusion works just fine as an additional emulator with Mala (and MessUi works fine outside of Mala too; I just can't get it to open inside of Mala). On all of the emulators (Fusion and MessUI), the games display in the Mala game list. When I'm in Fusion, I select a game, Fusion opens and runs it fine. But when I'm in MessUI, I select a game, I get the small black "Starting..." screen, the screen closes, I get the "closing program" sound, and nothing else happens. So I'm little stumped. Fusion works inside Mala. MessUI works by itself. But MessUI wont work inside Mala. Any thoughts?


  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 71
  • Last login:May 09, 2018, 10:03:23 pm
  • I want to build my own arcade controls!
Re: Mala and Mess
« Reply #1 on: January 20, 2017, 11:07:19 pm »
Interesting why you would run MessUI instead of Mess. I use MessUI to config Mess only. I call mess.exe (v119) with this command from MaLa and it works fine. Substitute EMU for your needs.

 EMU -cart "%path%\%rom%.%ext%" -skip_gameinfo -nonewui -window

Since it merged with MAME I also started using this for migration, for example. No issues found calling mame.exe.

 a7800 -window -resolution 640x480 -cart "%path%\%rom%.%ext%"

If you have problems, look in MaLa or MAME/Mess debug logs.