Main Restorations Software Audio/Jukebox/MP3 Everything Else Buy/Sell/Trade
Project Announcements Monitor/Video GroovyMAME Merit/JVL Touchscreen Meet Up Retail Vendors
Driving & Racing Woodworking Software Support Forums Consoles Project Arcade Reviews
Automated Projects Artwork Frontend Support Forums Pinball Forum Discussion Old Boards
Raspberry Pi & Dev Board controls.dat Linux Miscellaneous Arcade Wiki Discussion Old Archives
Lightguns Arcade1Up --- Bug Reports --- Site News

Unread posts | New Replies | Recent posts | Rules | Chatroom | Wiki | File Repository | RSS | Submit news

  

Author Topic: AimTrak Guns - can anyone see what is the issue?  (Read 164 times)

0 Members and 1 Guest are viewing this topic.

Arcade1980

  • Trade Count: (0)
  • Jr. Member
  • **
  • Offline Offline
  • Posts: 8
  • Last login:September 04, 2019, 10:06:53 am
  • I want to build my own arcade controls!
AimTrak Guns - can anyone see what is the issue?
« on: August 30, 2019, 07:50:30 am »
To assist with my ongoing issue of my Aimtrak guns not working after each startup(have to reconfig each time in Player1 Controls), I decided to do some more troubleshooting and did 3 steps to help me understand why :

1. Downloaded and configured Turnkey config and it created the Settings.ini file with the following entries

[Game Ports]
Port1=VID_D209&PID_1603&MI_01
Port2=VID_D209&PID_1604&MI_01

[Daemon Settings]
DaemonMode=FALSE
DaemonModeDelay=10

2. Using a Controlfile.cfg to ensure mapping of the AimTraks properly in my MAME.INI file

<mameconfig version="10">
    <system name = "default">
       <input>
          <mapdevice device="PID_1603" controller="GUNCODE_1" />
          <mapdevice device="PID_1604" controller="GUNCODE_2" />
          <mapdevice device="ATRAK Device #3" controller="JOYCODE_1" />
          <mapdevice device="ATRAK Device #4" controller="JOYCODE_2" />
       </input>
    </system>
</mameconfig>


3.  I ran the following command line MAME64 galaga -V >log.txt

Input: Adding mouse #1: HID-compliant mouse (device id: \\?\HID#VID_D209&PID_1603&MI_02#7&2d815e26&0&0000#{378de44c-56ef-11d1-bc8c-00a0c91405dd})
Input: Adding mouse #2: HID-compliant mouse (device id: \\?\HID#VID_D209&PID_1604&MI_02#7&253d5881&0&0000#{378de44c-56ef-11d1-bc8c-00a0c91405dd})
Input: Adding lightgun #1: HID-compliant mouse (device id: \\?\HID#VID_D209&PID_1603&MI_02#7&2d815e26&0&0000#{378de44c-56ef-11d1-bc8c-00a0c91405dd})
Input: Adding lightgun #2: HID-compliant mouse (device id: \\?\HID#VID_D209&PID_1604&MI_02#7&253d5881&0&0000#{378de44c-56ef-11d1-bc8c-00a0c91405dd})
Input: Adding joystick #0: ATRAK Device #3 (device id: ATRAK Device #3 product_1603d209-0000-0000-0000-504944564944 instance_64521280-b6bb-11e8-8002-444553540000)
Input: Adding joystick #1: ATRAK Device #4 (device id: ATRAK Device #4 product_1604d209-0000-0000-0000-504944564944 instance_64521280-b6bb-11e8-8004-444553540000)

What is Mouse #1/#2?  It's the same as Lightgun #1/#2

What I'm noticing is that the entries for "mouse #1 and #2" which I believe is the lightgun mouse gets randomly reassigned to mouse 1,2,3, or 4, so that it's inconsistent, which is causing my issue?. The Lightgun #1/#2 and Joystick #0/#1 remains consistent

Thoughts?

bperkins01

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 355
  • Last login:Yesterday at 04:10:03 pm
  • Plenty of skills.. gaining experience..
Re: AimTrak Guns - can anyone see what is the issue?
« Reply #1 on: August 30, 2019, 08:11:15 am »
Have you watched this?


I know he addresses this exact issue..
My Arcade Build and other projects here:
https://bperkins.wordpress.com/

Arcade1980

  • Trade Count: (0)
  • Jr. Member
  • **
  • Offline Offline
  • Posts: 8
  • Last login:September 04, 2019, 10:06:53 am
  • I want to build my own arcade controls!
Re: AimTrak Guns - can anyone see what is the issue?
« Reply #2 on: August 30, 2019, 08:19:58 am »
Yup, I did...thanks :)  Followed every instructions Maverick did.

Titchgamer

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 3399
  • Last login:Yesterday at 02:35:00 pm
  • I have a gaming addiction.....
Re: AimTrak Guns - can anyone see what is the issue?
« Reply #3 on: August 30, 2019, 05:40:38 pm »
Your problem is caused by the controller IDís changing.

The ATís have 2 IDs per gun if I remember right.
I think one for the mouse and 1 for the buttons? I dunno...

Anyways fix the IDs using Tur as covered in multiple threads and you should be golden.