Main Restorations Software Audio/Jukebox/MP3 Everything Else Buy/Sell/Trade
Project Announcements Monitor/Video GroovyMAME Merit/JVL Touchscreen Meet Up Retail Vendors
Driving & Racing Woodworking Software Support Forums Consoles Project Arcade Reviews
Automated Projects Artwork Frontend Support Forums Pinball Forum Discussion Old Boards
Raspberry Pi & Dev Board controls.dat Linux Miscellaneous Arcade Wiki Discussion Old Archives
Lightguns Arcade1Up --- Bug Reports --- Site News

Unread posts | New Replies | Recent posts | Rules | Chatroom | Wiki | File Repository | RSS | Submit news

  

Author Topic: Troubleshooting a WG 25k7191 no picture blowing fuse  (Read 1081 times)

0 Members and 1 Guest are viewing this topic.

grantspain

  • I personally prefer "bog trotter"
  • Trade Count: (+1)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 5989
  • Last login:Today at 02:44:21 pm
Re: Troubleshooting a WG 25k7191 no picture blowing fuse
« Reply #40 on: March 27, 2020, 06:22:22 pm »
locate the red gun pinon the crt socket  and short a bit of wire from that to a cap ground, if you screen goes bright red then gun is ok

joej85a

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 28
  • Last login:May 07, 2020, 07:16:12 pm
  • I want to build my own arcade controls!
Re: Troubleshooting a WG 25k7191 no picture blowing fuse
« Reply #41 on: March 27, 2020, 06:30:13 pm »
Well... WOOHOOO! the original board, with the new parts works! and RED is back! Man this is awesome  :cheers:

Now to start dialing it in, etc., but everything is working as expected.  My guess is that it was the grounded C37 that was the culprit.

BIG thanks to all you guys, for the vast knowledge and the super helpful posts.  Thanks guys!!!