Main Restorations Software Audio/Jukebox/MP3 Everything Else Buy/Sell/Trade
Project Announcements Monitor/Video GroovyMAME Merit/JVL Touchscreen Meet Up Retail Vendors
Driving & Racing Woodworking Software Support Forums Consoles Project Arcade Reviews
Automated Projects Artwork Frontend Support Forums Pinball Forum Discussion Old Boards
Raspberry Pi & Dev Board controls.dat Linux Miscellaneous Arcade Wiki Discussion Old Archives
Lightguns Arcade1Up --- Bug Reports --- Site News

Unread posts | New Replies | Recent posts | Rules | Chatroom | Wiki | File Repository | RSS | Submit news

  

Author Topic: Aimtrak Ligh Gun losing its recoil  (Read 4424 times)

0 Members and 1 Guest are viewing this topic.

magick81

  • Trade Count: (0)
  • Jr. Member
  • **
  • Offline Offline
  • Posts: 2
  • Last login:February 18, 2021, 10:12:04 pm
  • I want to build my own arcade controls!
Aimtrak Ligh Gun losing its recoil
« on: January 23, 2021, 04:02:58 am »
Hi all,
Am new to the scene to please forgive any noobishness I may display.

For Christmas I treated myself to the Aimtrak Light Gun. Unfortunately i didn't have much luck using it with my rpi4 Retropie.
So I switched to my PC and have been using it with MAME and Teknoparrot and I have been having an absolute blast of a good time.

But lately my gun isn't performing as it did when it was brand new. I noticed the recoil had stopped working. I have tried with different games on MAME and Teknoparrot. Even the calibration app, no recoil. Sometimes if I hold the gun at an angle I can get the recoil going again, and provided i keep it at that angle i can aim around that general area and keep the recoil.

I am no expert but it sounds like maybe some faulty or bad wiring. Can anyone tell me which wires to check? I'll have to see if i can find my multimeter in the meantime.

magick81

  • Trade Count: (0)
  • Jr. Member
  • **
  • Offline Offline
  • Posts: 2
  • Last login:February 18, 2021, 10:12:04 pm
  • I want to build my own arcade controls!
Re: Aimtrak Ligh Gun losing its recoil
« Reply #1 on: January 25, 2021, 01:28:12 am »
Wow. Nobody has any ideas?  :( :o ??? Guess I'll have to ask the manufacturer instead

Foxhole

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 287
  • Last login:June 22, 2022, 01:07:15 am
  • I want to build my own arcade controls!
Re: Aimtrak Ligh Gun losing its recoil
« Reply #2 on: January 25, 2021, 01:38:47 am »
Sounds like a wiring issue to me.
Probably the psu wire, try playing around with it and see if there's any difference.
If there is a change when you mess with the psu wire, then you'll probably be better off either replacing it or just finding the weak spot and fixing that.
« Last Edit: January 25, 2021, 01:42:26 am by Foxhole »

clhug

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 175
  • Last login:June 04, 2022, 08:19:57 am
Re: Aimtrak Ligh Gun losing its recoil
« Reply #3 on: February 15, 2021, 01:19:18 pm »
I've been wanting to post this question for a while, but did just now do some troubleshooting and got it working again on my own.  (Saw your question and was going to post that I also needed to help but decided to finally go look at it myself before posting, and just got lucky that I got it to work.)

I've had dual AimTracks w/ recoil using with MAME for about 5 or 6 years now.  The recoil worked great when I first got it, but I noticed about 2 years ago that the recoil only fired maybe 1/4 of the time, and half the time it did fire it was very weak.  The gun itself (the "lightgun" piece) still worked fine, it was only the recoil.

This happened with both guns.

I went into the AimTrack config software and tweaked the Recoil slider, reducing it some, and the recoil began working reliably again.  I noticed I had the Recoil slider all the way to the right.  I ended up lowering the setting.  With one gun I only needed to lower it by about 1/4 (so it was set AT about 3/4), but the other gun I needed to reduce down to a little under half.

Oddly, I can't find any mention of this Recoil slider in any of Ultimarc's documentation.  I guessed it was recoil force (like an internal voltage or current limiter to affect how hard the recoil "hits").  But I don't know.

Also of note, the Test button for the Recoil in the config software didn't fire the recoil either, after I got the slider adjusted to "fix" it while pulling the trigger on the gun itself, so I wouldn't necessarily trust that Test button.

I also swapped power supplies to see if affected what setting I needed on each gun, but it did not.

What I wonder is if the solenoid is getting weaker after a few years of use, but that is also only a guess.

Trnzaddict

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 170
  • Last login:January 25, 2022, 09:40:13 am
Re: Aimtrak Ligh Gun losing its recoil
« Reply #4 on: February 17, 2021, 08:44:04 pm »
Iím not sure the solenoids in the Aimtraks are very strong. I read here You canít even use them for rapid fire games like T2 or Rev X for more than like 15 minutes if not the solenoid will overheat and break permanently.

Thatís unbelievably weak.

clhug

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 175
  • Last login:June 04, 2022, 08:19:57 am
Re: Aimtrak Ligh Gun losing its recoil
« Reply #5 on: February 19, 2021, 05:23:29 pm »
Iím not sure the solenoids in the Aimtraks are very strong. I read here You canít even use them for rapid fire games like T2 or Rev X for more than like 15 minutes if not the solenoid will overheat and break permanently.

Thatís unbelievably weak.

For single-shot, I hadn't had any issues with them initially, and now that I have them readjusted with the software, they're working fine again.

I haven't really tried to use them with a game that would be rapid fire for an extended period, so I can't speak to that.