The NEW Build Your Own Arcade Controls

Software Support => GroovyMAME => Topic started by: querschnitt on April 18, 2019, 03:34:35 pm

Title: how to use portaudio?
Post by: querschnitt on April 18, 2019, 03:34:35 pm
hey everyone!

Can someone please link me to a tutorial that explains how to use portaudio ? I'm not sure what I should put in my mameconfig
Title: Re: how to use portaudio?
Post by: schmerzkaufen on April 22, 2019, 05:42:28 pm
Wondered about the same thing some time ago and here's compiled what I've gathered;

Quote
- Make a log, you will see the supported devices and APIs. However, the easiest way is to define the API and latency to use. The default device of the selected API is then used.
- WDM-KS should be the best option, which is _slightly_ better than WASAPI. MME is ancient, but actually seems to provide better latency than DirectSound under some circumstances on modern Windows systems, at least on my test rigs.
- Regarding safe ranges - if everything works as it should, WASAPI/0.003334 or WDM-KS/0.001 should be safe.
- When the API cannot use the specified latency, PA reverts to the default.
- One thing to keep in mind with low-latency audio is that it is important to have as few other applications running when using it. For instance, only have MAME running, and if problems are encountered, try using -nosleep and -priority 1.

couple examples below
___________________________________________________

# OSD SOUND OPTIONS
#
sound                        portaudio
audio_latency             1

#
# PORTAUDIO OPTIONS
#
pa_api                      Windows WDM-KS
pa_device                  none or default or "device name"
pa_latency                 0.001
______________________________________________________

# OSD SOUND OPTIONS
#
sound                        portaudio
audio_latency             1

#
# PORTAUDIO OPTIONS
#
pa_api                      Windows WASAPI
pa_device                  none or default or "device name"
pa_latency                 0.003334