The NEW Build Your Own Arcade Controls

Software Support => GroovyMAME => Topic started by: DentonClone on August 21, 2017, 02:30:43 am

Title: RetroArch Vulkan Problem
Post by: DentonClone on August 21, 2017, 02:30:43 am
First off, a big thanks to Calamity for developing CRT Emudriver and providing such amazing support.

After getting my CRT Emudriver 2.0/GroovyMAME Arcade PC working I thought I'd see if I could get that wonderful CRT goodness working with RetroArch. Sure enough after some configuration from this thread: http://forum.arcadecontrols.com/index.php?topic=138062.40 (http://forum.arcadecontrols.com/index.php?topic=138062.40) it's running beautifully.

The problem I'm having though is with the Vulkan renderer. I'm hoping to use it specifically for PS1 games and the Beetle PSX HW core's PGXP features. The problem is unless I'm on the latest drivers RetroArch won't start. That's a problem since the CRT Emudriver is based on an older driver version.

I've installed the Vulkan runtime separately as suggested in this thread: http://forum.arcadecontrols.com/index.php?topic=154557.0 (http://forum.arcadecontrols.com/index.php?topic=154557.0) According to a view tools I've found Vulkan is indeed installed and can run properly.

I'm unsure if it's the driver itself or a combination of the current card I'm using and the old drivers. Unfortunately I don't have a newer Radeon card on hand to test the idea.

The card I'm using is a Radeon HD 7700 which is the oldest card with Vulkan support. Would updating to a newer card possibly get this setup working or would it be all in the drivers?
Title: Re: RetroArch Vulkan Problem
Post by: Calamity on August 22, 2017, 01:05:12 pm
I can't help you with this right now. In a few months hopefully I'll have time for an updated release of the Emudriver. In the meantime you can try using latest official driver and Pakoman's method for GM without CRT Emudriver (search the forum). You'll probably mess the GM side of your setup, so unless PSX is so so important to you right now I'd wait for the new release.
Title: Re: RetroArch Vulkan Problem
Post by: Ya Dad on September 22, 2017, 01:21:03 pm
Good thing I found this thread. I was excited to try the ParaLLEl n64 core with RetroArch in 15khz 240p on my SD CRT with EmuDriver and was about to follow that same thread you found about installing the Vulcan drivers separately. Glad I didn't now. We'll just have to wait for the next version of CRT EmuDriver.
Title: Re: RetroArch Vulkan Problem
Post by: BahnYuki on January 24, 2019, 02:59:44 pm
Has this been addressed? I just picked up a R7 250 and it supposedly has Vulkan support in Crimson drivers 16.3 onward. Unfortunately the CRTEmudriver is based on 16.2.1 which makes Vulkan unusable on my GPU. If there is an updated driver please let me know because I've don't some searching on this site and the official site and have yet to see an update to the driver itself.